aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2015-02-10 04:44:13 +0800
committermadpilot <madpilot@FreeBSD.org>2015-02-10 04:44:13 +0800
commit4ba1184ec8fb7ee6689ef3cc0b715b1c584067aa (patch)
tree9ac324c9ac92c64f61329c60c6701a5aaf5497d4 /multimedia
parentbfa40ccc4c20ffb9db717eae10f50087b8bd8759 (diff)
downloadfreebsd-ports-gnome-4ba1184ec8fb7ee6689ef3cc0b715b1c584067aa.tar.gz
freebsd-ports-gnome-4ba1184ec8fb7ee6689ef3cc0b715b1c584067aa.tar.zst
freebsd-ports-gnome-4ba1184ec8fb7ee6689ef3cc0b715b1c584067aa.zip
Avoid a build error with clang on certain configurations.
PR: 197405 Submitted by: Kevin Zheng <kevinz5000@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libva/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/multimedia/libva/Makefile b/multimedia/libva/Makefile
index 3aff8afacc4e..bce0d3eb79ea 100644
--- a/multimedia/libva/Makefile
+++ b/multimedia/libva/Makefile
@@ -21,10 +21,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=va
USE_LDCONFIG= yes
-CPPFLAGS+= -isystem${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
# prevent types conflict: videodev2.h vs. drm.h
-CFLAGS+= -DHAVE_LINUX_INTEGER_TYPES
+CFLAGS+= -I${LOCALBASE}/include -DHAVE_LINUX_INTEGER_TYPES
OPTIONS_DEFINE= DEBUG