aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-03-27 03:23:13 +0800
committernox <nox@FreeBSD.org>2011-03-27 03:23:13 +0800
commit86683161b0ae8f710c57e365f432f941299e8ba6 (patch)
tree94784e930cc1c32d3f65546d1cd42ec199be3b00 /multimedia
parent10b47f9d058c282b3e2810bf73e136c50418b17b (diff)
downloadfreebsd-ports-gnome-86683161b0ae8f710c57e365f432f941299e8ba6.tar.gz
freebsd-ports-gnome-86683161b0ae8f710c57e365f432f941299e8ba6.tar.zst
freebsd-ports-gnome-86683161b0ae8f710c57e365f432f941299e8ba6.zip
Preliminary port of the vdr development branch, use at your own risk! :)
This is just a metaport that lets you select the plugins you want to install. See vdr/webcamd dvb thread(s) on the freebsd-multimedia list for FreeBSD notes, some links are here: http://people.freebsd.org/~nox/dvb/ and see these links for general vdr info: http://www.linuxtv.org/vdrwiki/index.php/Main_Page http://www.vdr-portal.de/ WWW: http://www.tvdr.de/
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/vdr-plugins/Makefile87
-rw-r--r--multimedia/vdr-plugins/pkg-descr16
3 files changed, 104 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 62709e5ef1ae..67a3a4539ef6 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -349,6 +349,7 @@
SUBDIR += vdr-plugin-upnp
SUBDIR += vdr-plugin-vnsiserver
SUBDIR += vdr-plugin-xineliboutput
+ SUBDIR += vdr-plugins
SUBDIR += vic
SUBDIR += vlc
SUBDIR += vodcatcher
diff --git a/multimedia/vdr-plugins/Makefile b/multimedia/vdr-plugins/Makefile
new file mode 100644
index 000000000000..9ee5fa29d7c8
--- /dev/null
+++ b/multimedia/vdr-plugins/Makefile
@@ -0,0 +1,87 @@
+# New ports collection makefile for: vdr
+# Date created: Sun Oct 17 21:15:34 CEST 2010
+# Whom: Juergen Lock <nox@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vdr-plugins
+PORTVERSION= 1.7.17
+PORTREVISION= 1
+CATEGORIES= multimedia
+MASTER_SITES= # none
+DISTFILES= # none
+EXTRACT_ONLY= # none
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Video Disk Recorder - plugin metaport
+
+NO_BUILD= yes
+
+OPTIONS= CONTROL "telnet control" On \
+ EPGSEARCH "EPG search" On \
+ FEMON "frontend monitor" On \
+ INFOSATEPG "infosat EPG data via satellite" On \
+ IPTV "IP television" On \
+ OSDPIP "picture-in-picture" On \
+ OSDTELETEXT "OSD teletext" On \
+ REMOTE "non-lirc remote control (experimental)" On \
+ SKINENIGMANG "Enigma-NG skin" On \
+ STREAMDEV "stream device (server and client)" On \
+ XINELIBOUTPUT "xineliboutput plugin/viewer" On \
+ LIVE "live web plugin" On \
+ UPNP "UPnP/DLNA plugin (alpha!)" On \
+ VNSISERVER "VNSI server (for xbmc pvr branch - untested)" Off \
+ SOFTDEVICE "softdevice (broken?)" Off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_CONTROL)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-control.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-control
+.endif
+.if defined(WITH_EPGSEARCH)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-epgsearch.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-epgsearch
+.endif
+.if defined(WITH_FEMON)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-femon.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-femon
+.endif
+.if defined(WITH_INFOSATEPG)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-infosatepg.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-infosatepg
+.endif
+.if defined(WITH_IPTV)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-iptv.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-iptv
+.endif
+.if defined(WITH_OSDPIP)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-osdpip.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-osdpip
+.endif
+.if defined(WITH_OSDTELETEXT)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-osdteletext.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-osdteletext
+.endif
+.if defined(WITH_REMOTE)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-remote.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-remote
+.endif
+.if defined(WITH_SKINENIGMANG)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-skinenigmang.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-skinenigmang
+.endif
+.if defined(WITH_STREAMDEV)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-streamdev-server.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-streamdev
+.endif
+.if defined(WITH_XINELIBOUTPUT)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-xineliboutput.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-xineliboutput
+.endif
+.if defined(WITH_LIVE)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-live.so.${PORTVERSION}:${PORTSDIR}/www/vdr-plugin-live
+.endif
+.if defined(WITH_UPNP)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-upnp.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-upnp
+.endif
+.if defined(WITH_SOFTDEVICE)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-softdevice.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-softdevice
+.endif
+.if defined(WITH_VNSISERVER)
+RUN_DEPENDS+= ${LOCALBASE}/lib/vdr/libvdr-vnsiserver.so.${PORTVERSION}:${PORTSDIR}/multimedia/vdr-plugin-vnsiserver
+.endif
+
+do-install: # empty
+
+.include <bsd.port.mk>
diff --git a/multimedia/vdr-plugins/pkg-descr b/multimedia/vdr-plugins/pkg-descr
new file mode 100644
index 000000000000..7a2534053e96
--- /dev/null
+++ b/multimedia/vdr-plugins/pkg-descr
@@ -0,0 +1,16 @@
+Preliminary port of the vdr development branch, use at your own risk! :)
+
+This is just a metaport that lets you select the plugins you want to
+install.
+
+See vdr/webcamd dvb thread(s) on the freebsd-multimedia list for FreeBSD
+notes, some links are here:
+
+ http://people.freebsd.org/~nox/dvb/
+
+and see these links for general vdr info:
+
+ http://www.linuxtv.org/vdrwiki/index.php/Main_Page
+ http://www.vdr-portal.de/
+
+WWW: http://www.tvdr.de/