aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-02-15 21:19:19 +0800
committermiwi <miwi@FreeBSD.org>2009-02-15 21:19:19 +0800
commit8bc3b5be4df68b2d443331adb9d3535cf00c3339 (patch)
tree137c24c4f39dd1e51fe0d7f885e0c859c1ee639d /multimedia
parentd997a0ee3ce60303b7fa6d997d9f59608298c4f8 (diff)
downloadfreebsd-ports-gnome-8bc3b5be4df68b2d443331adb9d3535cf00c3339.tar.gz
freebsd-ports-gnome-8bc3b5be4df68b2d443331adb9d3535cf00c3339.tar.zst
freebsd-ports-gnome-8bc3b5be4df68b2d443331adb9d3535cf00c3339.zip
clive-utils contains additional utilities that can be used together with
clive(1) (Historically, these utilities were part of clive(1) 1.x and were written in Python/Newt; they have now been rewritten in Perl/Tk to replace the features that were removed in clive 2.0): -clivefeed(1), a utility that parses RSS feeds containing video page links and uses clive(1) to extract them; -clivescan(1), a utility that scans video pages for video links and uses clive(1) to extract them; and -clivepass(1), a utility that can be used to create and change passwords for websites used by clive(1). The passwords are encrypted and saved along with the username information. Access is restricted by using a global passphrase. WWW: http://code.google.com/p/clive-utils/ PR: ports/131481 Submitted by: bf <bf2006a at yahoo.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/clive-utils/Makefile60
-rw-r--r--multimedia/clive-utils/distinfo3
-rw-r--r--multimedia/clive-utils/pkg-descr17
4 files changed, 81 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 45d2de04a00f..d97ed10bcb6d 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -20,6 +20,7 @@
SUBDIR += cclive
SUBDIR += cheese
SUBDIR += clive
+ SUBDIR += clive-utils
SUBDIR += clive1
SUBDIR += clutter-gst
SUBDIR += cx88
diff --git a/multimedia/clive-utils/Makefile b/multimedia/clive-utils/Makefile
new file mode 100644
index 000000000000..c1229a087dbd
--- /dev/null
+++ b/multimedia/clive-utils/Makefile
@@ -0,0 +1,60 @@
+# Ports collection makefile for: clive-utils
+# Date created: 7 February 2009
+# Whom: bf <bf2006a@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clive-utils
+PORTVERSION= 2.1.2
+CATEGORIES= multimedia net perl5
+MASTER_SITES= GOOGLE_CODE
+DIST_SUBDIR= clive
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Passwords, RSS parsing, and link extraction for clive
+
+USE_PERL5_RUN= 5.8.2+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+RUN_DEPENDS+= clive>=2.0:${PORTSDIR}/multimedia/clive \
+ p5-Crypt-PasswdMD5>=1.3:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+ p5-Crypt-Twofish>=2.12:${PORTSDIR}/security/p5-Crypt-Twofish \
+ p5-XML-RSS-LibXML>=0.30.02:${PORTSDIR}/textproc/p5-XML-RSS-LibXML \
+ p5-HTML-Strip>=1.06:${PORTSDIR}/www/p5-HTML-Strip \
+ p5-Tk>=804.028.501:${PORTSDIR}/x11-toolkits/p5-Tk
+
+PLIST_FILES= bin/clivefeed bin/clivepass bin/clivescan
+
+OPTIONS= PASTE "Enable pasting of URLs from X clipboard" Off \
+ FONTDIALOG "Enable Font Dialog support" Off
+
+.include <bsd.port.pre.mk>
+
+.ifdef WITH_PASTE
+RUN_DEPENDS+= p5-Clipboard>=0.09:${PORTSDIR}/x11/p5-Clipboard
+.endif
+
+.ifdef WITH_FONTDIALOG
+RUN_DEPENDS+= p5-Tk-FontDialog>=0.15:${PORTSDIR}/x11-toolkits/p5-Tk-FontDialog
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|clivescan -S|clivescan -n|g' ${WRKSRC}/*.1
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ for suffix in feed pass scan ; do \
+ ${INSTALL_SCRIPT} ${WRKSRC}/clive$$suffix ${PREFIX}/bin ; \
+ done
+
+.ifndef NO_INSTALL_MANPAGES
+MAN1= clivefeed.1 clivepass.1 clivescan.1
+MANCOMPRESSED= no
+post-install:
+ ${MKDIR} ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/*.1 ${MANPREFIX}/man/man1
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/clive-utils/distinfo b/multimedia/clive-utils/distinfo
new file mode 100644
index 000000000000..dcb79d3800ab
--- /dev/null
+++ b/multimedia/clive-utils/distinfo
@@ -0,0 +1,3 @@
+MD5 (clive/clive-utils-2.1.2.tar.bz2) = 37e32689e2d534aa46b2c8bfd44c1eb8
+SHA256 (clive/clive-utils-2.1.2.tar.bz2) = 59b325b45b1c4b2ee85c4aeaa20aa35048b2e5a720bf91b2fe375a220bd34484
+SIZE (clive/clive-utils-2.1.2.tar.bz2) = 18482
diff --git a/multimedia/clive-utils/pkg-descr b/multimedia/clive-utils/pkg-descr
new file mode 100644
index 000000000000..29d2594eef2e
--- /dev/null
+++ b/multimedia/clive-utils/pkg-descr
@@ -0,0 +1,17 @@
+clive-utils contains additional utilities that can be used together with
+clive(1) (Historically, these utilities were part of clive(1) 1.x and were
+written in Python/Newt; they have now been rewritten in Perl/Tk to replace
+the features that were removed in clive 2.0):
+
+-clivefeed(1), a utility that parses RSS feeds containing video page links
+ and uses clive(1) to extract them;
+
+-clivescan(1), a utility that scans video pages for video links and uses
+ clive(1) to extract them; and
+
+-clivepass(1), a utility that can be used to create and change passwords
+ for websites used by clive(1). The passwords are encrypted and
+ saved along with the username information. Access is restricted
+ by using a global passphrase.
+
+WWW: http://code.google.com/p/clive-utils/