aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-02-13 21:26:41 +0800
committermiwi <miwi@FreeBSD.org>2011-02-13 21:26:41 +0800
commit8c08438323fa2dd9003cb682663f41ccf0771b11 (patch)
treed13883f63c44be6cc9c7a5a7fae2e0172b5dd23e /multimedia
parentcf35c87626fb4054c6b378b35654545489cd99e1 (diff)
downloadfreebsd-ports-gnome-8c08438323fa2dd9003cb682663f41ccf0771b11.tar.gz
freebsd-ports-gnome-8c08438323fa2dd9003cb682663f41ccf0771b11.tar.zst
freebsd-ports-gnome-8c08438323fa2dd9003cb682663f41ccf0771b11.zip
Python bindings for the MLT framework.
MLT is an open source multimedia framework, designed and developed for television broadcasting. It provides a toolkit for broadcasters, video editors, media players, transcoders, web streamers and many more types of applications. The functionality of the system is provided via an assortment of ready to use tools, XML authoring components, and an extensible plug-in based API. WWW: http://www.mltframework.org PR: ports/154565 Submitted by: Charlie Kester <corky1951 at comcast.net>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/py-mlt/Makefile38
-rw-r--r--multimedia/py-mlt/distinfo2
-rw-r--r--multimedia/py-mlt/pkg-descr10
4 files changed, 51 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index fe8b4ddaab5d..749873fb501c 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -262,6 +262,7 @@
SUBDIR += py-kaa-base
SUBDIR += py-kaa-imlib2
SUBDIR += py-kaa-metadata
+ SUBDIR += py-mlt
SUBDIR += py-openlp
SUBDIR += py-pybmp
SUBDIR += py-qt4-multimedia
diff --git a/multimedia/py-mlt/Makefile b/multimedia/py-mlt/Makefile
new file mode 100644
index 000000000000..8260f230606f
--- /dev/null
+++ b/multimedia/py-mlt/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: mlt
+# Date created: 2011-02-06
+# Whom: Charlie Kester <corky1951@comcast.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mlt
+PORTVERSION= 0.6.0
+CATEGORIES= multimedia python
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= corky1951@comcast.net
+COMMENT= Python bindings for the MLT multimedia framework
+
+BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
+LIB_DEPENDS= mlt.3:${PORTSDIR}/multimedia/mlt
+
+USE_PYTHON= yes
+
+LICENSE= GPLv2
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/_mlt.so \
+ %%PYTHON_SITELIBDIR%%/mlt.py
+
+do-build:
+ (cd ${WRKSRC}/src/swig && \
+ swig -c++ -I${LOCALBASE}/include/mlt -I${LOCALBASE}/include/mlt++ -python mlt.i && \
+ g++ -fPIC -D_GNU_SOURCE -c -rdynamic -pthread -I${LOCALBASE}/include -I${LOCALBASE}/include/mlt -I${PYTHON_INCLUDEDIR} mlt_wrap.cxx && \
+ g++ -shared mlt_wrap.o -L${LOCALBASE}/lib -lmlt++ -o _mlt.so)
+
+do-install:
+ ${INSTALL_LIB} ${WRKSRC}/src/swig/_mlt.so ${PYTHONPREFIX_SITELIBDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/swig/mlt.py ${PYTHONPREFIX_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/multimedia/py-mlt/distinfo b/multimedia/py-mlt/distinfo
new file mode 100644
index 000000000000..287f58fa3a3b
--- /dev/null
+++ b/multimedia/py-mlt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mlt-0.6.0.tar.gz) = 91a0d916a39f03b437192a6e0c34354996458a8892ce0c91740c9881ea14746e
+SIZE (mlt-0.6.0.tar.gz) = 860173
diff --git a/multimedia/py-mlt/pkg-descr b/multimedia/py-mlt/pkg-descr
new file mode 100644
index 000000000000..99e6c5519c39
--- /dev/null
+++ b/multimedia/py-mlt/pkg-descr
@@ -0,0 +1,10 @@
+Python bindings for the MLT framework.
+
+MLT is an open source multimedia framework, designed and developed for
+television broadcasting. It provides a toolkit for broadcasters, video
+editors, media players, transcoders, web streamers and many more types
+of applications. The functionality of the system is provided via an
+assortment of ready to use tools, XML authoring components, and an
+extensible plug-in based API.
+
+WWW: http://www.mltframework.org