aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-02-11 00:17:40 +0800
committerarved <arved@FreeBSD.org>2004-02-11 00:17:40 +0800
commit9d03993f786499ab1fe50ec474984b998a17aee6 (patch)
tree2ff3618900aaa0292733a8331769506785fa73da /multimedia
parentfb0fb4992d8900cc842dfd0c7ae0c8373c15400e (diff)
downloadfreebsd-ports-gnome-9d03993f786499ab1fe50ec474984b998a17aee6.tar.gz
freebsd-ports-gnome-9d03993f786499ab1fe50ec474984b998a17aee6.tar.zst
freebsd-ports-gnome-9d03993f786499ab1fe50ec474984b998a17aee6.zip
Fix build on AMD64
Submitted by: lioux, Adriaan de Groot <adridg@cs.kun.nl>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libmpeg2/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/multimedia/libmpeg2/Makefile b/multimedia/libmpeg2/Makefile
index c97f817b2c2e..73e1d07cc0ed 100644
--- a/multimedia/libmpeg2/Makefile
+++ b/multimedia/libmpeg2/Makefile
@@ -66,6 +66,11 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|<SDL/|<SDL11/|' ${WRKSRC}/libvo/*
@${REINPLACE_CMD} -e 's|-O3||;s|<termio.h>|<termios.h>|' ${WRKSRC}/configure
+# AMD64 prefers position independent code
+.if ${MACHINE_ARCH:L} == "amd64"
+ @${REINPLACE_CMD} -e 's|-prefer-non-pic||' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
@${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
${WRKSRC}/libmpeg2/Makefile.in