aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-08-18 02:00:41 +0800
committerpawel <pawel@FreeBSD.org>2012-08-18 02:00:41 +0800
commita2aa7e6c7beef771f85ba2120bfb9b149bc67aa0 (patch)
tree8487962347b9188617d4e1646ae23d5a8353d26a /multimedia
parent90c6f1a6e02f23c0ddb903793761815278394eb7 (diff)
downloadfreebsd-ports-gnome-a2aa7e6c7beef771f85ba2120bfb9b149bc67aa0.tar.gz
freebsd-ports-gnome-a2aa7e6c7beef771f85ba2120bfb9b149bc67aa0.tar.zst
freebsd-ports-gnome-a2aa7e6c7beef771f85ba2120bfb9b149bc67aa0.zip
- Update to version 1.6.3
- Add missing deps - Sort and remove ABI versions from LIB_DEPENDS - Port needs USE_PKGCONFIG=build
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/lives/Makefile35
-rw-r--r--multimedia/lives/distinfo4
-rw-r--r--multimedia/lives/files/patch-src__plugins.h12
-rw-r--r--multimedia/lives/pkg-plist2
4 files changed, 32 insertions, 21 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index 7b9cdcd90c70..57ee0c4f41d8 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lives
-PORTVERSION= 1.6.2
-PORTREVISION= 1
+PORTVERSION= 1.6.3
CATEGORIES= multimedia
MASTER_SITES= http://salsaman.home.xs4all.nl/lives/current/
DISTNAME= LiVES-${PORTVERSION}
@@ -18,16 +17,30 @@ COMMENT= Video editing system
LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:${PORTSDIR}/multimedia/v4l_compat
-LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
+LIB_DEPENDS= asound:${PORTSDIR}/audio/alsa-lib \
+ jack:${PORTSDIR}/audio/jack \
+ ogg:${PORTSDIR}/audio/libogg \
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ pulse:${PORTSDIR}/audio/pulseaudio \
oil-0.3.0:${PORTSDIR}/devel/liboil \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ orc-0.4:${PORTSDIR}/devel/orc \
+ pcre:${PORTSDIR}/devel/pcre \
+ aa:${PORTSDIR}/graphics/aalib \
+ cairo:${PORTSDIR}/graphics/cairo \
visual-0.4.0:${PORTSDIR}/graphics/libvisual04 \
- dv.4:${PORTSDIR}/multimedia/libdv \
- theora.0:${PORTSDIR}/multimedia/libtheora \
+ png15:${PORTSDIR}/graphics/png \
+ avcodec:${PORTSDIR}/multimedia/ffmpeg \
+ dv:${PORTSDIR}/multimedia/libdv \
+ theora:${PORTSDIR}/multimedia/libtheora \
+ vpx:${PORTSDIR}/multimedia/libvpx \
mjpegutils-2.0.0:${PORTSDIR}/multimedia/mjpegtools \
- pulse:${PORTSDIR}/audio/pulseaudio \
schroedinger-1.0:${PORTSDIR}/multimedia/schroedinger \
- asound:${PORTSDIR}/audio/alsa-lib \
- avcodec:${PORTSDIR}/multimedia/ffmpeg
+ xvidcore:${PORTSDIR}/multimedia/xvid \
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123 \
sox:${PORTSDIR}/audio/sox \
ogg123:${PORTSDIR}/audio/vorbis-tools \
@@ -45,13 +58,17 @@ WRKSRC= ${WRKDIR}/${DISTNAME:L}
USE_BZIP2= yes
USE_LDCONFIG= yes
-USE_GNOME= gtk20 gnomehack
+USE_ICONV= yes
+USE_GNOME= gtk20 gnomehack gdkpixbuf2
USE_SDL= sdl
USE_PYTHON= yes
USE_PERL5= yes
USE_CDRTOOLS= yes
USE_GHOSTSCRIPT_RUN= yes
GNU_CONFIGURE= yes
+USE_PKGCONFIG= build
+USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext xfixes \
+ xi xinerama xrandr xrender
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --disable-ldvgrab
diff --git a/multimedia/lives/distinfo b/multimedia/lives/distinfo
index 6c1ccb609262..c0b87eb1cffe 100644
--- a/multimedia/lives/distinfo
+++ b/multimedia/lives/distinfo
@@ -1,2 +1,2 @@
-SHA256 (LiVES-1.6.2.tar.bz2) = 39135d7d79a357f70b340fc1ad34f4c1dccc51e1d34577810d525c8cc134efc1
-SIZE (LiVES-1.6.2.tar.bz2) = 3491550
+SHA256 (LiVES-1.6.3.tar.bz2) = eab661d85d538ea5a21224b437d7c3d85ad930998210dda2644c9c381124f92a
+SIZE (LiVES-1.6.3.tar.bz2) = 3492971
diff --git a/multimedia/lives/files/patch-src__plugins.h b/multimedia/lives/files/patch-src__plugins.h
index e5613213dd11..a73e8d75facb 100644
--- a/multimedia/lives/files/patch-src__plugins.h
+++ b/multimedia/lives/files/patch-src__plugins.h
@@ -1,5 +1,5 @@
---- ./src/plugins.h.orig 2012-06-25 19:44:08.000000000 +0200
-+++ ./src/plugins.h 2012-06-25 19:46:11.000000000 +0200
+--- src/plugins.h.orig 2012-08-17 16:05:34.000000000 +0200
++++ src/plugins.h 2012-08-17 16:10:09.000000000 +0200
@@ -12,7 +12,7 @@
#include <string.h>
#include <fcntl.h>
@@ -9,11 +9,3 @@
// generic plugins
-@@ -36,7 +36,6 @@
- GList *plugin_request_by_space (const gchar *plugin_type, const gchar *plugin_name, const gchar *request);
- GList *plugin_request_common (const gchar *plugin_type, const gchar *plugin_name, const gchar *request, const gchar *delim, gboolean allow_blanks);
-
--typedef weed_plant_t *(*weed_bootstrap_f) (weed_default_getter_f *value, int num_versions, int *plugin_versions);
-
- /// video playback plugins
- typedef gboolean (*plugin_keyfunc) (gboolean down, guint16 unicode, guint16 keymod);
diff --git a/multimedia/lives/pkg-plist b/multimedia/lives/pkg-plist
index 15a156264e28..90afd9d63ed7 100644
--- a/multimedia/lives/pkg-plist
+++ b/multimedia/lives/pkg-plist
@@ -145,6 +145,8 @@ lib/lives/plugins/effects/realtime/weed/tone_gen.la
lib/lives/plugins/effects/realtime/weed/tone_gen.so
lib/lives/plugins/effects/realtime/weed/tvpic.la
lib/lives/plugins/effects/realtime/weed/tvpic.so
+lib/lives/plugins/effects/realtime/weed/vector_visualiser.la
+lib/lives/plugins/effects/realtime/weed/vector_visualiser.so
lib/lives/plugins/effects/realtime/weed/vertigo.la
lib/lives/plugins/effects/realtime/weed/vertigo.so
lib/lives/plugins/effects/realtime/weed/videowall.la