aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2010-10-25 14:18:51 +0800
committervanilla <vanilla@FreeBSD.org>2010-10-25 14:18:51 +0800
commitbfa4c68e5b2ae5b384485624c4b5dad18b6a997e (patch)
tree72854b818b63c8447315349606b339a31e423efb /multimedia
parent4b56891ea1c6443f8fa7cc81a29809a43290074e (diff)
downloadfreebsd-ports-gnome-bfa4c68e5b2ae5b384485624c4b5dad18b6a997e.tar.gz
freebsd-ports-gnome-bfa4c68e5b2ae5b384485624c4b5dad18b6a997e.tar.zst
freebsd-ports-gnome-bfa4c68e5b2ae5b384485624c4b5dad18b6a997e.zip
Add mkclean 0.6.0, clean and optimize Matroska and WebM files.
PR: ports/151679 Submitted by: Peter Johnson <johnson.peter at gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/mkclean/Makefile33
-rw-r--r--multimedia/mkclean/distinfo3
-rw-r--r--multimedia/mkclean/files/patch-file_libc.c11
-rw-r--r--multimedia/mkclean/files/patch-root.proj10
-rw-r--r--multimedia/mkclean/pkg-descr11
6 files changed, 69 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 65fd12413e2b..f534c4eea331 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -190,6 +190,7 @@
SUBDIR += minitube
SUBDIR += miro
SUBDIR += mjpegtools
+ SUBDIR += mkclean
SUBDIR += mkvtoolnix
SUBDIR += mkxvcd
SUBDIR += mlt
diff --git a/multimedia/mkclean/Makefile b/multimedia/mkclean/Makefile
new file mode 100644
index 000000000000..2500fe7d9f6a
--- /dev/null
+++ b/multimedia/mkclean/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mkclean
+# Date created: 2010-10-24
+# Whom: Peter Johnson <johnson.peter@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mkclean
+PORTVERSION= 0.6.0
+CATEGORIES= multimedia
+MASTER_SITES= SF/matroska/${PORTNAME}
+
+MAINTAINER= johnson.peter@gmail.com
+COMMENT= Clean and optimize Matroska and WebM files
+
+USE_BZIP2= yes
+USE_ICONV= yes
+USE_GMAKE= yes
+
+HAS_CONFIGURE= yes
+MAKE_ENV+= CCFLAGS="-I${LOCALBASE}/include" \
+ LFLAGS="-L${LOCALBASE}/lib -liconv"
+
+MAKEFILE= GNUmakefile
+
+PLIST_FILES= bin/mkclean bin/mkWDclean bin/mkvtree
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/release/*/mkclean ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/release/*/mkWDclean ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/release/*/mkvtree ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/multimedia/mkclean/distinfo b/multimedia/mkclean/distinfo
new file mode 100644
index 000000000000..b63f557d1925
--- /dev/null
+++ b/multimedia/mkclean/distinfo
@@ -0,0 +1,3 @@
+MD5 (mkclean-0.6.0.tar.bz2) = 94489f21d4ae85f9c6ee9f70df32b73b
+SHA256 (mkclean-0.6.0.tar.bz2) = 098f7a44c5aafde4a99d64dfccffb4404dc354874693acd05314d6a8c3c23245
+SIZE (mkclean-0.6.0.tar.bz2) = 718736
diff --git a/multimedia/mkclean/files/patch-file_libc.c b/multimedia/mkclean/files/patch-file_libc.c
new file mode 100644
index 000000000000..a2f26f8e0080
--- /dev/null
+++ b/multimedia/mkclean/files/patch-file_libc.c
@@ -0,0 +1,11 @@
+--- corec/helpers/file/file_libc.c.orig 2010-09-26 04:42:30.000000000 -0700
++++ corec/helpers/file/file_libc.c 2010-10-24 01:44:37.000000000 -0700
+@@ -40,7 +40,7 @@
+ #include <unistd.h>
+ #include <dirent.h>
+ #include <errno.h>
+-#if defined(TARGET_OSX)
++#if defined(TARGET_OSX) || defined(__FreeBSD__)
+ #include <sys/mount.h>
+ #else
+ #include <sys/vfs.h>
diff --git a/multimedia/mkclean/files/patch-root.proj b/multimedia/mkclean/files/patch-root.proj
new file mode 100644
index 000000000000..6ba18b988d72
--- /dev/null
+++ b/multimedia/mkclean/files/patch-root.proj
@@ -0,0 +1,10 @@
+--- root.proj.orig 2010-09-26 04:42:30.000000000 -0700
++++ root.proj 2010-10-24 01:48:34.000000000 -0700
+@@ -12,6 +12,7 @@
+ USE matroska2
+ USE mkvtests
+ USE mkclean
++ USE mkWDclean
+ USE mkvalidator
+ }
+
diff --git a/multimedia/mkclean/pkg-descr b/multimedia/mkclean/pkg-descr
new file mode 100644
index 000000000000..b35aa1d02e86
--- /dev/null
+++ b/multimedia/mkclean/pkg-descr
@@ -0,0 +1,11 @@
+mkclean is a command line tool to clean and optimize Matroska (.mkv / .mka /
+.mks) and WebM (.webm / .weba) files that have already been muxed. It reorders
+the elements with the Cues at the front, so your Matroska files are ready to be
+streamed efficiently over the web. It also removes elements not found in the
+Matroska specs and the extra Meta Seek list of Clusters that some program add
+to their file. It can also optionally remux the Cluster blocks to start each
+boundary with a keyframe and the matching audio/subtitle blocks for that
+keyframe.
+
+Also comes with mkWDclean to modify files in a way they can play in
+broken/incomplete players.