aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-03-06 18:34:16 +0800
committeroliver <oliver@FreeBSD.org>2005-03-06 18:34:16 +0800
commitf58d509d230ebc38e175ad1a0be3119c2232928e (patch)
tree5471d9c68858d9afaa007bd15374f12abf112e11 /multimedia
parentb5ff69538153040234e134d05113d5089e021503 (diff)
downloadfreebsd-ports-gnome-f58d509d230ebc38e175ad1a0be3119c2232928e.tar.gz
freebsd-ports-gnome-f58d509d230ebc38e175ad1a0be3119c2232928e.tar.zst
freebsd-ports-gnome-f58d509d230ebc38e175ad1a0be3119c2232928e.zip
update to 0.99.6
PR: 77882 Submitted by: maintainer
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile206
-rw-r--r--multimedia/mplayer/distinfo6
-rw-r--r--multimedia/mplayer/files/extra-patch-gcc3414
-rw-r--r--multimedia/mplayer/files/patch-ad59
-rw-r--r--multimedia/mplayer/files/patch-ae14
-rw-r--r--multimedia/mplayer/files/patch-libfaad2-structs.h94
-rw-r--r--multimedia/mplayer/files/patch-libmpdemux-demux_rtp.cpp11
-rw-r--r--multimedia/mplayer/files/patch-libvo-vo_md5.c11
-rw-r--r--multimedia/mplayer/files/patch-mplayer.c11
-rw-r--r--multimedia/mplayer/pkg-plist172
10 files changed, 320 insertions, 278 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 71a6b9281d03..b2afdca8f3cf 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -13,6 +13,14 @@
#
# Core funcionality:
#
+# MPLAYER_GENERIC_BUILD
+# default: undefined
+# By default, the mplayer port creates a custom build based on personal
+# preferences.
+# If you want to build a generic package with certain fixed options,
+# suitable for any CPU within ${ARCH}, define this knob.
+# Note: The following knobs will have no effect in this case!
+#
# WITH_OPTIMIZED_CFLAGS
# default: undefined
# define if you want to enable -O3 -ffast-math -fomit-frame-pointer
@@ -38,6 +46,12 @@
# the default is to build mplayer with mencoder. If you're sure that you
# don't want to encode or recode any media file, then define this.
#
+# WITHOUT_X11
+# default: undefined
+# the default is to build mplayer with X11 support because of its capabilities
+# as a video player. If you don't want to install any X11 environment and use
+# mplayer as a multi-format audio-only player, this one is for you.
+#
# WITH_GTK1|WITH_GTK2
# default: autodetect GTK1
# if you want mplayer to have gui abilities, you can use this knob to define
@@ -47,8 +61,8 @@
# user interface by defining WITHOUT_GUI
# Note: If you define WITH_GTK* *and* WITHOUT_GUI, mplayer will be built without
# gui capabilities.
-# The GTK2 patches are not official ones, so they should be considered as
-# experimental.
+# At the moment there is no current gtk2 patch available, so defining this
+# knob has no effect right now.
#
# WITHOUT_GUI
# default: undefined
@@ -242,8 +256,7 @@
# to be installed.
PORTNAME= mplayer
-PORTVERSION= 0.99.5
-PORTREVISION= 6
+PORTVERSION= 0.99.6
CATEGORIES= multimedia audio ipv6
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
@@ -255,7 +268,7 @@ MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp.lug.udel.edu/MPlayer/releases/ \
ftp://mirrors.xmission.com/MPlayer/releases/ \
http://www.rrr.de/~riggs/mplayer/
-DISTNAME= MPlayer-1.0pre5try2
+DISTNAME= MPlayer-1.0pre6a
MAINTAINER= riggs@rrr.de
COMMENT= High performance media player/encoder supporting many formats
@@ -269,15 +282,12 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
-USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS=${PTHREAD_LIBS} \
TMPDIR="${WRKSRC}"
CONFIGURE_ARGS= --with-extralibdir=${LOCALBASE}/lib \
--with-extraincdir=${LOCALBASE}/include \
- --with-x11libdir=${X11BASE}/lib \
- --with-x11incdir=${X11BASE}/include \
--enable-png \
--enable-menu \
--disable-libfame \
@@ -285,9 +295,25 @@ CONFIGURE_ARGS= --with-extralibdir=${LOCALBASE}/lib \
--disable-tv-v4l \
--disable-tremor
+.if !defined(MPLAYER_GENERIC_BUILD)
+.if defined(WITHOUT_X11)
+WITHOUT_GUI= yes
+BUILD_DEPENDS+= imake:${X_IMAKE_PORT}
+CONFIGURE_ARGS+=--disable-x11
+.else
+USE_XLIB= yes
+CONFIGURE_ARGS+=--with-x11libdir=${X11BASE}/lib \
+ --with-x11incdir=${X11BASE}/include
+.endif
+
.if defined(WITH_LANG)
CONFIGURE_ARGS+=--language=${WITH_LANG}
.endif
+.else
+USE_XLIB= yes
+CONFIGURE_ARGS+=--with-x11libdir=${X11BASE}/lib \
+ --with-x11incdir=${X11BASE}/include
+.endif #MPLAYER_GENERIC_BUILD
WANT_GNOME= yes
WANT_SDL= yes
@@ -295,7 +321,7 @@ USE_REINPLACE= yes
MAN1= mplayer.1
MANCOMPRESSED= no
-CONFFILES= codecs.conf example.conf input.conf menu.conf
+CONFFILES= example.conf input.conf menu.conf
TOOLFILES= calcbpp.pl countquant.pl \
dvd2divxscript.pl menc2pass \
mencvcd mp.pl sws-test w32codec_dl.pl \
@@ -412,11 +438,85 @@ WITH_LZO= yes
WITH_FREETYPE= yes
.endif
-.if exists(${LOCALBASE}/lib/libmatroska.a)
-WITH_MATROSKA= yes
-.endif
+# Esablish de-facto dependencies for either building generic mplayer
+# binary-suitable package or custom build
-.if defined (DEBUG)
+.if defined(MPLAYER_GENERIC_BUILD)
+#Compiler flags
+CFLAGS= #let mplayer decide on this
+CONFIGURE_ARGS+=--enable-runtime-cpudetection
+#GUI
+USE_GNOME+= gtk12
+.if defined(PKGNAMESUFFIX)
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-gtk
+.else
+PKGNAMESUFFIX= -gtk
+.endif
+CONFIGURE_ARGS+= --enable-gui
+PLIST_SUB+= GMPLAYER=""
+RUN_DEPENDS+= ${LOCALBASE}/share/mplayer/Skin:${PORTSDIR}/multimedia/mplayer-skins
+#RTC
+CONFIGURE_ARGS+= --disable-rtc
+#lame for mencoder
+LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
+#mencoder
+MLINKS+= mplayer.1 mencoder.1
+PLIST_SUB+= MENCODER=""
+#ARTS
+CONFIGURE_ARGS+= --disable-arts
+#Fribidi
+CONFIGURE_ARGS+= --disable-fribidi
+#Cdparanoia
+CONFIGURE_ARGS+= --disable-cdparanoia
+#Caca
+CONFIGURE_ARGS+= --disable-caca
+#Libungif
+CONFIGURE_ARGS+= --disable-gif
+#Libdv
+CONFIGURE_ARGS+= --disable-libdv
+#Mad
+CONFIGURE_ARGS+= --disable-mad
+#Theora
+CONFIGURE_ARGS+= --disable-theora
+#Svgalib
+LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
+#Aalib
+LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
+#SDL
+USE_SDL= sdl
+#Esound
+CONFIGURE_ARGS+= --disable-esd
+#Vorbis
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
+#Real
+CONFIGURE_ARGS+= --disable-real
+#Live media
+CONFIGURE_ARGS+= --disable-live
+#XviD
+CONFIGURE_ARGS+= --enable-xvid
+LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
+#LZO
+CONFIGURE_ARGS+= --disable-liblzo
+#Freetype
+CONFIGURE_ARGS+= --with-extraincdir=${LOCALBASE}/include/freetype2 \
+ --enable-freetype
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+#XAnim codecs
+BUILD_DEPENDS+= xanim:${PORTSDIR}/multimedia/xanim
+CONFIGURE_ARGS+= --enable-xanim \
+ --with-xanimlibdir=${X11BASE}/lib/X11/xanim
+#Optical drive descriptors
+.if ${OSVERSION} < 500000
+DEFAULT_DVD_DEVICE=/dev/acd0c
+DEFAULT_CDROM_DEVICE=/dev/acd0c
+.else
+DEFAULT_DVD_DEVICE=/dev/acd0
+DEFAULT_CDROM_DEVICE=/dev/acd0
+.endif
+#Kernel granularity
+DEFAULT_KERN_HZ=1024
+.else #MPLAYER_GENERIC_BUILD
+.if defined(DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
@@ -424,7 +524,8 @@ CONFIGURE_ARGS+= --enable-debug
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
-.if ${HAVE_GNOME:Mgtk12}!="" && !defined(WITH_GTK2) && !defined(WITHOUT_GUI)
+#.if ${HAVE_GNOME:Mgtk12}!="" && !defined(WITH_GTK2) && !defined(WITHOUT_GUI)
+.if ${HAVE_GNOME:Mgtk12}!="" && !defined(WITHOUT_GUI)
WITH_GTK1= yes
.endif
@@ -437,24 +538,25 @@ RUN_DEPENDS+= ${LOCALBASE}/share/mplayer/Skin:${PORTSDIR}/multimedia/mplayer-ski
PLIST_SUB+= GMPLAYER="@comment "
.endif
-.if defined(WITH_GTK2) && !defined(WITH_GTK1) && !defined(WITHOUT_GUI)
-.if ( ${OSVERSION} < 500000 )
-USE_GCC= 3.4
-.endif
-USE_GNOME+= gtk20
-PATCHFILES+= mplayer1.0pre5-gtk2-20040730.patch.bz2
-.if defined(PKGNAMESUFFIX)
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-gtk2
-.else
-PKGNAMESUFFIX= -gtk2
-.endif
-CONFIGURE_ARGS+= --enable-gui
-.if defined(WITH_LANG)
-WITH_LANG= ""
-.endif
-.endif
+#.if defined(WITH_GTK2) && !defined(WITH_GTK1) && !defined(WITHOUT_GUI)
+#.if ( ${OSVERSION} < 500000 )
+#USE_GCC= 3.4
+#.endif
+#USE_GNOME+= gtk20
+#PATCHFILES+= mplayer1.0pre5-gtk2-20040730.patch.bz2
+#.if defined(PKGNAMESUFFIX)
+#PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-gtk2
+#.else
+#PKGNAMESUFFIX= -gtk2
+#.endif
+#CONFIGURE_ARGS+= --enable-gui
+#.if defined(WITH_LANG)
+#WITH_LANG= ""
+#.endif
+#.endif
-.if defined(WITH_GTK1) && !defined(WITH_GTK2) && !defined(WITHOUT_GUI)
+#.if defined(WITH_GTK1) && !defined(WITH_GTK2) && !defined(WITHOUT_GUI)
+.if defined(WITH_GTK1) && !defined(WITHOUT_GUI)
USE_GNOME+= gtk12
.if defined(PKGNAMESUFFIX)
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-gtk
@@ -543,13 +645,6 @@ CONFIGURE_ARGS+= --enable-mad \
CONFIGURE_ARGS+= --disable-mad
.endif
-.if defined(WITH_MATROSKA)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libmatroska.a:${PORTSDIR}/multimedia/libmatroska
-CONFIGURE_ARGS+= --enable-external-matroska=${LOCALBASE}/lib
-.else
-CONFIGURE_ARGS+= --disable-external-matroska
-.endif
-
.if defined(WITH_SVGALIB)
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
.endif
@@ -560,6 +655,8 @@ LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
.if defined(WITH_THEORA)
LIB_DEPENDS+= theora.1:${PORTSDIR}/multimedia/libtheora
+.else
+CONFIGURE_ARGS+= --disable-theora
.endif
#.if defined(WITH_TREMOR)
@@ -593,6 +690,8 @@ CONFIGURE_ARGS+= --enable-real \
--with-reallibdir=${LOCALBASE}/lib/RealPlayer8/Codecs
RUN_DEPENDS+= realplay:${PORTSDIR}/multimedia/linux-realplayer
BUILD_DEPENDS+= realplay:${PORTSDIR}/multimedia/linux-realplayer
+.else
+CONFIGURE_ARGS+= --disable-real
.endif
.if defined(WITH_LIVEMEDIA)
@@ -600,6 +699,8 @@ CONFIGURE_ARGS+= --enable-live \
--with-livelibdir=${LOCALBASE}/live
RUN_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/liveMedia
BUILD_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/liveMedia
+.else
+CONFIGURE_ARGS+= --disable-live
.endif
.if defined(WITH_XVID)
@@ -629,7 +730,6 @@ CONFIGURE_ARGS+= --disable-freetype
.if defined(WITH_XANIM)
BUILD_DEPENDS+= xanim:${PORTSDIR}/multimedia/xanim
-
CONFIGURE_ARGS+=--enable-xanim --with-xanimlibdir=${X11BASE}/lib/X11/xanim
.else
CONFIGURE_ARGS+=--disable-xanim
@@ -703,6 +803,7 @@ CONFIGURE_ARGS+= --disable-win32 \
--disable-qtx-codecs
.endif
.endif # ARCH == i386
+.endif #MPLAYER_GENERIC_BUILD
pre-everything::
@${ECHO_MSG} "N - O - T - E"
@@ -720,16 +821,16 @@ pre-everything::
@${ECHO_MSG} "http://www.mplayerhq.hu/homepage/dload.html"
.endif
-.if defined(WITH_GTK2) && !defined(WITHOUT_GUI)
- @${ECHO_MSG} "=====================> <Caution> <======================"
- @${ECHO_MSG} "GTK2 and UTF8 language options cannot peacefully coexist"
- @${ECHO_MSG} "If you have defined WITH_LANG=<something> and WITH_GTK2"
- @${ECHO_MSG} "your language options are ignored."
- @${ECHO_MSG} "====================> </Caution> <======================"
-.endif
+#.if defined(WITH_GTK2) && !defined(WITHOUT_GUI)
+# @${ECHO_MSG} "=====================> <Caution> <======================"
+# @${ECHO_MSG} "GTK2 and UTF8 language options cannot peacefully coexist"
+# @${ECHO_MSG} "If you have defined WITH_LANG=<something> and WITH_GTK2"
+# @${ECHO_MSG} "your language options are ignored."
+# @${ECHO_MSG} "====================> </Caution> <======================"
+#.endif
post-patch:
-.if ${OSVERSION} > 502125
+.if (${OSVERSION} > 502125 || (defined(USE_GCC) && ${USE_GCC} == 3.4))
@cd ${WRKSRC} && ${PATCH} < ${PATCHDIR}/extra-patch-gcc34
.endif
@${REINPLACE_CMD} -e \
@@ -738,8 +839,11 @@ post-patch:
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|; \
s|/dev/cdrom|${DEFAULT_CDROM_DEVICE}|' \
${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's!/usr/local!${PREFIX}!' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
@${FIND} ${WRKSRC}/DOCS/man -name "mplayer.1" | ${XARGS} ${REINPLACE_CMD} -E -e \
- 's|/dev/\\:(dvd[[:alnum:]]*[[:>:]])|${DEFAULT_DVD_DEVICE:S/dev\//dev\/\\\:/}|g ; \
+ 's|/usr/\\:local/\\:etc/\\:mplayer|${DATADIR:S/\//\/\\\:/g}|g ; \
+ s|/dev/\\:(dvd[[:alnum:]]*[[:>:]])|${DEFAULT_DVD_DEVICE:S/dev\//dev\/\\\:/}|g ; \
s|/dev/\\:(cdrom[[:alnum:]]*[[:>:]])|${DEFAULT_CDROM_DEVICE:S/dev\//dev\/\\\:/}|g'
.if defined(WITH_RTC)
@${REINPLACE_CMD} -e \
@@ -758,6 +862,11 @@ post-patch:
's|irqp = 1024|irqp = ${DEFAULT_KERN_HZ}|' \
${WRKSRC}/mplayer.c
.endif
+.if defined(MPLAYER_GENERIC_BUILD)
+ @${REINPLACE_CMD} -e \
+ 's|1.0pre6|1.0pre6-FreeBSD-generic|' \
+ ${WRKSRC}/version.sh
+.endif
post-configure:
@${REINPLACE_CMD} -e 's#-pthread#${PTHREAD_LIBS}#g' \
@@ -788,3 +897,4 @@ install-user:
@${PERL} ${FILESDIR}/install-user
.include <bsd.port.post.mk>
+
diff --git a/multimedia/mplayer/distinfo b/multimedia/mplayer/distinfo
index 4c20489c5152..edfd21d22e71 100644
--- a/multimedia/mplayer/distinfo
+++ b/multimedia/mplayer/distinfo
@@ -1,4 +1,2 @@
-MD5 (MPlayer-1.0pre5try2.tar.bz2) = 724c905a8dddb7e8ec9722fc585f833d
-SIZE (MPlayer-1.0pre5try2.tar.bz2) = 5073725
-MD5 (mplayer1.0pre5-gtk2-20040730.patch.bz2) = 49840e54549f47fa859d0c3d27014202
-SIZE (mplayer1.0pre5-gtk2-20040730.patch.bz2) = 38845
+MD5 (MPlayer-1.0pre6a.tar.bz2) = a812d945b884c2e2fa7f90c57cd76bff
+SIZE (MPlayer-1.0pre6a.tar.bz2) = 6380482
diff --git a/multimedia/mplayer/files/extra-patch-gcc34 b/multimedia/mplayer/files/extra-patch-gcc34
index 8d92957635d3..a8a44dd411ad 100644
--- a/multimedia/mplayer/files/extra-patch-gcc34
+++ b/multimedia/mplayer/files/extra-patch-gcc34
@@ -147,3 +147,17 @@
/* XXX: add ISOC specific test to avoid specific BSD testing. */
/* better than nothing implementation. */
/* btw, rintf() is existing on fbsd too -- alex */
+--- libavcodec/resample2.c.orig Thu Dec 23 22:24:08 2004
++++ libavcodec/resample2.c Mon Jan 10 23:03:32 2005
+@@ -28,6 +28,11 @@
+ #include "common.h"
+ #include "dsputil.h"
+
++#ifdef __FreeBSD__
++#include <math.h>
++#define lrintf(x) rintf(x)
++#endif
++
+ #if 1
+ #define FILTER_SHIFT 15
+
diff --git a/multimedia/mplayer/files/patch-ad b/multimedia/mplayer/files/patch-ad
index c80f3683b83e..cacd0e3812d9 100644
--- a/multimedia/mplayer/files/patch-ad
+++ b/multimedia/mplayer/files/patch-ad
@@ -1,6 +1,6 @@
---- configure.orig Thu Jul 15 00:04:42 2004
-+++ configure Thu Jul 22 22:13:22 2004
-@@ -344,7 +344,7 @@
+--- configure.orig Thu Dec 23 16:36:00 2004
++++ configure Tue Feb 8 23:24:26 2005
+@@ -359,7 +359,7 @@
# 1st pass checking for vital options
@@ -9,7 +9,23 @@
_ranlib=ranlib
_cc=cc
test "$CC" && _cc="$CC"
-@@ -601,22 +601,10 @@
+@@ -461,14 +461,7 @@
+ case "`( uname -m ) 2>&1`" in
+ i[3-9]86*|x86|x86pc|k5|k6|k6_2|k6_3|k6-2|k6-3|pentium*|athlon*|i586_i686|i586-i686|BePC) host_arch=i386 ;;
+ ia64) host_arch=ia64 ;;
+- x86_64|amd64)
+- if [ "`$_cc -dumpmachine | grep x86_64 | cut -d- -f1`" = "x86_64" -a \
+- -z "`echo $CFLAGS | grep -- -m32`" ]; then
+- host_arch=x86_64
+- else
+- host_arch=i386
+- fi
+- ;;
++ x86_64|amd64) host_arch=x86_64 ;;
+ macppc|ppc) host_arch=ppc ;;
+ alpha) host_arch=alpha ;;
+ sparc) host_arch=sparc ;;
+@@ -681,22 +674,10 @@
_cpuinfo="echo"
# Cygwin has /proc/cpuinfo, but only supports Intel CPUs
# FIXME: Remove the cygwin check once AMD CPUs are supported
@@ -30,9 +46,9 @@
_cpuinfo="TOOLS/cpuinfo"
-fi
- case "$host_arch" in
- i[3-9]86|x86|x86pc|k5|k6|k6-2|k6-3|pentium*|athlon*|i586-i686)
-@@ -1687,8 +1675,8 @@
+ x86_exts_check()
+ {
+@@ -1843,8 +1824,8 @@
;;
*)
@@ -43,7 +59,7 @@
;;
esac
-@@ -1698,7 +1686,7 @@
+@@ -1854,7 +1835,7 @@
test -z "$_bindir" && _bindir="$_prefix/bin"
test -z "$_datadir" && _datadir="$_prefix/share/mplayer"
test -z "$_mandir" && _mandir="$_prefix/man"
@@ -52,7 +68,7 @@
test -z "$_libdir" && _libdir="$_prefix/lib"
test -z "$_mlibdir" && _mlibdir="$MLIBHOME"
-@@ -2371,13 +2359,7 @@
+@@ -2576,13 +2557,7 @@
echocheck "memalign()"
@@ -66,8 +82,8 @@
if test "$_memalign" = yes ; then
_def_memalign='#define HAVE_MEMALIGN 1'
else
-@@ -2465,45 +2447,10 @@
-
+@@ -2671,48 +2646,11 @@
+ _def_threads='#undef HAVE_THREADS'
echocheck "pthread"
-cat > $TMPC << EOF
@@ -77,6 +93,8 @@
-EOF
-if mingw32 ; then
- _ld_pthread=''
+-elif hpux ; then
+- _ld_pthread=''
-elif ( cc_check && $TMPO ) ; then # QNX
- _ld_pthread=''
-elif ( cc_check -lpthread && $TMPO ) ; then
@@ -104,6 +122,7 @@
echores "yes (using $_ld_pthread)"
_pthreads='yes'
_def_pthreads='#define HAVE_PTHREADS 1'
+ _def_threads='#define HAVE_THREADS 1'
-else
- echores "no"
- _pthreads=''
@@ -113,7 +132,7 @@
echocheck "sys/soundcard.h"
cat > $TMPC << EOF
-@@ -4670,11 +4617,11 @@
+@@ -5000,11 +4938,11 @@
echocheck "RTC"
@@ -127,16 +146,16 @@
int main(void) { return RTC_IRQP_READ; }
EOF
_rtc=no
-@@ -5909,7 +5856,7 @@
+@@ -6314,7 +6252,7 @@
+ fi
_stripbinaries=no
elif test -z "$CFLAGS" ; then
- if test "$host_arch" != "mips" ; then
-- CFLAGS="-O4 $_march $_mcpu -pipe -ffast-math -fomit-frame-pointer"
+- CFLAGS="-O4 $_march $_mcpu $_pipe -ffast-math -fomit-frame-pointer"
+ CFLAGS="-O"
- else
- CFLAGS="-O4 $_march $_mcpu -ffast-math -fomit-frame-pointer"
- fi
-@@ -5919,6 +5866,9 @@
+ # always compile with '-g' if .developer:
+ if test -f ".developer" ; then
+ CFLAGS="-g $CFLAGS"
+@@ -6324,6 +6262,9 @@
_stripbinaries=no
fi
else
@@ -146,7 +165,7 @@
cat <<EOF
MPlayer compilation will use the CFLAGS set by you, but:
-@@ -5948,7 +5898,7 @@
+@@ -6363,7 +6304,7 @@
CFLAGS="$CFLAGS -D_REENTRANT"
elif bsd ; then
# FIXME bsd needs this so maybe other OS'es
diff --git a/multimedia/mplayer/files/patch-ae b/multimedia/mplayer/files/patch-ae
index d512ecb969da..9105985280bf 100644
--- a/multimedia/mplayer/files/patch-ae
+++ b/multimedia/mplayer/files/patch-ae
@@ -1,6 +1,6 @@
---- Makefile.orig Sat Jan 24 20:33:40 2004
-+++ Makefile Sat Jan 24 20:49:23 2004
-@@ -252,53 +252,10 @@
+--- Makefile.orig Fri Nov 5 15:02:40 2004
++++ Makefile Mon Jan 10 21:53:25 2005
+@@ -273,57 +273,10 @@
ifeq ($(VIDIX),yes)
$(DO_MAKE)
endif
@@ -10,7 +10,7 @@
- -ln -sf $(PRG) $(BINDIR)/gmplayer
-endif
- if test ! -d $(MANDIR)/man1 ; then mkdir -p $(MANDIR)/man1; fi
-- for i in $(LANGUAGES); do \
+- for i in $(MAN_LANG); do \
- if test "$$i" = en ; then \
- $(INSTALL) -c -m 644 DOCS/man/en/mplayer.1 $(MANDIR)/man1/mplayer.1 ; \
- else \
@@ -22,7 +22,7 @@
+ @${BSD_INSTALL_MAN} DOCS/man/en/mplayer.1 $(MANDIR)/man1/mplayer.1
ifeq ($(MENCODER),yes)
- $(INSTALL) -m 755 $(INSTALLSTRIP) $(PRG_MENCODER) $(BINDIR)/$(PRG_MENCODER)
-- for i in $(LANGUAGES); do \
+- for i in $(MAN_LANG); do \
- if test "$$i" = en ; then \
- ln -sf mplayer.1 $(MANDIR)/man1/mencoder.1 ; \
- else \
@@ -40,6 +40,10 @@
- @if test ! -d $(DATADIR)/Skin ; then mkdir -p $(DATADIR)/Skin ; fi
- @echo "*** Download skin(s) at http://www.mplayerhq.hu/homepage/dload.html"
- @echo "*** for GUI, and extract to $(DATADIR)/Skin/"
+- @if test ! -d $(prefix)/share/pixmaps ; then mkdir -p $(prefix)/share/pixmaps ; fi
+- $(INSTALL) -m 644 Gui/mplayer/pixmaps/mplayer-desktop.xpm $(prefix)/share/pixmaps/mplayer-desktop.xpm
+- @if test ! -d $(prefix)/share/applications ; then mkdir -p $(prefix)/share/applications ; fi
+- $(INSTALL) -m 644 etc/mplayer.desktop $(prefix)/share/applications/mplayer.desktop
-endif
- @if test ! -d $(CONFDIR) ; then mkdir -p $(CONFDIR) ; fi
- @if test -f $(CONFDIR)/codecs.conf ; then mv -f $(CONFDIR)/codecs.conf $(CONFDIR)/codecs.conf.old ; fi
diff --git a/multimedia/mplayer/files/patch-libfaad2-structs.h b/multimedia/mplayer/files/patch-libfaad2-structs.h
deleted file mode 100644
index 982f9b43bbf6..000000000000
--- a/multimedia/mplayer/files/patch-libfaad2-structs.h
+++ /dev/null
@@ -1,94 +0,0 @@
---- libfaad2/structs.h.orig Sat Sep 25 19:19:19 2004
-+++ libfaad2/structs.h Sat Sep 25 19:22:32 2004
-@@ -309,58 +309,58 @@
- typedef struct mp4AudioSpecificConfig
- {
- /* Audio Specific Info */
-- uint8_t objectTypeIndex;
-- uint8_t samplingFrequencyIndex;
-- uint32_t samplingFrequency;
-- uint8_t channelsConfiguration;
-+ unsigned char objectTypeIndex;
-+ unsigned char samplingFrequencyIndex;
-+ unsigned long samplingFrequency;
-+ unsigned char channelsConfiguration;
-
- /* GA Specific Info */
-- uint8_t frameLengthFlag;
-- uint8_t dependsOnCoreCoder;
-- uint16_t coreCoderDelay;
-- uint8_t extensionFlag;
-- uint8_t aacSectionDataResilienceFlag;
-- uint8_t aacScalefactorDataResilienceFlag;
-- uint8_t aacSpectralDataResilienceFlag;
-- uint8_t epConfig;
-+ unsigned char frameLengthFlag;
-+ unsigned char dependsOnCoreCoder;
-+ unsigned short coreCoderDelay;
-+ unsigned char extensionFlag;
-+ unsigned char aacSectionDataResilienceFlag;
-+ unsigned char aacScalefactorDataResilienceFlag;
-+ unsigned char aacSpectralDataResilienceFlag;
-+ unsigned char epConfig;
-
-- int8_t sbr_present_flag;
-- int8_t forceUpSampling;
-+ char sbr_present_flag;
-+ char forceUpSampling;
- } mp4AudioSpecificConfig;
-
- typedef struct faacDecConfiguration
- {
-- uint8_t defObjectType;
-- uint32_t defSampleRate;
-- uint8_t outputFormat;
-- uint8_t downMatrix;
-- uint8_t useOldADTSFormat;
-- uint8_t dontUpSampleImplicitSBR;
-+ unsigned char defObjectType;
-+ unsigned long defSampleRate;
-+ unsigned char outputFormat;
-+ unsigned char downMatrix;
-+ unsigned char useOldADTSFormat;
-+ unsigned char dontUpSampleImplicitSBR;
- } faacDecConfiguration, *faacDecConfigurationPtr;
-
- typedef struct faacDecFrameInfo
- {
-- uint32_t bytesconsumed;
-- uint32_t samples;
-- uint8_t channels;
-- uint8_t error;
-- uint32_t samplerate;
-+ unsigned long bytesconsumed;
-+ unsigned long samples;
-+ unsigned char channels;
-+ unsigned char error;
-+ unsigned long samplerate;
-
- /* SBR: 0: off, 1: on; normal, 2: on; downsampled */
-- uint8_t sbr;
-+ unsigned char sbr;
-
- /* MPEG-4 ObjectType */
-- uint8_t object_type;
-+ unsigned char object_type;
-
- /* AAC header type; MP4 will be signalled as RAW also */
-- uint8_t header_type;
-+ unsigned char header_type;
-
- /* multichannel configuration */
-- uint8_t num_front_channels;
-- uint8_t num_side_channels;
-- uint8_t num_back_channels;
-- uint8_t num_lfe_channels;
-- uint8_t channel_position[MAX_CHANNELS];
-+ unsigned char num_front_channels;
-+ unsigned char num_side_channels;
-+ unsigned char num_back_channels;
-+ unsigned char num_lfe_channels;
-+ unsigned char channel_position[MAX_CHANNELS];
- } faacDecFrameInfo;
-
- typedef struct
diff --git a/multimedia/mplayer/files/patch-libmpdemux-demux_rtp.cpp b/multimedia/mplayer/files/patch-libmpdemux-demux_rtp.cpp
deleted file mode 100644
index dd6287b5bd38..000000000000
--- a/multimedia/mplayer/files/patch-libmpdemux-demux_rtp.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libmpdemux/demux_rtp.cpp.orig Thu Jun 3 15:30:55 2004
-+++ libmpdemux/demux_rtp.cpp Thu Jul 22 23:29:36 2004
-@@ -407,7 +407,7 @@
- delete rtpState->sdpDescription;
- delete rtpState;
-
-- delete env; delete scheduler;
-+ env->reclaim(); delete scheduler;
- }
-
- ////////// Extra routines that help implement the above interface functions:
diff --git a/multimedia/mplayer/files/patch-libvo-vo_md5.c b/multimedia/mplayer/files/patch-libvo-vo_md5.c
deleted file mode 100644
index fa2a5e5585f7..000000000000
--- a/multimedia/mplayer/files/patch-libvo-vo_md5.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libvo/vo_md5.c.orig Mon Nov 11 10:20:26 2002
-+++ libvo/vo_md5.c Sun Jan 11 02:30:52 2004
-@@ -56,7 +56,7 @@
-
- video_out_pgm.flip_page();
-
-- snprintf (buf2, 100, "md5sum %s", vo_pgm_filename);
-+ snprintf (buf2, 100, "md5 %s", vo_pgm_filename);
- f = popen (buf2, "r");
- i = fread (buf2, 1, sizeof(buf2), f);
- pclose (f);
diff --git a/multimedia/mplayer/files/patch-mplayer.c b/multimedia/mplayer/files/patch-mplayer.c
new file mode 100644
index 000000000000..9826171c86b4
--- /dev/null
+++ b/multimedia/mplayer/files/patch-mplayer.c
@@ -0,0 +1,11 @@
+--- mplayer.c.orig Tue Dec 21 13:25:58 2004
++++ mplayer.c Mon Jan 10 22:43:29 2005
+@@ -93,7 +93,7 @@
+ #define ROUND(x) ((int)((x)<0 ? (x)-0.5 : (x)+0.5))
+
+ #ifdef HAVE_RTC
+-#include <linux/rtc.h>
++#include <rtc.h>
+ #endif
+
+ #ifdef USE_TV
diff --git a/multimedia/mplayer/pkg-plist b/multimedia/mplayer/pkg-plist
index cb41dfd009c5..affdaac11f21 100644
--- a/multimedia/mplayer/pkg-plist
+++ b/multimedia/mplayer/pkg-plist
@@ -1,75 +1,76 @@
bin/mplayer
%%MENCODER%%bin/mencoder
%%GMPLAYER%%bin/gmplayer
-%%PORTDOCS%%share/doc/mplayer/amiga.html
-%%PORTDOCS%%share/doc/mplayer/aspect.html
-%%PORTDOCS%%share/doc/mplayer/bsd.html
-%%PORTDOCS%%share/doc/mplayer/bugreports.html
-%%PORTDOCS%%share/doc/mplayer/bugreports_advusers.html
-%%PORTDOCS%%share/doc/mplayer/bugreports_fix.html
-%%PORTDOCS%%share/doc/mplayer/bugreports_report.html
-%%PORTDOCS%%share/doc/mplayer/bugreports_what.html
-%%PORTDOCS%%share/doc/mplayer/bugreports_where.html
-%%PORTDOCS%%share/doc/mplayer/bugs-audio.html
-%%PORTDOCS%%share/doc/mplayer/bugs-special.html
-%%PORTDOCS%%share/doc/mplayer/bugs.html
-%%PORTDOCS%%share/doc/mplayer/cd-dvd.html
-%%PORTDOCS%%share/doc/mplayer/codecs.html
-%%PORTDOCS%%share/doc/mplayer/commandline.html
-%%PORTDOCS%%share/doc/mplayer/control.html
-%%PORTDOCS%%share/doc/mplayer/custommatrices.html
-%%PORTDOCS%%share/doc/mplayer/default.css
-%%PORTDOCS%%share/doc/mplayer/devices.html
-%%PORTDOCS%%share/doc/mplayer/drives.html
-%%PORTDOCS%%share/doc/mplayer/dvd.html
-%%PORTDOCS%%share/doc/mplayer/edl.html
-%%PORTDOCS%%share/doc/mplayer/faq.html
-%%PORTDOCS%%share/doc/mplayer/features.html
-%%PORTDOCS%%share/doc/mplayer/formats.html
-%%PORTDOCS%%share/doc/mplayer/gcc-296.html
-%%PORTDOCS%%share/doc/mplayer/gui.html
-%%PORTDOCS%%share/doc/mplayer/history.html
-%%PORTDOCS%%share/doc/mplayer/howtoread.html
-%%PORTDOCS%%share/doc/mplayer/hp-ux.html
-%%PORTDOCS%%share/doc/mplayer/index.html
-%%PORTDOCS%%share/doc/mplayer/install.html
-%%PORTDOCS%%share/doc/mplayer/intro.html
-%%PORTDOCS%%share/doc/mplayer/irix.html
-%%PORTDOCS%%share/doc/mplayer/joe-barr.html
-%%PORTDOCS%%share/doc/mplayer/linux.html
-%%PORTDOCS%%share/doc/mplayer/macos.html
-%%PORTDOCS%%share/doc/mplayer/mailinglists.html
-%%PORTDOCS%%share/doc/mplayer/menc-feat-dvd-mpeg4.html
-%%PORTDOCS%%share/doc/mplayer/menc-feat-enc-images.html
-%%PORTDOCS%%share/doc/mplayer/menc-feat-enc-libavcodec.html
-%%PORTDOCS%%share/doc/mplayer/menc-feat-telecine.html
-%%PORTDOCS%%share/doc/mplayer/menc-feat-mpeg.html
-%%PORTDOCS%%share/doc/mplayer/menc-feat-mpeg4.html
-%%PORTDOCS%%share/doc/mplayer/menc-feat-extractsub.html
-%%PORTDOCS%%share/doc/mplayer/menc-feat-fix-avi.html
-%%PORTDOCS%%share/doc/mplayer/menc-feat-rescale.html
-%%PORTDOCS%%share/doc/mplayer/menc-feat-streamcopy.html
-%%PORTDOCS%%share/doc/mplayer/mencoder.html
-%%PORTDOCS%%share/doc/mplayer/mplayer-binary.html
-%%PORTDOCS%%share/doc/mplayer/mpst.html
-%%PORTDOCS%%share/doc/mplayer/nvidia-opinions.html
-%%PORTDOCS%%share/doc/mplayer/patches.html
-%%PORTDOCS%%share/doc/mplayer/ports.html
-%%PORTDOCS%%share/doc/mplayer/qnx.html
-%%PORTDOCS%%share/doc/mplayer/rtc.html
-%%PORTDOCS%%share/doc/mplayer/skin.html
-%%PORTDOCS%%share/doc/mplayer/skin-file.html
-%%PORTDOCS%%share/doc/mplayer/skin-fonts.html
-%%PORTDOCS%%share/doc/mplayer/skin-gui.html
-%%PORTDOCS%%share/doc/mplayer/skin-overview.html
-%%PORTDOCS%%share/doc/mplayer/solaris.html
-%%PORTDOCS%%share/doc/mplayer/streaming.html
-%%PORTDOCS%%share/doc/mplayer/subosd.html
-%%PORTDOCS%%share/doc/mplayer/tv-input.html
-%%PORTDOCS%%share/doc/mplayer/usage.html
-%%PORTDOCS%%share/doc/mplayer/users-vs-dev.html
-%%PORTDOCS%%share/doc/mplayer/vcd.html
-%%PORTDOCS%%share/doc/mplayer/windows.html
+%%PORTDOCS%%%%DOCSDIR%%/amiga.html
+%%PORTDOCS%%%%DOCSDIR%%/aspect.html
+%%PORTDOCS%%%%DOCSDIR%%/audio.html
+%%PORTDOCS%%%%DOCSDIR%%/bsd.html
+%%PORTDOCS%%%%DOCSDIR%%/bugreports.html
+%%PORTDOCS%%%%DOCSDIR%%/bugreports_advusers.html
+%%PORTDOCS%%%%DOCSDIR%%/bugreports_fix.html
+%%PORTDOCS%%%%DOCSDIR%%/bugreports_report.html
+%%PORTDOCS%%%%DOCSDIR%%/bugreports_what.html
+%%PORTDOCS%%%%DOCSDIR%%/bugreports_where.html
+%%PORTDOCS%%%%DOCSDIR%%/bugs-audio.html
+%%PORTDOCS%%%%DOCSDIR%%/bugs-special.html
+%%PORTDOCS%%%%DOCSDIR%%/bugs.html
+%%PORTDOCS%%%%DOCSDIR%%/cd-dvd.html
+%%PORTDOCS%%%%DOCSDIR%%/codecs.html
+%%PORTDOCS%%%%DOCSDIR%%/commandline.html
+%%PORTDOCS%%%%DOCSDIR%%/control.html
+%%PORTDOCS%%%%DOCSDIR%%/custommatrices.html
+%%PORTDOCS%%%%DOCSDIR%%/default.css
+%%PORTDOCS%%%%DOCSDIR%%/drives.html
+%%PORTDOCS%%%%DOCSDIR%%/dvd.html
+%%PORTDOCS%%%%DOCSDIR%%/edl.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/features.html
+%%PORTDOCS%%%%DOCSDIR%%/formats.html
+%%PORTDOCS%%%%DOCSDIR%%/gcc-296.html
+%%PORTDOCS%%%%DOCSDIR%%/gui.html
+%%PORTDOCS%%%%DOCSDIR%%/history.html
+%%PORTDOCS%%%%DOCSDIR%%/howtoread.html
+%%PORTDOCS%%%%DOCSDIR%%/hp-ux.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/install.html
+%%PORTDOCS%%%%DOCSDIR%%/intro.html
+%%PORTDOCS%%%%DOCSDIR%%/irix.html
+%%PORTDOCS%%%%DOCSDIR%%/joe-barr.html
+%%PORTDOCS%%%%DOCSDIR%%/linux.html
+%%PORTDOCS%%%%DOCSDIR%%/macos.html
+%%PORTDOCS%%%%DOCSDIR%%/mailinglists.html
+%%PORTDOCS%%%%DOCSDIR%%/menc-feat-dvd-mpeg4.html
+%%PORTDOCS%%%%DOCSDIR%%/menc-feat-enc-images.html
+%%PORTDOCS%%%%DOCSDIR%%/menc-feat-enc-libavcodec.html
+%%PORTDOCS%%%%DOCSDIR%%/menc-feat-telecine.html
+%%PORTDOCS%%%%DOCSDIR%%/menc-feat-mpeg.html
+%%PORTDOCS%%%%DOCSDIR%%/menc-feat-mpeg4.html
+%%PORTDOCS%%%%DOCSDIR%%/menc-feat-extractsub.html
+%%PORTDOCS%%%%DOCSDIR%%/menc-feat-fix-avi.html
+%%PORTDOCS%%%%DOCSDIR%%/menc-feat-rescale.html
+%%PORTDOCS%%%%DOCSDIR%%/menc-feat-streamcopy.html
+%%PORTDOCS%%%%DOCSDIR%%/mencoder.html
+%%PORTDOCS%%%%DOCSDIR%%/mplayer-binary.html
+%%PORTDOCS%%%%DOCSDIR%%/mpst.html
+%%PORTDOCS%%%%DOCSDIR%%/nvidia-opinions.html
+%%PORTDOCS%%%%DOCSDIR%%/patches.html
+%%PORTDOCS%%%%DOCSDIR%%/ports.html
+%%PORTDOCS%%%%DOCSDIR%%/qnx.html
+%%PORTDOCS%%%%DOCSDIR%%/rtc.html
+%%PORTDOCS%%%%DOCSDIR%%/skin.html
+%%PORTDOCS%%%%DOCSDIR%%/skin-file.html
+%%PORTDOCS%%%%DOCSDIR%%/skin-fonts.html
+%%PORTDOCS%%%%DOCSDIR%%/skin-gui.html
+%%PORTDOCS%%%%DOCSDIR%%/skin-overview.html
+%%PORTDOCS%%%%DOCSDIR%%/solaris.html
+%%PORTDOCS%%%%DOCSDIR%%/streaming.html
+%%PORTDOCS%%%%DOCSDIR%%/subosd.html
+%%PORTDOCS%%%%DOCSDIR%%/tv-input.html
+%%PORTDOCS%%%%DOCSDIR%%/usage.html
+%%PORTDOCS%%%%DOCSDIR%%/users-vs-dev.html
+%%PORTDOCS%%%%DOCSDIR%%/vcd.html
+%%PORTDOCS%%%%DOCSDIR%%/video.html
+%%PORTDOCS%%%%DOCSDIR%%/windows.html
%%VIDIX%%lib/libdha.so.1
%%VIDIX%%lib/libdha-1.so.0
%%VIDIX%%lib/mplayer/vidix/cyberblade_vid.so
@@ -80,22 +81,23 @@ bin/mplayer
%%VIDIX%%lib/mplayer/vidix/pm3_vid.so
%%VIDIX%%lib/mplayer/vidix/radeon_vid.so
%%VIDIX%%lib/mplayer/vidix/rage128_vid.so
+%%VIDIX%%lib/mplayer/vidix/savage_vid.so
%%VIDIX%%lib/mplayer/vidix/sis_vid.so
-share/mplayer/tools/calcbpp.pl
-share/mplayer/tools/countquant.pl
-share/mplayer/tools/dvd2divxscript.pl
-share/mplayer/tools/menc2pass
-share/mplayer/tools/mencvcd
-share/mplayer/tools/mp.pl
-share/mplayer/tools/sws-test
-share/mplayer/tools/w32codec_dl.pl
-share/mplayer/tools/x2mpsub.sh
-share/mplayer/codecs.conf
-share/mplayer/example.conf
-share/mplayer/input.conf
-share/mplayer/menu.conf
-@dirrm share/mplayer/tools
-@unexec rmdir %D/share/mplayer 2>/dev/null || true
-%%PORTDOCS%%@dirrm share/doc/mplayer
+%%VIDIX%%lib/mplayer/vidix/unichrome_vid.so
+%%DATADIR%%/tools/calcbpp.pl
+%%DATADIR%%/tools/countquant.pl
+%%DATADIR%%/tools/dvd2divxscript.pl
+%%DATADIR%%/tools/menc2pass
+%%DATADIR%%/tools/mencvcd
+%%DATADIR%%/tools/mp.pl
+%%DATADIR%%/tools/sws-test
+%%DATADIR%%/tools/w32codec_dl.pl
+%%DATADIR%%/tools/x2mpsub.sh
+%%DATADIR%%/example.conf
+%%DATADIR%%/input.conf
+%%DATADIR%%/menu.conf
+@dirrm %%DATADIR%%/tools
+@unexec rmdir %D/%%DATADIR%% 2>/dev/null || true
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%VIDIX%%@dirrm lib/mplayer/vidix
%%VIDIX%%@dirrm lib/mplayer