aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-04-06 22:48:33 +0800
committerjbeich <jbeich@FreeBSD.org>2016-04-06 22:48:33 +0800
commit38bfe8347b974d336ebfc1e6eeba52014b6717ce (patch)
tree2c07f7cbad3a273bbf153de0e25b4a9af7f5ffdc /multimedia
parent3491b77824c31369b438706b8086e5c0a05c2210 (diff)
downloadfreebsd-ports-gnome-38bfe8347b974d336ebfc1e6eeba52014b6717ce.tar.gz
freebsd-ports-gnome-38bfe8347b974d336ebfc1e6eeba52014b6717ce.tar.zst
freebsd-ports-gnome-38bfe8347b974d336ebfc1e6eeba52014b6717ce.zip
multimedia/l-smash: add new port
L-SMASH is a cross-platform library for dealing with ISO Base Media derived formats, including MP4. https://l-smash.github.io/l-smash/
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/l-smash/Makefile34
-rw-r--r--multimedia/l-smash/distinfo2
-rw-r--r--multimedia/l-smash/pkg-descr4
-rw-r--r--multimedia/l-smash/pkg-plist9
5 files changed, 50 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 5ad6e7ac484c..246a464bb732 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -166,6 +166,7 @@
SUBDIR += kmplayer-kde4
SUBDIR += kodi
SUBDIR += kplayer-kde4
+ SUBDIR += l-smash
SUBDIR += libaacs
SUBDIR += libass
SUBDIR += libav
diff --git a/multimedia/l-smash/Makefile b/multimedia/l-smash/Makefile
new file mode 100644
index 000000000000..3a24dddb7416
--- /dev/null
+++ b/multimedia/l-smash/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= l-smash
+PORTVERSION= 2.9.1
+DISTVERSIONPREFIX= v
+CATEGORIES= multimedia
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= MP4 muxer and other tools
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+
+USES= gmake pathfix
+PATHFIX_MAKEFILEIN= Makefile
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix="${PREFIX}" \
+ --cc="${CC}" \
+ --extra-cflags="${CPPFLAGS} ${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --extra-libs="${LIBS}" \
+ --enable-shared
+MAKE_ARGS= STRIP="${STRIP_CMD}"
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/-Os //; /=.*-fexcess-precision/d' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/SHARED/,/^$$/ { /STRIP/s/-x //; }' \
+ ${WRKSRC}/${MAKEFILE}
+
+.include <bsd.port.mk>
diff --git a/multimedia/l-smash/distinfo b/multimedia/l-smash/distinfo
new file mode 100644
index 000000000000..5d7b7da8ce8e
--- /dev/null
+++ b/multimedia/l-smash/distinfo
@@ -0,0 +1,2 @@
+SHA256 (l-smash-l-smash-v2.9.1_GH0.tar.gz) = 17f24fc8bffba753f8c628f1732fc3581b80362341274747ef6fb96af1cac45c
+SIZE (l-smash-l-smash-v2.9.1_GH0.tar.gz) = 450834
diff --git a/multimedia/l-smash/pkg-descr b/multimedia/l-smash/pkg-descr
new file mode 100644
index 000000000000..3c60d8605a57
--- /dev/null
+++ b/multimedia/l-smash/pkg-descr
@@ -0,0 +1,4 @@
+L-SMASH is a cross-platform library for dealing with ISO Base Media
+derived formats, including MP4.
+
+WWW: https://l-smash.github.io/l-smash/
diff --git a/multimedia/l-smash/pkg-plist b/multimedia/l-smash/pkg-plist
new file mode 100644
index 000000000000..d0e297ce0efa
--- /dev/null
+++ b/multimedia/l-smash/pkg-plist
@@ -0,0 +1,9 @@
+bin/boxdumper
+bin/muxer
+bin/remuxer
+bin/timelineeditor
+include/lsmash.h
+lib/liblsmash.a
+lib/liblsmash.so
+lib/liblsmash.so.2
+libdata/pkgconfig/liblsmash.pc