aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-01-05 19:57:37 +0800
committerjbeich <jbeich@FreeBSD.org>2018-01-05 19:57:37 +0800
commit3e577a4d8171e791766f9009fd070d9ab84cafe2 (patch)
treef7a3e5f649b528b726315f08ed1c871bcaf0ff86 /multimedia
parenta82b0cea8044d60873e175f24ed6492758fbd834 (diff)
downloadfreebsd-ports-gnome-3e577a4d8171e791766f9009fd070d9ab84cafe2.tar.gz
freebsd-ports-gnome-3e577a4d8171e791766f9009fd070d9ab84cafe2.tar.zst
freebsd-ports-gnome-3e577a4d8171e791766f9009fd070d9ab84cafe2.zip
multimedia/smpeg2: unbreak build with Clang 6 (C++14 by default)
audio/hufftable.cpp:553:8: error: constant expression evaluates to -1 which cannot be narrowed to type 'unsigned int' [-Wc++11-narrowing] { 0, 0-1, 0-1, 0, 0, htd33}, ^~~ audio/hufftable.cpp:553:8: note: insert an explicit cast to silence this issue { 0, 0-1, 0-1, 0, 0, htd33}, ^~~ static_cast<unsigned int>( ) audio/hufftable.cpp:553:13: error: constant expression evaluates to -1 which cannot be narrowed to type 'unsigned int' [-Wc++11-narrowing] { 0, 0-1, 0-1, 0, 0, htd33}, ^~~ audio/hufftable.cpp:553:13: note: insert an explicit cast to silence this issue { 0, 0-1, 0-1, 0, 0, htd33}, ^~~ static_cast<unsigned int>( ) audio/hufftable.cpp:557:8: error: constant expression evaluates to -1 which cannot be narrowed to type 'unsigned int' [-Wc++11-narrowing] { 4, 0-1, 0-1, 0, 0, htd33}, ^~~ audio/hufftable.cpp:557:8: note: insert an explicit cast to silence this issue { 4, 0-1, 0-1, 0, 0, htd33}, ^~~ static_cast<unsigned int>( ) audio/hufftable.cpp:557:13: error: constant expression evaluates to -1 which cannot be narrowed to type 'unsigned int' [-Wc++11-narrowing] { 4, 0-1, 0-1, 0, 0, htd33}, ^~~ audio/hufftable.cpp:557:13: note: insert an explicit cast to silence this issue { 4, 0-1, 0-1, 0, 0, htd33}, ^~~ static_cast<unsigned int>( ) audio/hufftable.cpp:567:8: error: constant expression evaluates to -1 which cannot be narrowed to type 'unsigned int' [-Wc++11-narrowing] {14, 0-1, 0-1, 0, 0, htd33}, ^~~ audio/hufftable.cpp:567:8: note: insert an explicit cast to silence this issue {14, 0-1, 0-1, 0, 0, htd33}, ^~~ static_cast<unsigned int>( ) audio/hufftable.cpp:567:13: error: constant expression evaluates to -1 which cannot be narrowed to type 'unsigned int' [-Wc++11-narrowing] {14, 0-1, 0-1, 0, 0, htd33}, ^~~ audio/hufftable.cpp:567:13: note: insert an explicit cast to silence this issue {14, 0-1, 0-1, 0, 0, htd33}, ^~~ static_cast<unsigned int>( ) Reported by: antoine (via bug 224669) Obtained from: r458130
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/smpeg2/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/multimedia/smpeg2/Makefile b/multimedia/smpeg2/Makefile
index 0ece9e825b8e..fa4500917fdd 100644
--- a/multimedia/smpeg2/Makefile
+++ b/multimedia/smpeg2/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= multi
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= libtool
+CFLAGS+= ${COMPILER_FEATURES:Mc++11:C/.+/-Wno-error=narrowing/}
+USES= compiler:features libtool
USE_SDL= sdl2
USE_LDCONFIG= yes