aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2018-02-18 18:06:56 +0800
committerrakuco <rakuco@FreeBSD.org>2018-02-18 18:06:56 +0800
commit4b7c7fe514bbef076f0e3c96e4340c6e9164b768 (patch)
treeede6537f40b829d9e995ceed40c323912e462373 /multimedia
parenta73ab50180133f167ad76479714befdd22598283 (diff)
downloadfreebsd-ports-gnome-4b7c7fe514bbef076f0e3c96e4340c6e9164b768.tar.gz
freebsd-ports-gnome-4b7c7fe514bbef076f0e3c96e4340c6e9164b768.tar.zst
freebsd-ports-gnome-4b7c7fe514bbef076f0e3c96e4340c6e9164b768.zip
Fix the build with clang 6.
There's no point in making old, unmaintained code be C++11 compliant, so just build with -std=gnu++98. qvideosurfacegstsink.cpp:345:73: error: constant expression evaluates to 4278190080 which cannot be narrowed to type 'int' [-Wc++11-narrowing] { QVideoFrame::Format_RGB32 , 32, 24, 4321, 0x0000FF00, 0x00FF0000, 0xFF000000, 0x00000000 }, ^~~~~~~~~~ (and others)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/qt4-mobility/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/multimedia/qt4-mobility/Makefile b/multimedia/qt4-mobility/Makefile
index 9885e5ec4e18..31f2b1058514 100644
--- a/multimedia/qt4-mobility/Makefile
+++ b/multimedia/qt4-mobility/Makefile
@@ -29,6 +29,8 @@ OPTIONS_DEFINE= BEARER CONNECTIVITY CONTACTS FEEDBACK GALLERY LOCATION \
SERVICEFRAMEWORK SYSTEMINFO VERSIT
OPTIONS_SUB= yes
+USE_CXXSTD= gnu++98
+
BEARER_DESC= Bearer module
CONNECTIVITY_DESC= Connectivity module
CONNECTIVITY_USE= qt4=rcc_build