aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjsa <jsa@FreeBSD.org>2010-08-22 13:07:38 +0800
committerjsa <jsa@FreeBSD.org>2010-08-22 13:07:38 +0800
commit64d0b78d411ac738c1636738699d20ca34882666 (patch)
treeb603bbb30920f93f967e152bd44e34f895dfbb0d /multimedia
parent8aaaab66cc8f1c6d6b5e3c7b046cd5fbc80d4421 (diff)
downloadfreebsd-ports-gnome-64d0b78d411ac738c1636738699d20ca34882666.tar.gz
freebsd-ports-gnome-64d0b78d411ac738c1636738699d20ca34882666.tar.zst
freebsd-ports-gnome-64d0b78d411ac738c1636738699d20ca34882666.zip
Re-enabled the Mozilla plugin, off by default. Thanks to decke for getting
this bit working again. Also, mark this port MAKE_JOBS_SAFE while we are here. Approved by: wxs (mentor)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vlc/Makefile32
1 files changed, 30 insertions, 2 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index d888c4fd5e73..478077fbe1be 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -54,6 +54,7 @@ OPTIONS= A52 "A52 DVD audio decoder" On \
OCFLAGS "Optimized CFLAGS" Off \
OGG "Ogg audio decoder support" On \
OPENGL "OpenGL acceleration support" Off \
+ PLUGIN "VLC Mozilla Plugin" Off \
PNG "PNG graphics format support" On \
PORTAUDIO "Portaudio library support" Off \
PULSE "Pulse Audio support" Off \
@@ -87,7 +88,8 @@ OPTIONS= A52 "A52 DVD audio decoder" On \
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
-USE_PERL5_BUILD= yes
+USE_PERL5_BUILD=yes
+MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
FAKEDIR= ${WRKDIR}/fake${PREFIX}
@@ -436,6 +438,19 @@ CONFIGURE_ARGS+=--enable-opengl
CONFIGURE_ARGS+=--disable-opengl
.endif
+.if defined(WITH_PLUGIN)
+USE_GECKO= libxul
+USE_WEBPLUGINS= gecko*
+WEBPLUGINS_FILES=libvlcplugin.so
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
+CONFIGURE_ENV+= MOZILLA_CONFIG="${GECKO_CONFIG}" \
+ XPIDL="${XPIDL}" \
+ XPIDL_INCL="${XPIDL_INCL}"
+CONFIGURE_ARGS+=--enable-mozilla
+.else
+CONFIGURE_ARGS+=--disable-mozilla
+.endif
+
.if defined(WITHOUT_PNG)
CONFIGURE_ARGS+=--disable-png
.else
@@ -646,6 +661,11 @@ post-patch:
${WRKSRC}/include/vlc_config.h
${REINPLACE_CMD} -e 's|portaudio\.h|portaudio2/&|g' \
${WRKSRC}/modules/audio_output/portaudio.c
+.if defined(WITH_PLUGIN)
+ @${REINPLACE_CMD} -e 's|npvlcdir = $$(libdir)/mozilla/plugins|npvlcdir = ${WEBPLUGINS_DIR}|g' \
+ ${WRKSRC}/projects/mozilla/Makefile.am \
+ ${WRKSRC}/projects/mozilla/Makefile.in
+.endif
pre-install:
${RM} -rf ${PLIST} ${FAKEDIR}
@@ -667,6 +687,14 @@ pre-install:
${RM} -f ${FAKEDIR}/lib/vlc/plugins/services_discovery/libsap_plugin.la
${RM} -f ${FAKEDIR}/lib/vlc/plugins/services_discovery/libsap_plugin.so
.endif
+.if defined(WITH_PLUGIN)
+.for ext in so la
+ ${ECHO_CMD} "${WEBPLUGINS_DIR}/libvlcplugin.${ext}" | \
+ ${SED} -e 's|${PREFIX}/||' >> ${PLIST}
+.endfor
+ ${ECHO_CMD} "@dirrmtry ${WEBPLUGINS_DIR}" | \
+ ${SED} -e 's|${PREFIX}/||' >> ${PLIST}
+.endif
cd ${FAKEDIR}/lib && ${FIND} -s * -type f -o -type l| \
${SED} -e 's|^|lib/|' >> ${PLIST} \
&& ${FIND} -d * -type d | \
@@ -722,6 +750,6 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/doc/vlc-config.1 ${MANPREFIX}/man/man1/
if [ ! -d ${PREFIX}/share/applications ]; then \
${MKDIR} ${PREFIX}/share/applications ; \
- fi
+fi
.include <bsd.port.post.mk>