aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-11-15 00:12:56 +0800
committertcberner <tcberner@FreeBSD.org>2016-11-15 00:12:56 +0800
commit6c5965ba9ac4e94e995d4e16a6b052b416a4b6cf (patch)
treedbe08499461c3eea79dce8b1eca87e2699ef0d1c /multimedia
parentbf14630d264a9160dc837c514f487902a2f64259 (diff)
downloadfreebsd-ports-gnome-6c5965ba9ac4e94e995d4e16a6b052b416a4b6cf.tar.gz
freebsd-ports-gnome-6c5965ba9ac4e94e995d4e16a6b052b416a4b6cf.tar.zst
freebsd-ports-gnome-6c5965ba9ac4e94e995d4e16a6b052b416a4b6cf.zip
Importing KDE Frameworks into the ports tree (required for newer KDE Desktop and Applications)
KDE Frameworks is a collection of libraries and software frameworks by KDE that serve as technological foundation for KDE Plasma 5 and KDE Applications distributed under the GNU Lesser General Public License (LGPL) [1]. The work is based on what we have in the KDE testing repo [2]. This is the next big step in updating the KDE Desktop and its Applications to anything less dusty. With this change, `USES=kde:5` is now a valid option. Ports that need to depend on KDE Framework can now set: USES=kde:5 USE_KDE=<framework1> <framework2> ... <frameworkX> For example: www/qupzilla-qt5 can depend on sysutils/kf5-kwallet via: KWALLET_USE= KDE=wallet I would like to thank Raphael and Adriaan for reviewing the ports in the testing repo :) [1] https://en.wikipedia.org/wiki/KDE_Frameworks [2] http://src.mouf.net/area51/log/branches/plasma5 Reviewed by: rakuco, mat, groot_kde.org Approved by: rakuco (maintainer) Differential Revision: https://reviews.freebsd.org/D8329
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/kf5-kmediaplayer/Makefile18
-rw-r--r--multimedia/kf5-kmediaplayer/distinfo3
-rw-r--r--multimedia/kf5-kmediaplayer/pkg-descr4
-rw-r--r--multimedia/kf5-kmediaplayer/pkg-plist16
-rw-r--r--multimedia/qt5-phonon4-designerplugin/Makefile5
-rw-r--r--multimedia/qt5-phonon4-gstreamer/Makefile5
-rw-r--r--multimedia/qt5-phonon4-vlc/Makefile4
-rw-r--r--multimedia/qt5-phonon4/Makefile4
9 files changed, 50 insertions, 10 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 1af4eb476088..b7a2bdab3cef 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -165,6 +165,7 @@
SUBDIR += kdemultimedia4-ffmpegthumbs
SUBDIR += kdemultimedia4-mplayerthumbs
SUBDIR += kdenlive
+ SUBDIR += kf5-kmediaplayer
SUBDIR += kissdx
SUBDIR += kmplayer-kde4
SUBDIR += kodi
diff --git a/multimedia/kf5-kmediaplayer/Makefile b/multimedia/kf5-kmediaplayer/Makefile
new file mode 100644
index 000000000000..1d3d2c4a978a
--- /dev/null
+++ b/multimedia/kf5-kmediaplayer/Makefile
@@ -0,0 +1,18 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= kmediaplayer
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= multimedia kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 plugin interface for media player features
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= auth codecs completion config configwidgets coreaddons \
+ ecm i18n jobwidgets kio parts service sonnet textwidgets \
+ widgetsaddons xmlgui
+USE_QT5= buildtools_build core dbus gui network qmake_build \
+ testlib widgets xml
+
+.include <bsd.port.mk>
diff --git a/multimedia/kf5-kmediaplayer/distinfo b/multimedia/kf5-kmediaplayer/distinfo
new file mode 100644
index 000000000000..7e21e9a2e861
--- /dev/null
+++ b/multimedia/kf5-kmediaplayer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475424080
+SHA256 (KDE/frameworks/5.27.0/kmediaplayer-5.27.0.tar.xz) = 1d951602a8bc39283e21814eea521bfeca893f55efdf6921f7e0dc4f45db7200
+SIZE (KDE/frameworks/5.27.0/kmediaplayer-5.27.0.tar.xz) = 9520
diff --git a/multimedia/kf5-kmediaplayer/pkg-descr b/multimedia/kf5-kmediaplayer/pkg-descr
new file mode 100644
index 000000000000..e7384734ee29
--- /dev/null
+++ b/multimedia/kf5-kmediaplayer/pkg-descr
@@ -0,0 +1,4 @@
+KMediaPlayer builds on the KParts framework to provide a common interface for
+KParts that can play media files.
+
+WWW: https://api.kde.org/frameworks/kmediaplayer/html/index.html
diff --git a/multimedia/kf5-kmediaplayer/pkg-plist b/multimedia/kf5-kmediaplayer/pkg-plist
new file mode 100644
index 000000000000..297586bdcba1
--- /dev/null
+++ b/multimedia/kf5-kmediaplayer/pkg-plist
@@ -0,0 +1,16 @@
+include/KF5/KMediaPlayer/KMediaPlayer/Player
+include/KF5/KMediaPlayer/KMediaPlayer/View
+include/KF5/KMediaPlayer/kmediaplayer/kmediaplayer_export.h
+include/KF5/KMediaPlayer/kmediaplayer/player.h
+include/KF5/KMediaPlayer/kmediaplayer/view.h
+include/KF5/kmediaplayer_version.h
+lib/cmake/KF5MediaPlayer/KF5MediaPlayerConfig.cmake
+lib/cmake/KF5MediaPlayer/KF5MediaPlayerConfigVersion.cmake
+lib/cmake/KF5MediaPlayer/KF5MediaPlayerTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5MediaPlayer/KF5MediaPlayerTargets.cmake
+lib/libKF5MediaPlayer.so
+lib/libKF5MediaPlayer.so.5
+lib/libKF5MediaPlayer.so.%%KDE_FRAMEWORKS_VERSION%%
+share/dbus-1/interfaces/kf5_org.kde.KMediaPlayer.xml
+share/kservicetypes5/kmediaplayer.desktop
+share/kservicetypes5/kmediaplayerengine.desktop
diff --git a/multimedia/qt5-phonon4-designerplugin/Makefile b/multimedia/qt5-phonon4-designerplugin/Makefile
index f0c216005418..e62b2dfaca30 100644
--- a/multimedia/qt5-phonon4-designerplugin/Makefile
+++ b/multimedia/qt5-phonon4-designerplugin/Makefile
@@ -14,9 +14,8 @@ COMMENT= Qt 5 Designer plugin for Phonon 4
LICENSE= LGPL21
-BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/extra-cmake-modules
-
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:5 tar:xz
+USE_KDE= ecm
USE_QT5= buildtools_build qmake_build designer phonon4
CMAKE_ARGS= -DPHONON_QT_PLUGIN_INSTALL_DIR=${PREFIX}/${QT_PLUGINDIR_REL}/designer \
-DPHONON_BUILD_PHONON4QT5=ON
diff --git a/multimedia/qt5-phonon4-gstreamer/Makefile b/multimedia/qt5-phonon4-gstreamer/Makefile
index 6a8cd8f82520..0b81287fa25a 100644
--- a/multimedia/qt5-phonon4-gstreamer/Makefile
+++ b/multimedia/qt5-phonon4-gstreamer/Makefile
@@ -15,14 +15,13 @@ COMMENT= GStreamer backend for Phonon 4 Qt 5
LICENSE= LGPL21
-BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/extra-cmake-modules
-
WRKSRC= ${WRKDIR}/${DISTNAME:S/-backend//}
-USES= cmake:outsource pkgconfig tar:xz
+USES= cmake:outsource kde:5 pkgconfig tar:xz
USE_GL= gl
USE_GNOME= glib20 libxml2
USE_GSTREAMER1= yes
+USE_KDE= ecm
USE_QT5= buildtools_build qmake_build core gui opengl phonon4 widgets \
x11extras
CMAKE_ARGS= -DPHONON_BUILD_PHONON4QT5=ON
diff --git a/multimedia/qt5-phonon4-vlc/Makefile b/multimedia/qt5-phonon4-vlc/Makefile
index 98edd89efa4b..bc8ea580a79b 100644
--- a/multimedia/qt5-phonon4-vlc/Makefile
+++ b/multimedia/qt5-phonon4-vlc/Makefile
@@ -12,12 +12,12 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= VLC backend for Phonon 4 Qt 5
-BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/extra-cmake-modules
LIB_DEPENDS= libvlc.so:multimedia/vlc
WRKSRC= ${WRKDIR}/${DISTNAME:S/-backend//}
-USES= cmake:outsource pkgconfig tar:xz
+USES= cmake:outsource kde:5 pkgconfig tar:xz
+USE_KDE= ecm
USE_QT5= core gui widgets phonon4 \
buildtools_build qmake_build
CMAKE_ARGS= -DPHONON_BUILD_PHONON4QT5=ON
diff --git a/multimedia/qt5-phonon4/Makefile b/multimedia/qt5-phonon4/Makefile
index 6bc7408e5371..152ab10fcf92 100644
--- a/multimedia/qt5-phonon4/Makefile
+++ b/multimedia/qt5-phonon4/Makefile
@@ -14,9 +14,9 @@ COMMENT= Phonon 4 transitional library for Qt 5
LICENSE= LGPL21
-BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/extra-cmake-modules
-USES= cmake:outsource pathfix tar:xz
+USES= cmake:outsource kde:5 pathfix tar:xz
+USE_KDE= ecm
USE_QT5= core dbus gui opengl widgets \
buildtools_build qmake_build
CMAKE_ARGS= -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=TRUE \