aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-03-05 03:11:34 +0800
committeryuri <yuri@FreeBSD.org>2018-03-05 03:11:34 +0800
commit706c17f19a46fd4e312328f1beffbdbe1b7a33e6 (patch)
treeaee48cf90b2dc8d8f2b85eaaf84307090be2ea47 /multimedia
parent77eb24cea36a387fe6a7275e78f2248c43fe258d (diff)
downloadfreebsd-ports-gnome-706c17f19a46fd4e312328f1beffbdbe1b7a33e6.tar.gz
freebsd-ports-gnome-706c17f19a46fd4e312328f1beffbdbe1b7a33e6.tar.zst
freebsd-ports-gnome-706c17f19a46fd4e312328f1beffbdbe1b7a33e6.zip
New port: multimedia/nostt: Command line NOS Teletekst reader, the Dutch public teletext system
PR: 226347 Submitted by: Sijmen J. Mulder <ik@sjmulder.nl> Approved by: tcberner (mentor, implicit)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/nostt/Makefile27
-rw-r--r--multimedia/nostt/distinfo3
-rw-r--r--multimedia/nostt/pkg-descr9
4 files changed, 40 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 2de6bbfccf61..ff902d03131c 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -278,6 +278,7 @@
SUBDIR += mythtv-frontend
SUBDIR += naludump
SUBDIR += nordlicht
+ SUBDIR += nostt
SUBDIR += obs-studio
SUBDIR += oggvideotools
SUBDIR += ogmrip
diff --git a/multimedia/nostt/Makefile b/multimedia/nostt/Makefile
new file mode 100644
index 000000000000..8bdd5e7a2b1b
--- /dev/null
+++ b/multimedia/nostt/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= nostt
+DISTVERSION= 1.0
+CATEGORIES= multimedia
+
+MAINTAINER= ik@sjmulder.nl
+COMMENT= Command line NOS Teletekst reader, the Dutch public teletext system
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libjson-c.so:devel/json-c
+
+USES= localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= sjmulder
+
+PLIST_FILES= bin/nostt \
+ man/man1/nostt.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nostt ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/nostt.1 ${STAGEDIR}${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/multimedia/nostt/distinfo b/multimedia/nostt/distinfo
new file mode 100644
index 000000000000..311e935d6d60
--- /dev/null
+++ b/multimedia/nostt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520189422
+SHA256 (sjmulder-nostt-1.0_GH0.tar.gz) = f7f353eb13296b5cfe030cf7fa7f1456d6293f06b061e930f2b3a6fe48a20071
+SIZE (sjmulder-nostt-1.0_GH0.tar.gz) = 7812
diff --git a/multimedia/nostt/pkg-descr b/multimedia/nostt/pkg-descr
new file mode 100644
index 000000000000..adcdb49907fa
--- /dev/null
+++ b/multimedia/nostt/pkg-descr
@@ -0,0 +1,9 @@
+nostt is a command line reader for NOS Teletekst, the Dutch public teletext
+system (like Ceefax in the UK). It supports color and has an interactive mode.
+
+Note that teletext supports 6-cell (2x3) block drawing characters. The NOS
+viewer and API use a custom font with these characters in the "private use"
+0xF000 Unicode range. Because such characters are not usually available on
+terminals, they are replaced by % characaters.
+
+WWW: https://github.com/sjmulder/nostt