aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-29 00:23:47 +0800
committerpav <pav@FreeBSD.org>2004-05-29 00:23:47 +0800
commit8464403c6c57c2bd05d00b853bf64870f55e25bd (patch)
tree49678866a8c1b5b39c58cab3bb2b4551b25fe50f /multimedia
parent3f6e6a05bc497128987ce4d55075c5b70e895799 (diff)
downloadfreebsd-ports-gnome-8464403c6c57c2bd05d00b853bf64870f55e25bd.tar.gz
freebsd-ports-gnome-8464403c6c57c2bd05d00b853bf64870f55e25bd.tar.zst
freebsd-ports-gnome-8464403c6c57c2bd05d00b853bf64870f55e25bd.zip
- Fix reopening of audio device after pause under certain circumstances
PR: ports/67179 Submitted by: Andriy Gapon <avg@icyb.net.ua> Approved by: maintainer Obtained from: mplayer CVS
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mplayer/files/patch-libao2-ao_oss.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 013a9a5b34a0..58158c16095d 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -206,7 +206,7 @@
PORTNAME= mplayer
PORTVERSION= 0.92.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio ipv6
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
diff --git a/multimedia/mplayer/files/patch-libao2-ao_oss.c b/multimedia/mplayer/files/patch-libao2-ao_oss.c
new file mode 100644
index 000000000000..c384d1da90a4
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libao2-ao_oss.c
@@ -0,0 +1,15 @@
+--- libao2/ao_oss.c.orig Sun Jul 27 13:41:36 2003
++++ libao2/ao_oss.c Sun Jul 27 13:49:37 2003
+@@ -247,7 +247,11 @@
+ mp_msg(MSGT_AO,MSGL_ERR,"\nFatal error: *** CANNOT RE-OPEN / RESET AUDIO DEVICE *** %s\n", strerror(errno));
+ return;
+ }
+-
++
++#if defined(FD_CLOEXEC) && defined(F_SETFD)
++ fcntl(audio_fd, F_SETFD, FD_CLOEXEC);
++#endif
++
+ ioctl (audio_fd, SNDCTL_DSP_SETFMT, &ao_data.format);
+ if(ao_data.format != AFMT_AC3) {
+ if (ao_data.channels > 2)