aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-12-18 11:00:41 +0800
committerlinimon <linimon@FreeBSD.org>2017-12-18 11:00:41 +0800
commite5af7935daee6352daa3af5c4f2e5bdf024126d8 (patch)
tree1edd52cac39d7d9b0dead2ee04828d9d082681cb /multimedia
parent5b2f5ad0349beb74b43f48e60a8d53dbe1e7ae16 (diff)
downloadfreebsd-ports-gnome-e5af7935daee6352daa3af5c4f2e5bdf024126d8.tar.gz
freebsd-ports-gnome-e5af7935daee6352daa3af5c4f2e5bdf024126d8.tar.zst
freebsd-ports-gnome-e5af7935daee6352daa3af5c4f2e5bdf024126d8.zip
Mark broken on aarch64. It looks like this Makefile could use some
modernizing. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/avidemux/Makefile.common8
1 files changed, 5 insertions, 3 deletions
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index 4e329f8415d5..75b96752e55b 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -71,7 +71,7 @@ PLIST_SUB+= NLS="@comment " QT_NLS="@comment "
# for libexecinfo: (so that __builtin_frame_address() finds the top
# of the stack)
-.if ${ARCH} == "amd64"
+.if ${ARCH} == amd64
CFLAGS+= -fno-omit-frame-pointer
#MAKE_ENV+= ARCH=x86_64
#CONFIGURE_ENV+= ARCH=x86_64
@@ -271,8 +271,10 @@ LDFLAGS+= -lc++
USE_GCC= yes
#.endif
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
+.if ${ARCH} == aarch64
+BROKEN= cmake/admDetermineSystem.cmake:78: CPU not supported
+.elif ${ARCH} == powerpc || ${ARCH} == sparc64
+BROKEN= Does not compile on powerpc or sparc64
.endif
post-patch: