aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2009-11-23 04:28:29 +0800
committerlioux <lioux@FreeBSD.org>2009-11-23 04:28:29 +0800
commit196e64101986b011918aca09dd3e034b3cf14cdc (patch)
tree670027f3c7e17796988002d3428caae0269fef9d /multimedia
parent7ca4a368ab3160c6381b4d0b90a50d20745243b4 (diff)
downloadfreebsd-ports-gnome-196e64101986b011918aca09dd3e034b3cf14cdc.tar.gz
freebsd-ports-gnome-196e64101986b011918aca09dd3e034b3cf14cdc.tar.zst
freebsd-ports-gnome-196e64101986b011918aca09dd3e034b3cf14cdc.zip
- Fix build on systems where GCC stack protection (aka Propolice)
was enabled for userland on src/share/mk/bsd.sys.mk (SVN rev 180012 on 2008-06-25 21:33:28Z by ru) - For OSVERSION >= 800040, add -fstack-protector to LDFLAGS
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/x264-devel/Makefile7
-rw-r--r--multimedia/x264/Makefile7
2 files changed, 14 insertions, 0 deletions
diff --git a/multimedia/x264-devel/Makefile b/multimedia/x264-devel/Makefile
index ace2002880f1..b315b2be58bf 100644
--- a/multimedia/x264-devel/Makefile
+++ b/multimedia/x264-devel/Makefile
@@ -40,6 +40,13 @@ CONFIGURE_ARGS+= --extra-cflags="${CPPFLAGS} ${CFLAGS} -fPIC -I${LOCALBASE}/incl
.include <bsd.port.pre.mk>
+# Around the time GCC stack protection (aka Propolice) for userland
+# was enabled on src/share/mk/bsd.sys.mk
+# SVN rev 180012 on 2008-06-25 21:33:28Z by ru
+.if ${OSVERSION} >= 800040
+LDFLAGS+= -fstack-protector
+.endif
+
.if ${ARCH}=="i386"
MAKE_ENV+= ARCH_X86="1"
.endif
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index ace2002880f1..b315b2be58bf 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -40,6 +40,13 @@ CONFIGURE_ARGS+= --extra-cflags="${CPPFLAGS} ${CFLAGS} -fPIC -I${LOCALBASE}/incl
.include <bsd.port.pre.mk>
+# Around the time GCC stack protection (aka Propolice) for userland
+# was enabled on src/share/mk/bsd.sys.mk
+# SVN rev 180012 on 2008-06-25 21:33:28Z by ru
+.if ${OSVERSION} >= 800040
+LDFLAGS+= -fstack-protector
+.endif
+
.if ${ARCH}=="i386"
MAKE_ENV+= ARCH_X86="1"
.endif