aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2018-08-01 06:00:53 +0800
committerjhale <jhale@FreeBSD.org>2018-08-01 06:00:53 +0800
commit542d15f1bf5b9540c04a5ac0e128bfda6fcd17db (patch)
tree17a4aff2fac81f99374dfbb4baa9e8419bae0112 /multimedia
parent039db5272a17136b3dd5c4d3327142cb46f87d87 (diff)
downloadfreebsd-ports-gnome-542d15f1bf5b9540c04a5ac0e128bfda6fcd17db.tar.gz
freebsd-ports-gnome-542d15f1bf5b9540c04a5ac0e128bfda6fcd17db.tar.zst
freebsd-ports-gnome-542d15f1bf5b9540c04a5ac0e128bfda6fcd17db.zip
Remove the BRAINZ3 option.
The webservice provided by audio/libmusicbrainz3 will cease operation on 2018-08-01. Libmusicbrainz3 has been marked deprecated for 6 months and is scheduled for removal. https://blog.musicbrainz.org/2018/02/01/web-service-ver-1-0-ws-1-will-be-removed-in-6-months/ While here, convert the rest of the options logic to options helpers.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gnome-mplayer/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/multimedia/gnome-mplayer/Makefile b/multimedia/gnome-mplayer/Makefile
index 52b5dc9e6e30..528da1fadcc7 100644
--- a/multimedia/gnome-mplayer/Makefile
+++ b/multimedia/gnome-mplayer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnome-mplayer
PORTVERSION= 1.0.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia gnome
MASTER_SITES= https://launchpad.net/ubuntu/+archive/primary/+files/
DISTNAME= gnome-mplayer_1.0.9.orig
@@ -24,7 +24,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nautilus \
--disable-nemo \
--disable-schemas-install \
- --without-libgda
+ --without-libgda \
+ --without-libmusicbrainz3
INSTALLS_ICONS= yes
WRKSRC= ${WRKDIR}/gnome-mplayer-${PORTVERSION}
@@ -35,21 +36,18 @@ GLIB_SCHEMAS= apps.gecko-mediaplayer.preferences.gschema.xml \
apps.gnome-mplayer.preferences.enums.xml \
apps.gnome-mplayer.preferences.gschema.xml
-OPTIONS_DEFINE= ALSA BRAINZ3 DOCS GIO GPOD GTK3 NOTIFY PULSEAUDIO
+OPTIONS_DEFINE= ALSA DOCS GIO GPOD GTK3 NOTIFY PULSEAUDIO
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_RUN_DEPENDS= alsa-plugins>0:audio/alsa-plugins
ALSA_CONFIGURE_WITH= alsa
-BRAINZ3_DESC= Add support for libmusicbrainz
-BRAINZ3_LIB_DEPENDS= libmusicbrainz3.so:audio/libmusicbrainz3 \
- libcurl.so:ftp/curl
-BRAINZ3_CONFIGURE_WITH= libmusicbrainz3
GIO_DESC= Use GIO for file I/O
GIO_CONFIGURE_WITH= gio
GPOD_DESC= Add support for libgpod
GPOD_LIB_DEPENDS= libgpod.so:audio/libgpod
GPOD_CONFIGURE_WITH= libgpod
GTK3_USE= gnome=gtk30
+GTK3_USE_OFF= gnome=gtk20
GTK3_CONFIGURE_ENABLE= gtk3
NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
NOTIFY_RUN_DEPENDS= notification-daemon>0:deskutils/notification-daemon
@@ -57,12 +55,6 @@ NOTIFY_CONFIGURE_WITH= libnotify
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_WITH= pulseaudio
-.include <bsd.port.options.mk>
-
-.if !${PORT_OPTIONS:MGTK3}
-USE_GNOME+= gtk20
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
'/COPYING\\/d ; \