aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-05-10 22:14:10 +0800
committerkwm <kwm@FreeBSD.org>2013-05-10 22:14:10 +0800
commit695b3aead5ab9987d9d809746db69f307636d9d6 (patch)
tree96e5b792d99506d8eb177ceffcd916f1fff893d3 /multimedia
parent5ab67ae3520d5113fd9c120b72575901b0b5db91 (diff)
downloadfreebsd-ports-gnome-695b3aead5ab9987d9d809746db69f307636d9d6.tar.gz
freebsd-ports-gnome-695b3aead5ab9987d9d809746db69f307636d9d6.tar.zst
freebsd-ports-gnome-695b3aead5ab9987d9d809746db69f307636d9d6.zip
Add USE_GCC=any as a temporary patch to work around a crash in the clang
compiler after the 3.3 update. The problem was reported upstream but no patch available yet. Submitted by: miwi
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer-plugins/Makefile3
-rw-r--r--multimedia/gstreamer/Makefile2
2 files changed, 5 insertions, 0 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 671c660fdcbd..2e4ae1b16503 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -55,6 +55,9 @@ CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${EXTRA_LIBS} ${PTHREAD_LIBS}
CFLAGS+= -I${LOCALBASE}/include
+# workaround a crash in clang 3.3 crash llvm bug # 15840
+USE_GCC= any
+
DEFAULT_AUDIOSINK?= osssink
DEFAULT_AUDIOSRC?= osssrc
diff --git a/multimedia/gstreamer/Makefile b/multimedia/gstreamer/Makefile
index 1ac3cc094b47..0672024bcb2d 100644
--- a/multimedia/gstreamer/Makefile
+++ b/multimedia/gstreamer/Makefile
@@ -18,6 +18,8 @@ LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
CFLAGS:= ${CFLAGS} -O2 -Wno-format
USES= bison pathfix pkgconfig gettext
+# workaround a crash in clang 3.3 crash llvm bug # 15840
+USE_GCC= any
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= glib20 libxml2 ltverhack ltasneededhack