aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2015-01-27 05:32:37 +0800
committerthierry <thierry@FreeBSD.org>2015-01-27 05:32:37 +0800
commita55b6961b2e5d37f1caa2322c62b4b9f03478fed (patch)
treedd374a6fed30233f754deef0348a10ea135c9353 /multimedia
parenta7c5c7f322a33ef3480a142c37e4d8ad75040617 (diff)
downloadfreebsd-ports-gnome-a55b6961b2e5d37f1caa2322c62b4b9f03478fed.tar.gz
freebsd-ports-gnome-a55b6961b2e5d37f1caa2322c62b4b9f03478fed.tar.zst
freebsd-ports-gnome-a55b6961b2e5d37f1caa2322c62b4b9f03478fed.zip
Upgrade to 0.6.6 .
Changelog at <http://freetuxtv.blogspot.fr/2014/01/freetuxtv-version-066.html>.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/freetuxtv/Makefile23
-rw-r--r--multimedia/freetuxtv/distinfo4
-rw-r--r--multimedia/freetuxtv/files/patch-data-ui-addchannelsgroups.glade184
-rw-r--r--multimedia/freetuxtv/pkg-plist13
4 files changed, 203 insertions, 21 deletions
diff --git a/multimedia/freetuxtv/Makefile b/multimedia/freetuxtv/Makefile
index 789d3d1bc780..897a1d870ed4 100644
--- a/multimedia/freetuxtv/Makefile
+++ b/multimedia/freetuxtv/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= freetuxtv
-PORTVERSION= 0.6.5
-PORTREVISION= 16
+PORTVERSION= 0.6.6
CATEGORIES= multimedia
MASTER_SITES= GOOGLE_CODE
MAINTAINER= ports@FreeBSD.org
-COMMENT= WebTV player based on GTK2+ and LibVLC
+COMMENT= WebTV player based on GTK3+ and LibVLC
LICENSE= GPLv3
@@ -16,12 +15,12 @@ LIB_DEPENDS= libvlc.so:${PORTSDIR}/multimedia/vlc \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
libcurl.so:${PORTSDIR}/ftp/curl \
- libnotify.so:${PORTSDIR}/devel/libnotify \
+ libnotify.so:${PORTSDIR}/devel/libnotify
USES= gmake iconv libtool pkgconfig
-USE_GNOME= gtk20
+USE_GNOME= gtk30
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gtk=2.0
+CONFIGURE_ARGS= --with-gtk=3.0
CFLAGS+= -Wno-return-type -w
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
@@ -34,19 +33,17 @@ OPTIONS_SUB= yes
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
+NLS_BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
SUB_FILES= pkg-message
-# Wrong versioning upstream, Upstream use GTK3 in newer Versions
-PORTSCOUT= ignore:1
-
-post-patch:
- @${REINPLACE_CMD} -e 's|$${pkgdatadir}/doc|$${pkgdocdir}|' \
+pre-configure:
+ ${REINPLACE_CMD} -e 's|$${pkgdatadir}/doc|$${pkgdocdir}|' \
-e 's|install-data-am: install-freetuxtvdocDATA|install-data-am: |' \
${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's/libvlc_media_new_path/libvlc_media_new_location/' \
+ ${REINPLACE_CMD} -e 's/libvlc_media_new_path/libvlc_media_new_location/' \
${WRKSRC}/lib/libvlc-gtk/gtk-libvlc-media-player.c
- @${REINPLACE_CMD} -e 's|g_strcasecmp|g_ascii_strcasecmp|' \
+ ${REINPLACE_CMD} -e 's|g_strcasecmp|g_ascii_strcasecmp|' \
${WRKSRC}/src/main.c
post-install:
diff --git a/multimedia/freetuxtv/distinfo b/multimedia/freetuxtv/distinfo
index f24c689c5f2d..850f674023ef 100644
--- a/multimedia/freetuxtv/distinfo
+++ b/multimedia/freetuxtv/distinfo
@@ -1,2 +1,2 @@
-SHA256 (freetuxtv-0.6.5.tar.gz) = aa437510fb192c7fcece4ef39344ea8098e2c66bd4878c95a425e02a25954356
-SIZE (freetuxtv-0.6.5.tar.gz) = 1445535
+SHA256 (freetuxtv-0.6.6.tar.gz) = 57c8831314ebb7d27b5bbf957306b04831db1d2d714c2dc5db5f4f84abf5ab7a
+SIZE (freetuxtv-0.6.6.tar.gz) = 1585142
diff --git a/multimedia/freetuxtv/files/patch-data-ui-addchannelsgroups.glade b/multimedia/freetuxtv/files/patch-data-ui-addchannelsgroups.glade
new file mode 100644
index 000000000000..63aeb75265fe
--- /dev/null
+++ b/multimedia/freetuxtv/files/patch-data-ui-addchannelsgroups.glade
@@ -0,0 +1,184 @@
+--- data/ui/addchannelsgroups.glade.orig 2014-01-18 15:47:31.000000000 +0100
++++ data/ui/addchannelsgroups.glade 2015-01-26 21:44:08.000000000 +0100
+@@ -1,7 +1,22 @@
+ <?xml version="1.0" encoding="UTF-8"?>
++<!-- Generated with glade 3.18.3 -->
++<!-- Patch from upstream r750 -->
+ <interface>
+- <requires lib="gtk+" version="2.20"/>
+- <!-- interface-naming-policy project-wide -->
++ <requires lib="gtk+" version="3.0"/>
++ <object class="GtkTreeStore" id="treestore_channelsgroup">
++ <columns>
++ <!-- column-name Name -->
++ <column type="gchararray"/>
++ <!-- column-name URI -->
++ <column type="gchararray"/>
++ <!-- column-name Required -->
++ <column type="gchararray"/>
++ <!-- column-name BRegex -->
++ <column type="gchararray"/>
++ <!-- column-name ERegex -->
++ <column type="gchararray"/>
++ </columns>
++ </object>
+ <object class="GtkDialog" id="dialogaddgroup">
+ <property name="can_focus">False</property>
+ <property name="border_width">5</property>
+@@ -11,24 +26,23 @@
+ <property name="default_height">450</property>
+ <property name="icon_name">freetuxtv</property>
+ <property name="type_hint">dialog</property>
+- <property name="has_separator">True</property>
+ <child internal-child="vbox">
+- <object class="GtkVBox" id="dialog-vbox2">
++ <object class="GtkBox" id="dialog-vbox2">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <property name="spacing">5</property>
+ <child internal-child="action_area">
+- <object class="GtkHButtonBox" id="dialog-action_area2">
++ <object class="GtkButtonBox" id="dialog-action_area2">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <property name="layout_style">end</property>
+ <child>
+ <object class="GtkButton" id="button_close">
+ <property name="label">gtk-close</property>
++ <property name="use_action_appearance">False</property>
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">True</property>
+- <property name="use_action_appearance">False</property>
+ <property name="use_stock">True</property>
+ </object>
+ <packing>
+@@ -40,10 +54,10 @@
+ <child>
+ <object class="GtkButton" id="button_add">
+ <property name="label">gtk-add</property>
++ <property name="use_action_appearance">False</property>
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">True</property>
+- <property name="use_action_appearance">False</property>
+ <property name="use_stock">True</property>
+ </object>
+ <packing>
+@@ -93,8 +107,6 @@
+ <property name="text" translatable="yes">http://freetuxtv.googlecode.com/svn/trunk/data/channels_groups.xml</property>
+ <property name="primary_icon_activatable">False</property>
+ <property name="secondary_icon_activatable">False</property>
+- <property name="primary_icon_sensitive">True</property>
+- <property name="secondary_icon_sensitive">True</property>
+ </object>
+ <packing>
+ <property name="expand">True</property>
+@@ -105,10 +117,10 @@
+ <child>
+ <object class="GtkButton" id="button_refresh">
+ <property name="label">gtk-refresh</property>
++ <property name="use_action_appearance">False</property>
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">True</property>
+- <property name="use_action_appearance">False</property>
+ <property name="use_stock">True</property>
+ </object>
+ <packing>
+@@ -142,8 +154,6 @@
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="border_width">3</property>
+- <property name="hscrollbar_policy">automatic</property>
+- <property name="vscrollbar_policy">automatic</property>
+ <property name="shadow_type">etched-in</property>
+ <child>
+ <object class="GtkTreeView" id="treeview_channelsgroups">
+@@ -153,6 +163,9 @@
+ <property name="headers_clickable">False</property>
+ <property name="expander_column">treeviewcolumn2</property>
+ <property name="search_column">0</property>
++ <child internal-child="selection">
++ <object class="GtkTreeSelection" id="treeview-selection1"/>
++ </child>
+ <child>
+ <object class="GtkTreeViewColumn" id="treeviewcolumn2">
+ <property name="title" translatable="yes">Languages/Channels group</property>
+@@ -235,8 +248,6 @@
+ <property name="tooltip_text" translatable="yes">Name of the group which will be added</property>
+ <property name="primary_icon_activatable">False</property>
+ <property name="secondary_icon_activatable">False</property>
+- <property name="primary_icon_sensitive">True</property>
+- <property name="secondary_icon_sensitive">True</property>
+ </object>
+ <packing>
+ <property name="left_attach">1</property>
+@@ -263,8 +274,6 @@
+ <property name="width_chars">50</property>
+ <property name="primary_icon_activatable">False</property>
+ <property name="secondary_icon_activatable">False</property>
+- <property name="primary_icon_sensitive">True</property>
+- <property name="secondary_icon_sensitive">True</property>
+ </object>
+ <packing>
+ <property name="left_attach">1</property>
+@@ -319,8 +328,6 @@
+ <property name="tooltip_text" translatable="yes">Text or regexp which must be deleted at the end of the channel's name</property>
+ <property name="primary_icon_activatable">False</property>
+ <property name="secondary_icon_activatable">False</property>
+- <property name="primary_icon_sensitive">True</property>
+- <property name="secondary_icon_sensitive">True</property>
+ </object>
+ <packing>
+ <property name="left_attach">1</property>
+@@ -346,8 +353,6 @@
+ <property name="tooltip_text" translatable="yes">Text or regexp which must be deleted at the beginning of the channel's name</property>
+ <property name="primary_icon_activatable">False</property>
+ <property name="secondary_icon_activatable">False</property>
+- <property name="primary_icon_sensitive">True</property>
+- <property name="secondary_icon_sensitive">True</property>
+ </object>
+ <packing>
+ <property name="left_attach">1</property>
+@@ -437,8 +442,6 @@
+ <property name="can_focus">True</property>
+ <property name="primary_icon_activatable">False</property>
+ <property name="secondary_icon_activatable">False</property>
+- <property name="primary_icon_sensitive">True</property>
+- <property name="secondary_icon_sensitive">True</property>
+ </object>
+ <packing>
+ <property name="left_attach">1</property>
+@@ -471,10 +474,11 @@
+ <child>
+ <object class="GtkRadioButton" id="radiobutton1">
+ <property name="label" translatable="yes">Favourites</property>
++ <property name="use_action_appearance">False</property>
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">False</property>
+- <property name="use_action_appearance">False</property>
++ <property name="xalign">0.5</property>
+ <property name="active">True</property>
+ <property name="draw_indicator">True</property>
+ </object>
+@@ -534,18 +538,4 @@
+ <action-widget response="0">button_add</action-widget>
+ </action-widgets>
+ </object>
+- <object class="GtkTreeStore" id="treestore_channelsgroup">
+- <columns>
+- <!-- column-name Name -->
+- <column type="gchararray"/>
+- <!-- column-name URI -->
+- <column type="gchararray"/>
+- <!-- column-name Required -->
+- <column type="gchararray"/>
+- <!-- column-name BRegex -->
+- <column type="gchararray"/>
+- <!-- column-name ERegex -->
+- <column type="gchararray"/>
+- </columns>
+- </object>
+ </interface>
diff --git a/multimedia/freetuxtv/pkg-plist b/multimedia/freetuxtv/pkg-plist
index 16eaebb03477..766cbcf40915 100644
--- a/multimedia/freetuxtv/pkg-plist
+++ b/multimedia/freetuxtv/pkg-plist
@@ -421,20 +421,21 @@ share/applications/freetuxtv.desktop
%%DATADIR%%/ui/addrecording.glade
%%DATADIR%%/ui/channelproperties.glade
%%DATADIR%%/ui/freetuxtv.glade
+share/icons/hicolor/128x128/apps/freetuxtv.png
share/icons/hicolor/16x16/apps/freetuxtv.png
share/icons/hicolor/22x22/apps/freetuxtv.png
share/icons/hicolor/32x32/apps/freetuxtv.png
share/icons/hicolor/48x48/apps/freetuxtv.png
+share/icons/hicolor/64x64/apps/freetuxtv.png
share/icons/hicolor/scalable/apps/freetuxtv.svg
%%NLS%%share/locale/de/LC_MESSAGES/freetuxtv.mo
+%%NLS%%share/locale/es/LC_MESSAGES/freetuxtv.mo
%%NLS%%share/locale/fr/LC_MESSAGES/freetuxtv.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/freetuxtv.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/freetuxtv.mo
%%NLS%%share/locale/pt/LC_MESSAGES/freetuxtv.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/freetuxtv.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/freetuxtv.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/freetuxtv.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/freetuxtv.mo
share/pixmaps/freetuxtv.png
-@dirrm %%DATADIR%%/ui
-@dirrm %%DATADIR%%/images/channels
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%
-@dirrmtry include/libvlc-gtk
-@dirrmtry include/libdbevolution