aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-22 09:15:19 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-22 09:15:19 +0800
commitc35b4e29d6d16a32622548a17d38815d59c59d9e (patch)
tree0c07443b478fb33416592bf0cae1d18b5907dd27 /multimedia
parent4fa4a1e28574ef2665f5294de9c34240a7329a66 (diff)
downloadfreebsd-ports-gnome-c35b4e29d6d16a32622548a17d38815d59c59d9e.tar.gz
freebsd-ports-gnome-c35b4e29d6d16a32622548a17d38815d59c59d9e.tar.zst
freebsd-ports-gnome-c35b4e29d6d16a32622548a17d38815d59c59d9e.zip
Mark these ports as broken on aarch64, and, where appropriate, on armvX.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Bento4/Makefile2
-rw-r--r--multimedia/acidrip/Makefile2
-rw-r--r--multimedia/kmplayer-kde4/Makefile3
-rw-r--r--multimedia/photofilmstrip/Makefile2
4 files changed, 9 insertions, 0 deletions
diff --git a/multimedia/Bento4/Makefile b/multimedia/Bento4/Makefile
index 2eeee357a6d3..d8ace0d1bb80 100644
--- a/multimedia/Bento4/Makefile
+++ b/multimedia/Bento4/Makefile
@@ -11,6 +11,8 @@ COMMENT= Full-featured MP4 format and MPEG DASH library and tools
LICENSE= GPLv2
+BROKEN_aarch64= fails to compile: Ap4AesBlockCipher.cpp:93:4: AP4_PLATFORM_BYTE_ORDER is not set
+
USES= cmake:outsource,noninja
USE_GITHUB= yes
diff --git a/multimedia/acidrip/Makefile b/multimedia/acidrip/Makefile
index 4866fb0bcd3a..f8d79cb8b294 100644
--- a/multimedia/acidrip/Makefile
+++ b/multimedia/acidrip/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}%20-%20Your%20two-wheeled
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK2::Perl wrapper for MPlayer and MEncoder for ripping DVDs
+BROKEN_aarch64= fails to build: test for MEncoder: sh: mplayer: not found
+
BUILD_DEPENDS= lsdvd:multimedia/lsdvd \
mencoder:multimedia/mencoder \
p5-Gtk2>=0:x11-toolkits/p5-Gtk2
diff --git a/multimedia/kmplayer-kde4/Makefile b/multimedia/kmplayer-kde4/Makefile
index a69d52d53afa..bb3a25c3e809 100644
--- a/multimedia/kmplayer-kde4/Makefile
+++ b/multimedia/kmplayer-kde4/Makefile
@@ -14,6 +14,9 @@ COMMENT= KDE frontend to Phonon / KDE4
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
+NOT_FOR_ARCHS= aarch64
+NOT_FOR_ARCHS_REASON= prcpucfg.h:764:2: error: "Unknown CPU architecture"
+
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libdbus-glib-1.so:devel/dbus-glib \
libphonon.so:multimedia/phonon \
diff --git a/multimedia/photofilmstrip/Makefile b/multimedia/photofilmstrip/Makefile
index 518c66c92cfd..8dcb058a52dc 100644
--- a/multimedia/photofilmstrip/Makefile
+++ b/multimedia/photofilmstrip/Makefile
@@ -14,6 +14,8 @@ COMMENT= Creates movies out of your pictures
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_aarch64= fails to build: Signal 11
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
RUN_DEPENDS= mencoder:multimedia/mencoder \
mplayer:multimedia/mplayer