aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjpaetzel <jpaetzel@FreeBSD.org>2009-04-28 01:54:33 +0800
committerjpaetzel <jpaetzel@FreeBSD.org>2009-04-28 01:54:33 +0800
commitdeb90b4b513c8f44e1624014b2327379065f6b1b (patch)
tree9681443f9bc4a9c5928c56f2a576f140caccb10b /multimedia
parenta9d145cced7cd25736cf1d3f59f1ea8a2d6ceb0f (diff)
downloadfreebsd-ports-gnome-deb90b4b513c8f44e1624014b2327379065f6b1b.tar.gz
freebsd-ports-gnome-deb90b4b513c8f44e1624014b2327379065f6b1b.tar.zst
freebsd-ports-gnome-deb90b4b513c8f44e1624014b2327379065f6b1b.zip
Restore functionaity to read encrypted DVDs.
PR: ports/134016 Approved by: linimon (mentor)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libdvdread/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/multimedia/libdvdread/Makefile b/multimedia/libdvdread/Makefile
index 18fccbd9e7a6..ed0df20bad44 100644
--- a/multimedia/libdvdread/Makefile
+++ b/multimedia/libdvdread/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libdvdread
PORTVERSION= 4.1.3
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/dvdnav/ \
http://www2.mplayerhq.hu/MPlayer/releases/dvdnav/ \
@@ -19,6 +20,10 @@ MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/dvdnav/ \
MAINTAINER= ganael.laplanche@martymac.com
COMMENT= MPlayer version of the libdvdread project
+.if !defined(PACKAGE_BUILDING)
+LIB_DEPENDS= dvdcss.${DVDCSS_LIBVERSION}:${PORTSDIR}/multimedia/libdvdcss
+.endif
+
USE_BZIP2= yes
CFLAGS+= "-I${LOCALBASE}/include"
LDFLAGS+= "-L${LOCALBASE}/lib"
@@ -36,8 +41,13 @@ CONFIGURE_ARGS= --prefix="${PREFIX}" \
USE_GMAKE= yes
USE_LDCONFIG= yes
+# DVDCSS version hardcoded in src/dvd_input.c (dlopen'ed)
+DVDCSS_LIBVERSION= 3
+
post-patch:
@${REINPLACE_CMD} -e 's|-ldl ||g' \
${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E -e 's|(libdvdcss.so)\.2|\1.${DVDCSS_LIBVERSION}|' \
+ ${WRKSRC}/src/dvd_input.c
.include <bsd.port.mk>