aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-10-01 05:48:37 +0800
committermarcus <marcus@FreeBSD.org>2003-10-01 05:48:37 +0800
commitf47f22d6282d377b7da96c6fd8ac688507b34942 (patch)
tree3564da550ac7c2908af5588dfc8bf03a16c8db0f /multimedia
parentb9b59fc74c3ac352f959de2673e8290625a79530 (diff)
downloadfreebsd-ports-gnome-f47f22d6282d377b7da96c6fd8ac688507b34942.tar.gz
freebsd-ports-gnome-f47f22d6282d377b7da96c6fd8ac688507b34942.tar.zst
freebsd-ports-gnome-f47f22d6282d377b7da96c6fd8ac688507b34942.zip
Apply the ffmpeg configure patch conditionally. This patch breaks
the build on i386. Reported by: Jeremy Messenger <mezz7@cox.net> Approved by: lioux (implicit)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer-plugins/Makefile6
-rw-r--r--multimedia/gstreamer-plugins/files/ia64-patch-ffmpeg::configure (renamed from multimedia/gstreamer-plugins/files/patch-ffmpeg::configure)0
-rw-r--r--multimedia/gstreamer-plugins80/Makefile6
-rw-r--r--multimedia/gstreamer-plugins80/files/ia64-patch-ffmpeg::configure (renamed from multimedia/gstreamer-plugins80/files/patch-ffmpeg::configure)0
4 files changed, 12 insertions, 0 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 39f577faf79f..ef5d1b1faa1d 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -105,6 +105,12 @@ post-install:
.include <bsd.port.pre.mk>
+# Fix build on ia64. This patch breaks other archs, so include it
+# conditionally
+.if ${ARCH} == "ia64"
+EXTRA_PATCHES= ${FILESDIR}/ia64-patch-ffmpeg::configure
+.endif
+
# hermes is required for gstreamer-player to work
# since it is currently the only colorspace plugin available
WITH_HERMES= yes
diff --git a/multimedia/gstreamer-plugins/files/patch-ffmpeg::configure b/multimedia/gstreamer-plugins/files/ia64-patch-ffmpeg::configure
index f4c1cb8ae5f6..f4c1cb8ae5f6 100644
--- a/multimedia/gstreamer-plugins/files/patch-ffmpeg::configure
+++ b/multimedia/gstreamer-plugins/files/ia64-patch-ffmpeg::configure
diff --git a/multimedia/gstreamer-plugins80/Makefile b/multimedia/gstreamer-plugins80/Makefile
index 39f577faf79f..ef5d1b1faa1d 100644
--- a/multimedia/gstreamer-plugins80/Makefile
+++ b/multimedia/gstreamer-plugins80/Makefile
@@ -105,6 +105,12 @@ post-install:
.include <bsd.port.pre.mk>
+# Fix build on ia64. This patch breaks other archs, so include it
+# conditionally
+.if ${ARCH} == "ia64"
+EXTRA_PATCHES= ${FILESDIR}/ia64-patch-ffmpeg::configure
+.endif
+
# hermes is required for gstreamer-player to work
# since it is currently the only colorspace plugin available
WITH_HERMES= yes
diff --git a/multimedia/gstreamer-plugins80/files/patch-ffmpeg::configure b/multimedia/gstreamer-plugins80/files/ia64-patch-ffmpeg::configure
index f4c1cb8ae5f6..f4c1cb8ae5f6 100644
--- a/multimedia/gstreamer-plugins80/files/patch-ffmpeg::configure
+++ b/multimedia/gstreamer-plugins80/files/ia64-patch-ffmpeg::configure