aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/ayttm
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-07-16 00:47:45 +0800
committerwxs <wxs@FreeBSD.org>2009-07-16 00:47:45 +0800
commit5df5244832441b2891d52b6e4692f7826550fbf9 (patch)
treee5cc110a0c6b72dd9bb7f133efd52b77ab031c63 /net-im/ayttm
parent194d70d50158859e626cd148123bb52dec698a06 (diff)
downloadfreebsd-ports-gnome-5df5244832441b2891d52b6e4692f7826550fbf9.tar.gz
freebsd-ports-gnome-5df5244832441b2891d52b6e4692f7826550fbf9.tar.zst
freebsd-ports-gnome-5df5244832441b2891d52b6e4692f7826550fbf9.zip
- Chase security/gpgme update.
Most changes are just PORTREVISION and LIB_DEPENDS fixes. However, the following ports require a patch to use the new gpgme correctly: deskutils/kdepim3 deskutils/kdepim3 deskutils/kdepim3 deskutils/kdepim3 deskutils/kdepim4 deskutils/kdepim4 deskutils/kdepimlibs4 deskutils/kdepimlibs4 deskutils/kdepimlibs4 finance/qhacc mail/mutt-devel net-im/ayttm net-im/centericq net-im/centerim net-im/centerim-devel security/openvas-libnasl These patches were submitted by various people and documented in ports/135911. PR: ports/135911
Diffstat (limited to 'net-im/ayttm')
-rw-r--r--net-im/ayttm/Makefile3
-rw-r--r--net-im/ayttm/files/patch-modules__aycryption__aycryption.c11
2 files changed, 13 insertions, 1 deletions
diff --git a/net-im/ayttm/Makefile b/net-im/ayttm/Makefile
index a7e98fb5d283..5b4e2ec794fc 100644
--- a/net-im/ayttm/Makefile
+++ b/net-im/ayttm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ayttm
PORTVERSION= 0.5.0.82
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
@@ -16,7 +17,7 @@ COMMENT= A "chat" program that combines AIM, ICQ, and Yahoo! Chat into one
LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
jasper.4:${PORTSDIR}/graphics/jasper \
- gpgme.17:${PORTSDIR}/security/gpgme \
+ gpgme.18:${PORTSDIR}/security/gpgme \
pspell.16:${PORTSDIR}/textproc/aspell
OPTIONS= ARTS "Enable aRts support" off \
diff --git a/net-im/ayttm/files/patch-modules__aycryption__aycryption.c b/net-im/ayttm/files/patch-modules__aycryption__aycryption.c
new file mode 100644
index 000000000000..9f0693f740ea
--- /dev/null
+++ b/net-im/ayttm/files/patch-modules__aycryption__aycryption.c
@@ -0,0 +1,11 @@
+--- ./modules/aycryption/aycryption.c.orig 2008-08-11 00:50:44.000000000 -0400
++++ ./modules/aycryption/aycryption.c 2009-07-02 04:06:35.000000000 -0400
+@@ -108,6 +108,8 @@
+
+ static int aycryption_init()
+ {
++ gpgme_check_version (NULL);
++
+ input_list *il = g_new0(input_list, 1);
+ plugin_info.prefs = il;
+