aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/climm/Makefile
diff options
context:
space:
mode:
authorjedgar <jedgar@FreeBSD.org>2001-01-25 11:19:53 +0800
committerjedgar <jedgar@FreeBSD.org>2001-01-25 11:19:53 +0800
commit9e022f1b0a6d26b54e9f77c182446fd37bd3df4f (patch)
tree7985bce401329d4a79f51b6343f368a43fd3d3dd /net-im/climm/Makefile
parent6e46f1c8ac23ea89091fc72a74a66054ea48e847 (diff)
downloadfreebsd-ports-gnome-9e022f1b0a6d26b54e9f77c182446fd37bd3df4f.tar.gz
freebsd-ports-gnome-9e022f1b0a6d26b54e9f77c182446fd37bd3df4f.tar.zst
freebsd-ports-gnome-9e022f1b0a6d26b54e9f77c182446fd37bd3df4f.zip
- Update port to 0.4.6p1 (fixes remote buffer overflow)
- Add some additional buffer checks
Diffstat (limited to 'net-im/climm/Makefile')
-rw-r--r--net-im/climm/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-im/climm/Makefile b/net-im/climm/Makefile
index b9840e2f6ac8..1e66b15d57bf 100644
--- a/net-im/climm/Makefile
+++ b/net-im/climm/Makefile
@@ -6,21 +6,22 @@
#
PORTNAME= micq
-PORTVERSION= 0.4.6
+PORTVERSION= 0.4.6.1
CATEGORIES= net
-MASTER_SITES= ftp://micq.chatzone.org/pub/micq/V${PORTVERSION}/
+MASTER_SITES= http://micq.ukeer.de/source/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/1/p1/}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@freebsd.org
-FORBIDDEN= "Remote buffer overflow"
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.1/-p1/}/src
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/micq ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/micq
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/micq
- ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${PREFIX}/share/doc/micq
+ ${INSTALL_DATA} ${WRKSRC}/../README ${PREFIX}/share/doc/micq
+ ${INSTALL_DATA} ${WRKSRC}/../CHANGELOG ${PREFIX}/share/doc/micq
.endif
.include <bsd.port.mk>