aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/coccinella/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-16 17:44:49 +0800
committeredwin <edwin@FreeBSD.org>2004-12-16 17:44:49 +0800
commit381f1132a8b6015dcbc88347ade71c3caf6b84a4 (patch)
tree1ff7af0c8b851fd3111f30d967f362590f1a490c /net-im/coccinella/Makefile
parentef7a288b3b9c96184e4d20ff76b06294b37b4afe (diff)
downloadfreebsd-ports-gnome-381f1132a8b6015dcbc88347ade71c3caf6b84a4.tar.gz
freebsd-ports-gnome-381f1132a8b6015dcbc88347ade71c3caf6b84a4.tar.zst
freebsd-ports-gnome-381f1132a8b6015dcbc88347ade71c3caf6b84a4.zip
New Port: net/coccinella jabber client
A Jabber client with whiteboard communication Please check this port twice, because its my first one. PR: ports/73013 Submitted by: Marc <marc@bruenink.de>
Diffstat (limited to 'net-im/coccinella/Makefile')
-rw-r--r--net-im/coccinella/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-im/coccinella/Makefile b/net-im/coccinella/Makefile
new file mode 100644
index 000000000000..80316e4befe6
--- /dev/null
+++ b/net-im/coccinella/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: coccinella
+# Date created: 21 Oct 2004
+# Whom: Marc Bruenink
+#
+# $FreeBSD$
+#
+
+PORTNAME= coccinella
+PORTVERSION= 0.95.1
+CATEGORIES= net tk84
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Coccinella-${PORTVERSION}Src
+
+MAINTAINER= marc@bruenink.de
+COMMENT= Jabber client with whiteboard communication
+
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+WISH= ${LOCALBASE}/bin/wish8.4
+LIBTARGETDIR= ${PREFIX}/${PORTNAME}
+PLIST_SUB+= LIBTARGETDIR=${PORTNAME}
+
+post-extract:
+ @${RM} -r ${WRKSRC}/bin/
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|\(exec.*\)wish|\1${WISH}|g' ${WRKSRC}/Coccinella.tcl
+
+do-install:
+ @${CP} -r ${WRKSRC} ${LIBTARGETDIR}
+ @${RM} ${LIBTARGETDIR}/CHANGES ${LIBTARGETDIR}/README*
+ @${INSTALL_SCRIPT} ${WRKSRC}/Coccinella.tcl ${LIBTARGETDIR}
+ @${LN} -sf ${LIBTARGETDIR}/Coccinella.tcl ${PREFIX}/bin/coccinella
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/CHANGES ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>