aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/ejabberd/Makefile
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2005-08-28 23:51:48 +0800
committervsevolod <vsevolod@FreeBSD.org>2005-08-28 23:51:48 +0800
commit13afc8bf3c04decaec223dce4bf2df3770b3cda2 (patch)
treeb385b0845a7b58c607d7f9d6d0339ab818b9ba6d /net-im/ejabberd/Makefile
parent85f9c73f8b65e524116fe95bb1918ff89f7a36e2 (diff)
downloadfreebsd-ports-gnome-13afc8bf3c04decaec223dce4bf2df3770b3cda2.tar.gz
freebsd-ports-gnome-13afc8bf3c04decaec223dce4bf2df3770b3cda2.tar.zst
freebsd-ports-gnome-13afc8bf3c04decaec223dce4bf2df3770b3cda2.zip
Update to 0.9.8 [1]
Fix default installation paths to preserve erlang cookies [2] Submitted by: Denis Shaposhnikov <dsh@vlink.ru> [1] Alexander Timoshenko <gonzo@univ.kiev.ua> [2] PR: 84383 [2] Approved by: perky (mentor)
Diffstat (limited to 'net-im/ejabberd/Makefile')
-rw-r--r--net-im/ejabberd/Makefile48
1 files changed, 26 insertions, 22 deletions
diff --git a/net-im/ejabberd/Makefile b/net-im/ejabberd/Makefile
index a943f89709ec..1f2174c8af14 100644
--- a/net-im/ejabberd/Makefile
+++ b/net-im/ejabberd/Makefile
@@ -6,13 +6,10 @@
#
PORTNAME= ejabberd
-PORTVERSION= 0.9.1
-PORTREVISION= 2
+PORTVERSION= 0.9.8
CATEGORIES= net
MASTER_SITES= http://www.jabber.ru/files/ejabberd/ \
http://www.process-one.net/en/projects/ejabberd/download/${PORTVERSION}/
-PATCH_SITES= http://www.jabber.ru/files/ejabberd/
-PATCHFILES= ejabberd_ctl.erl.diff
MAINTAINER= vsevolod@FreeBSD.org
COMMENT= Free and Open Source distributed fault-tolerant Jabber server
@@ -21,35 +18,42 @@ BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
-PLIST_SUB= VERSION="${PORTVERSION}"
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_REINPLACE= yes
-USE_OPENSSL= yes
USE_ICONV= yes
-PLIST_SUB= PORTVERSION=${PORTVERSION}
+USE_OPENSSL= yes
+USE_RC_SUBR= ${PORTNAME}.sh
NOPRECIOUSMAKEVARS= yes
-.include <bsd.port.pre.mk>
+MAKE_ENV= PORTVERSION=${PORTVERSION}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PLIST_SUB= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION}
+SUB_FILES= ${PORTNAME} pkg-message
+SUB_LIST= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/ejabberd ${WRKSRC}/ejabberd.sh
- @${REINPLACE_CMD} -e 's|%%PORTVERSION%%|${PORTVERSION}|g' \
- ${WRKSRC}/Makefile.in
- @${FIND} ${WRKSRC} -name \*.orig -or -name \*.bak | ${XARGS} ${RM}
+pre-install:
+ ${FIND} ${WRKSRC} '(' -name \*.orig -or -name \*.bak ')' -delete
post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/ejabberd ${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKSRC}/ejabberd.sh ${PREFIX}/etc/rc.d
- @${INSTALL_DATA} ${FILESDIR}/ejabberd.defaults ${PREFIX}/etc
- @${INSTALL_SCRIPT} ${WRKSRC}/../tools/ejabberdctl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${WRKSRC}/../tools/${PORTNAME}ctl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d
+
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.defaults ${PREFIX}/etc/${PORTNAME}/${PORTNAME}.defaults.example
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.inetrc ${PREFIX}/etc/${PORTNAME}/${PORTNAME}.inetrc.example
+.if !exists(${PREFIX}/etc/${PORTNAME}/${PORTNAME}.inetrc)
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.inetrc ${PREFIX}/etc/${PORTNAME}/${PORTNAME}.inetrc
+.endif
+
+ ${FIND} ${PREFIX}/lib/erlang/lib/${DISTNAME} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}
+ ${FIND} ${PREFIX}/lib/erlang/lib/${DISTNAME} -type f -print0 | ${XARGS} -0 ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/../doc/* ${DOCSDIR}
.endif
+
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
-17 08:02:53 +0800'>2002-11-1769-4140/+4783 * Lots of GObject work.Chris Toshok2002-11-1717-1249/+1404 * GtkObject->Gobject and GnomeDialog->GtkDialog work.Chris Toshok2002-11-174-208/+252 * lots of GObject work.Chris Toshok2002-11-1712-486/+508 * new function, build pango layout for string.Chris Toshok2002-11-163-53/+84 * (esma_dispose): g_object_unref() instead of gtk_object_unref().Ettore Perazzoli2002-11-161-1/+1 * fix typo.Chris Toshok2002-11-151-2/+2 * ETableConfig derives from GObject (fix warnings).Chris Toshok2002-11-154-70/+82 * deal with EBitArray/ESorter being a GObject now.Chris Toshok2002-11-152-2/+2 * deal with ESelectionModel no longer deriving from GtkObject.Chris Toshok2002-11-1510-359/+394 * this derives from GObject now.Chris Toshok2002-11-159-296/+312 * use GtkDialog's ::response instead of GnomeDialog's ::clicked.Chris Toshok2002-11-152-5/+12 * hrm, we shouldn't need to do this, but gtk_widget_show_all the customChris Toshok2002-11-151-0/+1 * this subclasses from GObject now, not GtkObject. don't use GtkObjectChris Toshok2002-11-156-3922/+3925 * New. (e_clipped_label_destroy): Removed.Ettore Perazzoli2002-11-153-13/+22 * Changed to use g_object_*() and g_signal_*()Ettore Perazzoli2002-11-152-47/+70 * add more marshallers for e-table.Chris Toshok2002-11-141-160/+177 * more porting work.Chris Toshok2002-11-1414-1098/+971 * menus/gal-view-menus.h GObjectified.Ettore Perazzoli2002-11-145-98/+98 * start porting to GObject.Chris Toshok2002-11-1412-375/+235 * Converted to Glade 2.Ettore Perazzoli2002-11-142-244/+263 * gnome-xml->libxmlNot Zed2002-11-133-3/+9 * only clear choices if cv->choices != NULL. (e_completion_view_disconnect):Chris Toshok2002-11-121-3/+6 * port to GObject.Chris Toshok2002-11-123-101/+106 * (init): Use GObject functions instead ofEttore Perazzoli2002-11-122-16/+18 * Replace gtk_object_(un)?ref() with g_object_(un)?ref(). Likewise.Ettore Perazzoli2002-11-126-20/+20 * Forgot two more gtk_object_(un)?ref()s.Ettore Perazzoli2002-11-122-4/+4 * Replace gtk_object_(un)?ref() with g_object_(un)?ref(). Likewise.Ettore Perazzoli2002-11-1212-67/+67 * Removed. (impl_finalize): New. (class_init): Override GObject::finalize,Ettore Perazzoli2002-11-124-43/+56 * correct the GET_CLASS macro.Chris Toshok2002-11-096-6/+6 * include gnome-dialogJP Rosevear2002-11-082-0/+5 * ignore the generated marshal source.Chris Toshok2002-11-076-132/+182 * remove duplicate g_signal_new for column_width_changed.Chris Toshok2002-11-071-8/+0 * GObjectify GObjectifyMike Kestner2002-11-064-63/+55 * remove ref/unref G_OBJECT masks ditto ditto ditto ditto ditto ditto dittoMike Kestner2002-11-069-63/+63 * GObjectify GObjectify GObjectify use GObject api for models use GObjectMike Kestner2002-11-0624-767/+563 * use GObject api for models GObjectify GObjectify GObjectify GObjectifyMike Kestner2002-11-0526-867/+623 * use GObject api for ETableHeader use GObject api on ETableHeaderMike Kestner2002-11-0515-327/+297 * (impl_expose_event): UseEttore Perazzoli2002-11-042-1/+6 * (e_timezone_dialog_get_builtin_timezone): Constify argEttore Perazzoli2002-11-043-2/+8 * First big sync of my GNOME 2 porting work (incomplete, and stillEttore Perazzoli2002-11-0232-255/+328 * gobjectify ETableExtras is now a GObject (e_tree_class_init): removeMike Kestner2002-11-023-35/+18 * merging the gal-2 branch back to the trunk.Mike Kestner2002-11-01172-2868/+1945 * Emit a search_activated signal. (e_search_bar_set_item_id): Revert toJeffrey Stedfast2002-10-292-3/+9 * add prototypes for the _change* functions.Chris Toshok2002-10-252-19/+160 * call e_tree_state_changeMike Kestner2002-10-251-0/+2 * If the clear button was pressed, we want the entry to be sensitive (notJeffrey Stedfast2002-10-245-24/+31 * (activate_by_subitems): gtk_widget_grab_focus()Ettore Perazzoli2002-10-242-0/+11 * don't emit a signal if we couldn't find the view rowJP Rosevear2002-10-221-2/+4 * Don't include the byte reserved for the nul in the outleft size.Jeffrey Stedfast2002-10-171-17/+25 * check if the selection fits in the leftover daysJP Rosevear2002-10-162-4/+28 * call drop_timeoutMike Kestner2002-10-041-2/+1 * [Add a small delay to the switching of pages in the multi-configEttore Perazzoli2002-10-012-10/+56 * use the fg color array in style, not text color. Change requested by ChrisMike Kestner2002-09-281-2/+2 * Ooops.Ettore Perazzoli2002-09-281-4/+3 * (create_page_container): Don't set upEttore Perazzoli2002-09-282-0/+7 * add the gtk2 keypad entries (resync with gdk).Larry Ewing2002-09-251-10/+34 * New api to set the search column on a tree without having to set a sortMike Kestner2002-09-242-0/+23 * Clear search by setting text to "" and search to first search.Not Zed2002-09-243-12/+17 * Fix some non-ANSI switch statements.Dan Winship2002-09-232-2/+7 * Set the selection model's selection_mode after setting the table model, orDan Winship2002-09-201-5/+2 * guard against NULL nodes.Mike Kestner2002-09-201-0/+1 * exit editing on dblclick. ungrab based on grabbed_count. unset grabbed_colMike Kestner2002-09-181-7/+8 * forgot to commit the po stuff from the release. also bumped the so number.Mike Kestner2002-09-111-1/+1 * take a clip_height and use it to set the maximum number of lines ifJP Rosevear2002-09-111-20/+15 * need to make the find now button sensitive when you select something fromChris Toshok2002-08-302-0/+7 * kill a return that caused selection ranges to not emit selection_changedMike Kestner2002-08-301-1/+0 * If the item is ADVANCED_ID, check the query and efb->setquery to seePeter Williams2002-08-302-1/+14 * Don't set the item id; clear search isn't in the menu anymore. FixesPeter Williams2002-08-242-1/+5 * don't adjust for two digit dates here, the e_time_parse routines do thatJP Rosevear2002-08-223-23/+5 * ref/unref the gvmMike Kestner2002-08-152-0/+8 * And finally here.Jeffrey Stedfast2002-08-074-74/+6 * #include <string.h> for memsetJeffrey Stedfast2002-08-075-21/+125 * Set the query text into the filter name when saving it, for #10979.Not Zed2002-08-062-2/+13 * Add missing cast. (e_calendar_item_signal_emission_idle_cb): Likewise.Ettore Perazzoli2002-07-244-4/+14 * (item_key_press): In the case of '-' and '=', checkEttore Perazzoli2002-07-241-0/+6 * Also perform a search on the query_changed signal, which is what getsPeter Williams2002-07-244-38/+74 * Made these able to find the potential row for a new node which will be theChristopher James Lahey2002-07-191-3/+8 * Install libversit.a so that people compiling against the addressbook canPeter Williams2002-07-183-21/+44 * (setup_standard_verbs): Set the <commands> partEttore Perazzoli2002-07-182-5/+41 * (e_timezone_dialog_init):Ettore Perazzoli2002-07-062-0/+7 * (update_sensitivity): Removed.Ettore Perazzoli2002-07-032-43/+58 * (subitem_activated_cb): Don't emitEttore Perazzoli2002-07-022-3/+7 * (activate_by_subitems): Don't set the entry to beEttore Perazzoli2002-07-022-2/+7 * (build_items): Put the numbers in front of theEttore Perazzoli2002-06-192-1/+6 * Patch by clahey.JP Rosevear2002-06-181-1/+37 * Edit the view after appending it to the model.Christopher James Lahey2002-06-171-0/+1 * Don't draw or interact with the popup button if a cell isn't editableChristopher James Lahey2002-06-159-30/+50 * Bumped the version number to 0.19.99.17.Christopher James Lahey2002-06-062-1/+25 * Added debugging printfs. (e_text_request_paste): Fixed the order ofChristopher James Lahey2002-06-061-2/+14 * Added debugging printfs.Christopher James Lahey2002-06-053-1/+13 * Added debugging printfs.Christopher James Lahey2002-06-053-2/+38 * Made it so that on realize we grab focus if we have the cursor, sinceChristopher James Lahey2002-06-051-0/+11 * Added this function to let you disable the define views dialog.Christopher James Lahey2002-06-053-41/+73 * Added this function.Christopher James Lahey2002-06-057-125/+269 * Don't show this dialog more than once per collection.Christopher James Lahey2002-06-052-9/+37 * Added this function to set the user visible name of this collection.Christopher James Lahey2002-06-044-4/+45 * Reenable tooltips if the GAL_DO_TOOLTIPS environment variable is set.Christopher James Lahey2002-06-042-2/+3 * Get the font from the style again when the style changes. (init): ChecksChristopher James Lahey2002-06-045-6/+64 * Reflow and redraw when the style gets set.Christopher James Lahey2002-06-042-322/+330 * New helper function. (build_items): g_strdup() the text for all the items.Ettore Perazzoli2002-05-312-13/+71 * Added would_be_expanded refactoring code out of is_expanded.Christopher James Lahey2002-05-251-16/+22 * Put the stuff in /menu/Searchplaceholder/Search instead of /menu/Search.Ettore Perazzoli2002-05-231-3/+11 * Put the search menu in a SearchPlaceholder.Ettore Perazzoli2002-05-231-0/+3 * New, overrides GtkWidget::draw. (impl_expose_event): New, overridesEttore Perazzoli2002-05-232-2/+108 * Check for path being NULL.Christopher James Lahey2002-05-212-2/+17 * Prepend the advanced menu with a separator.Ettore Perazzoli2002-05-213-6/+15 * Strip underscores from the menu item labels.Ettore Perazzoli2002-05-213-6/+43 * Made it so that if the current_id doesn't match any of the given ids, itChristopher James Lahey2002-05-142-4/+20 * Changed a lot of direct uses in this file of node->is_expanded to call theChristopher James Lahey2002-05-141-70/+76 * If grabbed_item is NULL, cancel the timeout.Christopher James Lahey2002-05-111-0/+8 * Include string.h here.Christopher James Lahey2002-05-111-0/+2 * Switch from gnome_canvas_item_grab to e_canvas_item_grab.Christopher James Lahey2002-05-105-31/+149 * Bump file version to 2. (This will make older versions of gal ignore theDan Winship2002-05-101-4/+12 * Change this directory to include the $(VERSION).Christopher James Lahey2002-05-071-6/+2 * Make the style here match the proper widget style to emulate a label or anChristopher James Lahey2002-05-031-1/+1 * Added this function that lets you specify the translation domain.Christopher James Lahey2002-05-0310-84/+121 * Added horizontal dividers to this item when in table mode.Christopher James Lahey2002-05-034-26/+28 * Set the gettext-domain here.Christopher James Lahey2002-05-0211-36/+81 * From gal/e-table/ChangeLog:Christopher James Lahey2002-04-301-8/+8 * Changed LDFLAGS to LIBS for tests here. Bumped the version number toChristopher James Lahey2002-04-302-0/+39 * Take an int instead of a double. From a patch by jody@ximian.com.Christopher James Lahey2002-04-271-1/+1 * Don't print out the colors here unless debugging is turned on.Christopher James Lahey2002-04-272-1/+8 * Only unref etst->sort_info once.Christopher James Lahey2002-04-271-1/+0 * Documented the life cycle requirements of the return value of theseChristopher James Lahey2002-04-272-7/+23 * Include alloca.h here if it's necessary.Christopher James Lahey2002-04-271-0/+4 * Initialize these struct members individually instead of as a struct.Christopher James Lahey2002-04-271-1/+4 * Added calls to e_table_model_pre_change here so that the ETableItemChristopher James Lahey2002-04-261-0/+4 * Made these handle the case where all_children_selected_array has a bitChristopher James Lahey2002-04-261-2/+7 * Ansification patch from danw.Christopher James Lahey2002-04-2610-22/+23 * Ansification patch from danw.Christopher James Lahey2002-04-264-4/+4 * Ansification patch from danw.Christopher James Lahey2002-04-26