aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/ejabberd
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2015-02-08 04:37:44 +0800
committerashish <ashish@FreeBSD.org>2015-02-08 04:37:44 +0800
commit449453010414b6d8578097bd843baf74ca3d5d06 (patch)
treee6254230078e1c5d89cfd223c4e863c66c647daa /net-im/ejabberd
parentde1e7b77da6267d089641dc3a74fbbb723fe497b (diff)
downloadfreebsd-ports-gnome-449453010414b6d8578097bd843baf74ca3d5d06.tar.gz
freebsd-ports-gnome-449453010414b6d8578097bd843baf74ca3d5d06.tar.zst
freebsd-ports-gnome-449453010414b6d8578097bd843baf74ca3d5d06.zip
- Update to 14.12
- Remove HTTP option, and add RIAK option - Remove a diff as it's not needed anymore - Add diff for building with Erlang 17RB - Update dependency tarball
Diffstat (limited to 'net-im/ejabberd')
-rw-r--r--net-im/ejabberd/Makefile11
-rw-r--r--net-im/ejabberd/distinfo8
-rw-r--r--net-im/ejabberd/files/patch-Makefile.in12
-rw-r--r--net-im/ejabberd/files/patch-ejabberdctl.template6
-rw-r--r--net-im/ejabberd/files/patch-erlang-17-dict-queue208
-rw-r--r--net-im/ejabberd/files/patch-unicode-fixup55
-rw-r--r--net-im/ejabberd/pkg-plist73
7 files changed, 268 insertions, 105 deletions
diff --git a/net-im/ejabberd/Makefile b/net-im/ejabberd/Makefile
index 5f8c833afd6c..4d51b620b6b4 100644
--- a/net-im/ejabberd/Makefile
+++ b/net-im/ejabberd/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= ejabberd
-PORTVERSION= 14.07
-PORTREVISION= 2
+PORTVERSION= 14.12
CATEGORIES= net-im
MASTER_SITES= http://www.process-one.net/downloads/${PORTNAME}/${PORTVERSION}/:p1 \
http://distfiles.pirateparty.in/%SUBDIR%/:deps \
${MASTER_SITE_LOCAL:S/$/:deps/}
MASTER_SITE_SUBDIR= ashish/:deps
-DISTFILES+= ${PORTNAME}-${PORTVERSION}.tgz:p1 ejabberd-deps-1.tar.xz:deps
+DISTFILES+= ${PORTNAME}-${PORTVERSION}.tgz:p1 ejabberd-deps-2.tar.xz:deps
MAINTAINER= ashish@FreeBSD.org
COMMENT= Free and Open Source distributed fault-tolerant Jabber server
@@ -31,7 +30,7 @@ USES= gmake pkgconfig
USE_RC_SUBR= ${PORTNAME}
NOPRECIOUSMAKEVARS= yes
-OPTIONS_DEFINE= ODBC PAM DOCS HTTP JSON MYSQL PGSQL LAGER ICONV
+OPTIONS_DEFINE= ODBC PAM DOCS JSON MYSQL PGSQL LAGER ICONV RIAK
OPTIONS_DEFAULT= LAGER ICONV
MAKE_ENV= PORTVERSION=${PORTVERSION}
@@ -49,15 +48,15 @@ SUB_LIST= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION} \
SHAREOWN=${SHAREOWN} SHAREGRP=${SHAREGRP}
OPTIONS_SUB= yes
-HTTP_DESC= HTTP support
LAGER_DESC= LAGER logger
+RIAK_DESC= Riak database support
PAM_CONFIGURE_ENABLE= pam
ODBC_CONFIGURE_ENABLE= odbc
LAGER_CONFIGURE_ENABLE= lager
-HTTP_CONFIGURE_ENABLE= http
JSON_CONFIGURE_ENABLE= json
MYSQL_CONFIGURE_ENABLE= mysql
PGSQL_CONFIGURE_ENABLE= pgsql
+RIAK_CONFIGURE_ENABLE= riak
ICONV_CONFIGURE_ENABLE= iconv
ICONV_USES= iconv:wchar_t
ICONV_LDFLAGS= ${ICONV_LIB}
diff --git a/net-im/ejabberd/distinfo b/net-im/ejabberd/distinfo
index 70644cf08dc6..d86402e5dadd 100644
--- a/net-im/ejabberd/distinfo
+++ b/net-im/ejabberd/distinfo
@@ -1,4 +1,4 @@
-SHA256 (ejabberd-14.07.tgz) = 60d2a7c2010f6fec3a6cbe9516d56d4b580833353bc8200107f1029c102162fb
-SIZE (ejabberd-14.07.tgz) = 3200975
-SHA256 (ejabberd-deps-1.tar.xz) = 3be239cb6b881b5b49c50d1a68bed2ea2dd860ef579d826f15e1cae18fd7d2a4
-SIZE (ejabberd-deps-1.tar.xz) = 9952828
+SHA256 (ejabberd-14.12.tgz) = 88c481e6e81e6e81100cdfae8e77bc6ffd6faed62f1938cf1e90ed7504c8785a
+SIZE (ejabberd-14.12.tgz) = 3261685
+SHA256 (ejabberd-deps-2.tar.xz) = 0f5604c0ce40c499f082170b457c4238fac570df71b4b03b9d5fa525abb15847
+SIZE (ejabberd-deps-2.tar.xz) = 12475132
diff --git a/net-im/ejabberd/files/patch-Makefile.in b/net-im/ejabberd/files/patch-Makefile.in
index 1df921834af8..26fce0cc68a4 100644
--- a/net-im/ejabberd/files/patch-Makefile.in
+++ b/net-im/ejabberd/files/patch-Makefile.in
@@ -26,7 +26,7 @@ $FreeBSD$
# /var/lib/ejabberd/.erlang.cookie
COOKIEFILE = $(SPOOLDIR)/.erlang.cookie
-@@ -109,25 +109,22 @@
+@@ -113,25 +113,22 @@
#
# Configuration files
$(INSTALL) -d -m 750 $(G_USER) $(ETCDIR)
@@ -59,17 +59,17 @@ $FreeBSD$
#
# Init script
$(SED) -e "s*@ctlscriptpath@*$(SBINDIR)*" \
-@@ -177,6 +176,7 @@
+@@ -184,6 +181,7 @@
chmod -R 750 $(LOGDIR)
#
# Documentation
+ifndef NOPORTDOCS
$(INSTALL) -d $(DOCDIR)
- $(INSTALL) -m 644 doc/dev.html $(DOCDIR)
- $(INSTALL) -m 644 doc/guide.html $(DOCDIR)
-@@ -186,6 +186,7 @@
- && $(INSTALL) -m 644 doc/guide.pdf $(DOCDIR) \
+ [ -f doc/dev.html ] \
+ && $(INSTALL) -m 644 doc/dev.html $(DOCDIR) \
+@@ -196,6 +194,7 @@
|| echo "No doc/guide.pdf was built"
+ $(INSTALL) -m 644 doc/*.png $(DOCDIR)
$(INSTALL) -m 644 COPYING $(DOCDIR)
+endif
diff --git a/net-im/ejabberd/files/patch-ejabberdctl.template b/net-im/ejabberd/files/patch-ejabberdctl.template
index 98a1dc839cee..27ebcccc5565 100644
--- a/net-im/ejabberd/files/patch-ejabberdctl.template
+++ b/net-im/ejabberd/files/patch-ejabberdctl.template
@@ -3,7 +3,7 @@ $FreeBSD$
--- ejabberdctl.template.orig
+++ ejabberdctl.template
-@@ -67,10 +67,10 @@
+@@ -72,10 +72,10 @@
EJABBERD_CONFIG_PATH=$ETC_DIR/ejabberd.yml
fi
if [ "$LOGS_DIR" = "" ] ; then
@@ -16,7 +16,7 @@ $FreeBSD$
fi
if [ "$EJABBERD_DOC_PATH" = "" ] ; then
EJABBERD_DOC_PATH={{docdir}}
-@@ -84,10 +84,10 @@
+@@ -89,10 +89,10 @@
EJABBERDDIR={{libdir}}/ejabberd
fi
if [ "$EJABBERD_EBIN_PATH" = "" ] ; then
@@ -29,7 +29,7 @@ $FreeBSD$
fi
if [ "$EJABBERD_BIN_PATH" = "" ] ; then
EJABBERD_BIN_PATH=$EJABBERD_PRIV_PATH/bin
-@@ -281,7 +281,7 @@
+@@ -279,7 +279,7 @@
# using flock if available. Expects a linux-style
# flock that can lock a file descriptor.
MAXCONNID=100
diff --git a/net-im/ejabberd/files/patch-erlang-17-dict-queue b/net-im/ejabberd/files/patch-erlang-17-dict-queue
new file mode 100644
index 000000000000..00d21ba63682
--- /dev/null
+++ b/net-im/ejabberd/files/patch-erlang-17-dict-queue
@@ -0,0 +1,208 @@
+$FreeBSD$
+
+Fixes to make it work with Erlang R17
+
+--- ../deps/meck/rebar.config.orig
++++ ../deps/meck/rebar.config
+@@ -1,4 +1,6 @@
+-{erl_opts, [warnings_as_errors, debug_info]}.
++{erl_opts, [
++ {platform_define, "^17-", 'ERLANG_17'},
++ warnings_as_errors, debug_info]}.
+ {xref_checks, [undefined_function_calls]}.
+ {dialyzer_opts, [{warnings, [unmatched_returns]}]}.
+
+--- ../deps/meck/src/meck_proc.erl.orig
++++ ../deps/meck/src/meck_proc.erl
+@@ -46,6 +46,17 @@
+ %%% Definitions
+ %%%============================================================================
+
++-ifdef(ERLANG_17).
++-record(state, {mod :: atom(),
++ can_expect :: any | [{Mod::atom(), Ari::byte()}],
++ expects :: dict:dict(),
++ valid = true :: boolean(),
++ history = [] :: meck_history:history() | undefined,
++ original :: term(),
++ was_sticky = false :: boolean(),
++ reload :: {Compiler::pid(), {From::pid(), Tag::any()}} |
++ undefined}).
++-else.
+ -record(state, {mod :: atom(),
+ can_expect :: any | [{Mod::atom(), Ari::byte()}],
+ expects :: dict(),
+@@ -55,6 +66,7 @@
+ was_sticky = false :: boolean(),
+ reload :: {Compiler::pid(), {From::pid(), Tag::any()}} |
+ undefined}).
++-endif.
+
+
+ %%%============================================================================
+@@ -340,9 +352,17 @@
+ end.
+
+
++-ifdef(ERLANG_17).
++-spec init_expects(Exports::[meck_expect:func_ari()] | undefined,
++ Options::[proplists:property()]) ->
++ dict:dict().
++-else.
+ -spec init_expects(Exports::[meck_expect:func_ari()] | undefined,
+ Options::[proplists:property()]) ->
+ dict().
++-endif.
++
++
+ init_expects(Exports, Options) ->
+ Passthrough = proplists:get_bool(passthrough, Options),
+ StubAll = proplists:is_defined(stub_all, Options),
+@@ -379,8 +399,13 @@
+ erlang:error(concurrent_reload).
+
+
++-ifdef(ERLANG_17).
++-spec do_get_result_spec(Expects::dict:dict(), Func::atom(), Args::[any()]) ->
++ {meck_ret_spec:result_spec() | undefined, NewExpects::dict:dict()}.
++-else.
+ -spec do_get_result_spec(Expects::dict(), Func::atom(), Args::[any()]) ->
+ {meck_ret_spec:result_spec() | undefined, NewExpects::dict()}.
++-endif.
+ do_get_result_spec(Expects, Func, Args) ->
+ FuncAri = {Func, erlang:length(Args)},
+ Clauses = dict:fetch(FuncAri, Expects),
+@@ -411,23 +436,39 @@
+ end.
+
+
++-ifdef(ERLANG_17).
++-spec store_expect(Mod::atom(), meck_expect:func_ari(),
++ meck_expect:expect(), Expects::dict:dict()) ->
++ {NewExpects::dict:dict(), CompilerPid::pid()}.
++-else.
+ -spec store_expect(Mod::atom(), meck_expect:func_ari(),
+ [meck_expect:func_clause()], Expects::dict()) ->
+ {NewExpects::dict(), CompilerPid::pid()}.
++-endif.
+ store_expect(Mod, FuncAri, Clauses, Expects) ->
+ NewExpects = dict:store(FuncAri, Clauses, Expects),
+ compile_expects(Mod, NewExpects).
+
+
++-ifdef(ERLANG_17).
++-spec do_delete_expect(Mod::atom(), meck_expect:func_ari(), Expects::dict:dict()) ->
++ {NewExpects::dict:dict(), CompilerPid::pid()}.
++-else.
+ -spec do_delete_expect(Mod::atom(), meck_expect:func_ari(), Expects::dict()) ->
+ {NewExpects::dict(), CompilerPid::pid()}.
++-endif.
+ do_delete_expect(Mod, FuncAri, Expects) ->
+ NewExpects = dict:erase(FuncAri, Expects),
+ compile_expects(Mod, NewExpects).
+
+
++-ifdef(ERLANG_17).
++-spec compile_expects(Mod::atom(), Expects::dict:dict()) ->
++ {NewExpects::dict:dict(), CompilerPid::pid()}.
++-else.
+ -spec compile_expects(Mod::atom(), Expects::dict()) ->
+ {NewExpects::dict(), CompilerPid::pid()}.
++-endif.
+ compile_expects(Mod, Expects) ->
+ %% If the recompilation is made by the server that executes a module
+ %% no module that is called from meck_code:compile_and_load_forms/2
+--- ../deps/riakc/rebar.config.orig
++++ ../deps/riakc/rebar.config
+@@ -1,6 +1,8 @@
+ {cover_enabled, true}.
+ {eunit_opts, [verbose]}.
+-{erl_opts, [warnings_as_errors, debug_info]}.
++{erl_opts, [
++ {platform_define, "^17-", 'ERLANG_17'},
++ warnings_as_errors, debug_info]}.
+ {deps, [
+ {riak_pb, ".*", {git, "git://github.com/basho/riak_pb", {tag, "1.4.4.0"}}}
+ ]}.
+--- ../deps/riakc/src/riakc_obj.erl.orig
++++ ../deps/riakc/src/riakc_obj.erl
+@@ -79,7 +79,11 @@
+ -type key() :: binary() | 'undefined'. %% A key name
+ -type id() :: {bucket(), key()}.
+ -type vclock() :: binary(). %% An opaque vector clock
++-ifdef(ERLANG_17).
++-type metadata() :: dict:dict(). %% Value metadata
++-else.
+ -type metadata() :: dict(). %% Value metadata
++-endif.
+ -type content_type() :: string(). %% The media type of a value
+ -type value() :: binary(). %% An opaque value
+ -type contents() :: [{metadata(), value()}]. %% All metadata/value pairs in a `riakc_obj'.
+@@ -98,6 +102,16 @@
+ -type tag() :: binary().
+ -type link() :: {tag(), [id()]}.
+
++-ifdef(ERLANG_17).
++-record(riakc_obj, {
++ bucket :: bucket(),
++ key :: key(),
++ vclock :: vclock(),
++ contents :: contents(),
++ updatemetadata :: dict:dict(),
++ updatevalue :: value()
++ }).
++-else.
+ -record(riakc_obj, {
+ bucket :: bucket(),
+ key :: key(),
+@@ -106,6 +120,7 @@
+ updatemetadata :: dict(),
+ updatevalue :: value()
+ }).
++-endif.
+
+ -type riakc_obj() :: #riakc_obj{}. %% The record/type containing the entire Riak object.
+ -export_type([riakc_obj/0, bucket/0, key/0, vclock/0, contents/0, metadata/0, value/0,
+@@ -284,7 +299,11 @@
+ end.
+
+ %% @doc Return the content type from metadata
++-ifdef(ERLANG_17).
++-spec md_ctype(dict:dict()) -> undefined | content_type().
++-else.
+ -spec md_ctype(dict()) -> undefined | content_type().
++-endif.
+ md_ctype(MetaData) ->
+ case dict:find(?MD_CTYPE, MetaData) of
+ error ->
+--- ../deps/riakc/src/riakc_pb_socket.erl.orig
++++ ../deps/riakc/src/riakc_pb_socket.erl
+@@ -110,6 +110,20 @@
+
+ -type portnum() :: non_neg_integer(). %% The TCP port number of the Riak node's Protocol Buffers interface
+ -type address() :: string() | atom() | inet:ip_address(). %% The TCP/IP host name or address of the Riak node
++-ifdef(ERLANG_17).
++-record(state, {address :: address(), % address to connect to
++ port :: portnum(), % port to connect to
++ auto_reconnect = false :: boolean(), % if true, automatically reconnects to server
++ % if false, exits on connection failure/request timeout
++ queue_if_disconnected = false :: boolean(), % if true, add requests to queue if disconnected
++ sock :: port(), % gen_tcp socket
++ active :: #request{} | undefined, % active request
++ queue :: queue:queue() | undefined, % queue of pending requests
++ connects=0 :: non_neg_integer(), % number of successful connects
++ failed=[] :: [connection_failure()], % breakdown of failed connects
++ connect_timeout=infinity :: timeout(), % timeout of TCP connection
++ reconnect_interval=?FIRST_RECONNECT_INTERVAL :: non_neg_integer()}).
++-else.
+ -record(state, {address :: address(), % address to connect to
+ port :: portnum(), % port to connect to
+ auto_reconnect = false :: boolean(), % if true, automatically reconnects to server
+@@ -122,6 +136,7 @@
+ failed=[] :: [connection_failure()], % breakdown of failed connects
+ connect_timeout=infinity :: timeout(), % timeout of TCP connection
+ reconnect_interval=?FIRST_RECONNECT_INTERVAL :: non_neg_integer()}).
++-endif.
+
+ %% @doc Create a linked process to talk with the riak server on Address:Port
+ %% Client id will be assigned by the server.
diff --git a/net-im/ejabberd/files/patch-unicode-fixup b/net-im/ejabberd/files/patch-unicode-fixup
deleted file mode 100644
index 45a607d7acb3..000000000000
--- a/net-im/ejabberd/files/patch-unicode-fixup
+++ /dev/null
@@ -1,55 +0,0 @@
-
-$FreeBSD$
-
-Erlang treats the files by default as utf-8, whereas these files have ISO-8859-1
-characters in them.
-
---- ../deps/lhttpc/src/lhttpc.app.src.orig 2014-05-19 07:38:56.000000000 +0530
-+++ ../deps/lhttpc/src/lhttpc.app.src 2014-08-07 13:17:49.172704645 +0530
-@@ -1,3 +1,4 @@
-+%% coding: latin-1
- %%% ----------------------------------------------------------------------------
- %%% Copyright (c) 2009, Erlang Training and Consulting Ltd.
- %%% All rights reserved.
---- ../deps/lhttpc/src/lhttpc.erl.orig 2014-05-19 07:38:56.000000000 +0530
-+++ ../deps/lhttpc/src/lhttpc.erl 2014-08-07 13:17:49.169705958 +0530
-@@ -1,3 +1,4 @@
-+%% coding: latin-1
- %%% ----------------------------------------------------------------------------
- %%% Copyright (c) 2009, Erlang Training and Consulting Ltd.
- %%% All rights reserved.
---- ../deps/lhttpc/src/lhttpc_client.erl.orig 2014-05-19 07:38:56.000000000 +0530
-+++ ../deps/lhttpc/src/lhttpc_client.erl 2014-08-07 13:17:49.171704902 +0530
-@@ -1,3 +1,4 @@
-+%% coding: latin-1
- %%% ----------------------------------------------------------------------------
- %%% Copyright (c) 2009, Erlang Training and Consulting Ltd.
- %%% All rights reserved.
---- ../deps/lhttpc/src/lhttpc_lib.erl.orig 2014-05-19 07:38:56.000000000 +0530
-+++ ../deps/lhttpc/src/lhttpc_lib.erl 2014-08-07 13:17:49.173704875 +0530
-@@ -1,3 +1,4 @@
-+%% coding: latin-1
- %%% ----------------------------------------------------------------------------
- %%% Copyright (c) 2009, Erlang Training and Consulting Ltd.
- %%% All rights reserved.
---- ../deps/lhttpc/src/lhttpc_manager.erl.orig 2014-05-19 07:38:56.000000000 +0530
-+++ ../deps/lhttpc/src/lhttpc_manager.erl 2014-08-07 13:17:49.171704902 +0530
-@@ -1,3 +1,4 @@
-+%% coding: latin-1
- %%% ----------------------------------------------------------------------------
- %%% Copyright (c) 2009, Erlang Training and Consulting Ltd.
- %%% All rights reserved.
---- ../deps/lhttpc/src/lhttpc_sock.erl.orig 2014-05-19 07:38:56.000000000 +0530
-+++ ../deps/lhttpc/src/lhttpc_sock.erl 2014-08-07 13:17:49.173704875 +0530
-@@ -1,3 +1,4 @@
-+%% coding: latin-1
- %%% ----------------------------------------------------------------------------
- %%% Copyright (c) 2009, Erlang Training and Consulting Ltd.
- %%% All rights reserved.
---- ../deps/lhttpc/src/lhttpc_sup.erl.orig 2014-05-19 07:38:56.000000000 +0530
-+++ ../deps/lhttpc/src/lhttpc_sup.erl 2014-08-07 13:17:49.170704704 +0530
-@@ -1,3 +1,4 @@
-+%% coding: latin-1
- %%% ----------------------------------------------------------------------------
- %%% Copyright (c) 2009, Erlang Training and Consulting Ltd.
- %%% All rights reserved.
diff --git a/net-im/ejabberd/pkg-plist b/net-im/ejabberd/pkg-plist
index 1db860749fa5..746590a9253d 100644
--- a/net-im/ejabberd/pkg-plist
+++ b/net-im/ejabberd/pkg-plist
@@ -9,17 +9,18 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ELDAPv3.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/XmppAddr.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/acl.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/adhoc.beam
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/beam_util.beam
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/bitmap.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/cache_tab.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/cache_tab_sup.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/cache_tab_app.beam
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/cache_tab_treap.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/cyrsasl.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/cyrsasl_anonymous.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/cyrsasl_digest.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/cyrsasl_plain.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/cyrsasl_scram.beam
%%NO_LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/dynamic_compile.beam
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ehyperloglog.app
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ehyperloglog.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/%%PORTNAME%%.app
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/%%PORTNAME%%.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/%%PORTNAME%%_admin.beam
@@ -94,7 +95,6 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/esip_transaction.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/esip_transport.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/esip_udp_sup.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/error_logger_lager_h.beam
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/example_serv.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/extauth.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ezlib.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ezlib_app.beam
@@ -118,14 +118,6 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/gen_pubsub_nodetree.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/gr_param_sup.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/gr_sup.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/gre.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ibrowse.app
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ibrowse.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ibrowse_app.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ibrowse_http_client.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ibrowse_lb.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ibrowse_lib.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ibrowse_socks5.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ibrowse_sup.beam
%%ICONV%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/iconv.beam
%%ICONV%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/iconv_app.beam
%%ICONV%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/iconv_sup.beam
@@ -139,6 +131,7 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/jlib.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lager.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lager_app.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lager_backend_throttle.beam
+%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lager_common_test_backend.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lager_config.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lager_console_backend.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lager_crash_log.beam
@@ -153,13 +146,16 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/jlib.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lager_transform.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lager_trunc_io.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lager_util.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lhttpc.app
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lhttpc.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lhttpc_client.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lhttpc_lib.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lhttpc_manager.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lhttpc_sock.beam
-%%HTTP%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lhttpc_sup.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck.app
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_code.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_code_gen.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_cover.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_expect.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_history.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_proc.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_ret_spec.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_util.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_adhoc.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_announce.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_blocking.beam
@@ -167,8 +163,10 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_caps.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_carboncopy.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_configure.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_configure2.beam
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_client_state.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_disco.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_echo.beam
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_fail2ban.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_http_bind.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_http_fileserver.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_ip_blacklist.beam
@@ -253,6 +251,7 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_tls_app.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_tls_sup.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_utils.app
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_xml.app
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_xmlrpc.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_yaml.app
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_yaml.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_yaml_app.beam
@@ -264,6 +263,25 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_zlib.app
%%PGSQL%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/pgsql_sup.beam
%%PGSQL%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/pgsql_tcp.beam
%%PGSQL%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/pgsql_util.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/pokemon_pb.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/protobuffs.app
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/protobuffs.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/protobuffs_compile.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/protobuffs_file.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/protobuffs_parser.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/protobuffs_scanner.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/riak_kv_pb.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/riak_pb.app
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/riak_pb.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/riak_pb_codec.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/riak_pb_kv_codec.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/riak_pb_search_codec.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/riak_search_pb.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/riakc.app
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/riakc_obj.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/riakc_pb_socket.beam
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xml_util.beam
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xmlrpc_codec.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/pubsub_db_odbc.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/pubsub_index.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/pubsub_subscription.beam
@@ -283,26 +301,17 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/stun_shaper.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/stun_sup.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/stun_test.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/stun_tmp_sup.beam
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/stun_treap.beam
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/tcp_serv.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/translate.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/treap.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/turn.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/turn_sm.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/turn_tmp_sup.beam
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/url_util.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/win32_dns.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xml.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xml_app.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xml_gen.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xml_stream.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xml_sup.beam
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xmlrpc.app
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xmlrpc.beam
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xmlrpc_decode.beam
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xmlrpc_encode.beam
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xmlrpc_http.beam
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/xmlrpc_util.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/ELDAPv3.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/XmppAddr.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/adhoc.hrl
@@ -316,11 +325,8 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/eldap.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/esip.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/esip_lib.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/http_bind.hrl
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/ibrowse.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/jlib.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/lager.hrl
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/lhttpc.hrl
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/lhttpc_types.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/logger.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/mod_muc_room.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/mod_privacy.hrl
@@ -330,10 +336,14 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/ns.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/p1_logger.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/p1_mysql.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/pubsub.hrl
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/riak_kv_pb.hrl
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/riak_pb.hrl
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/riak_pb_kv_codec.hrl
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/riak_search_pb.hrl
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/riakc.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/stun.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/xml.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/xml_gen.hrl
-lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/xmlrpc.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/bin/captcha.sh
%%PAM%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/bin/epam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/esip_drv.so
@@ -341,6 +351,7 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/expat_erl.so
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/ezlib_drv.so
%%ICONV%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/iconv.so
%%JSON%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/jiffy.so
+%%JSON%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/jiffy.so
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/p1_sha.so
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/p1_tls_drv.so
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/p1_yaml.so