aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/folks/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
committerkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
commit77aa43669359356c3cab5041fdfcd537e1cabf09 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net-im/folks/Makefile
parent0fdeab2269ff13fcc43d09958d528d0ce5ec786a (diff)
downloadfreebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.gz
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.zst
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Diffstat (limited to 'net-im/folks/Makefile')
-rw-r--r--net-im/folks/Makefile40
1 files changed, 27 insertions, 13 deletions
diff --git a/net-im/folks/Makefile b/net-im/folks/Makefile
index fec8de126d2c..96abe0a587d6 100644
--- a/net-im/folks/Makefile
+++ b/net-im/folks/Makefile
@@ -1,14 +1,9 @@
-# New ports collection makefile for: folks
-# Date created: 23 July 2010
-# Whom: Koop Mast <kwm@FreeBSD.org>
-#
+# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/net-im/folks/Makefile,v 1.8 2010/10/26 08:47:55 kwm Exp $
-#
+# $MCom: ports/net-im/folks/Makefile,v 1.29 2012/08/17 19:06:45 kwm Exp $
PORTNAME= folks
-PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTVERSION= 0.7.0
CATEGORIES= net-im
MASTER_SITES= GNOME
@@ -17,17 +12,36 @@ COMMENT= library to aggregates people from multiple sources
BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala-vapigen \
g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-LIB_DEPENDS= gee.2:${PORTSDIR}/devel/libgee \
+LIB_DEPENDS= gee:${PORTSDIR}/devel/libgee06 \
telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib
-USE_BZIP2= yes
+CONFLICTS= folks-0.4.[0-9]*
+
+USE_XZ= yes
+USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack
+USE_GNOME= gnomehier gnomehack intlhack ltverhack evolutiondataserver3
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_SUB= VERSION=16
+PLIST_SUB= LIBVER=25 VERSION=33
+
+#OPTIONS= SOCIALWEB "Enable social web backend" on
+
+#.include <bsd.port.options.mk>
+
+#.if defined(WITH_SOCIALWEB)
+#LIB_DEPENDS+= socialweb.0:${PORTSDIR}/www/libsocialweb
+#CONFIGURE_ARGS+=--enable-libsocialweb-backend=yes
+#.else
+CONFIGURE_ARGS+=--enable-libsocialweb-backend=no
+#.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^build_old_libs=yes|build_old_libs=no|g' \
+ ${WRKDIR}/gnome-libtool
.include <bsd.port.mk>