aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/freetalk/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-06-23 04:34:50 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-06-23 04:34:50 +0800
commit4d777003ec0b41d8b9b7a83432d4200f5be8a054 (patch)
tree07b6452db4cda0960e1396f304e5ae69c40c4914 /net-im/freetalk/Makefile
parent134fd102f6762b5ef95cf20f692aaf810e793f67 (diff)
downloadfreebsd-ports-gnome-4d777003ec0b41d8b9b7a83432d4200f5be8a054.tar.gz
freebsd-ports-gnome-4d777003ec0b41d8b9b7a83432d4200f5be8a054.tar.zst
freebsd-ports-gnome-4d777003ec0b41d8b9b7a83432d4200f5be8a054.zip
Freetalk is a console based Jabber client. It features a readline interface
with completion of buddy names, commands, and even ordinary English words. Freetalk is extensible, configurable, and scriptable through a Guile interface. WWW: http://www.gnu.org/software/freetalk/ PR: 135897 Submitted by: Oleg Ginzburg <oleg.ginzburg@nevosoft.ru>
Diffstat (limited to 'net-im/freetalk/Makefile')
-rw-r--r--net-im/freetalk/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-im/freetalk/Makefile b/net-im/freetalk/Makefile
new file mode 100644
index 000000000000..0a63326c67f3
--- /dev/null
+++ b/net-im/freetalk/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: freetalk
+# Date created: 19 June 2009
+# Whom: Oleg Ginzburg (oleg.ginzburg@nevosoft.ru)
+#
+# $FreeBSD$
+#
+
+PORTNAME= freetalk
+PORTVERSION= 3.2
+CATEGORIES= net-im
+MASTER_SITES= SAVANNAH/freetalk \
+ http://itdev.spb.ru/mirror/
+
+MAINTAINER= oleg.ginzburg@nevosoft.ru
+COMMENT= GNU console based Jabber client
+
+LIB_DEPENDS= loudmouth-1.0:${PORTSDIR}/net-im/loudmouth
+BUILD_DEPENDS= guile>=1.8.6:${PORTSDIR}/lang/guile
+RUN_DEPENDS= guile>=1.8.6:${PORTSDIR}/lang/guile
+
+USE_GNOME= pkgconfig glib20
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+MAN1= freetalk.1
+INFO= freetalk
+
+OPTIONS= BEEP "Use beep program" off
+
+.if !defined(WITHOUT_NLS)
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_BEEP)
+RUN_DEPENDS+= ${LOCALBASE}/bin/beep:${PORTSDIR}/audio/beep
+.endif
+
+.include <bsd.port.mk>