aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/fugu/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-10-28 08:54:55 +0800
committerwill <will@FreeBSD.org>2000-10-28 08:54:55 +0800
commitc099e5add2d992499f19b36e15a7cf09b188f8a1 (patch)
tree5e4cc71936419aac7cb4fe8d53ae83c8e0d7540c /net-im/fugu/Makefile
parentc1c9c510815cdcf9fd0dfada11add45c3dfe6a7d (diff)
downloadfreebsd-ports-gnome-c099e5add2d992499f19b36e15a7cf09b188f8a1.tar.gz
freebsd-ports-gnome-c099e5add2d992499f19b36e15a7cf09b188f8a1.tar.zst
freebsd-ports-gnome-c099e5add2d992499f19b36e15a7cf09b188f8a1.zip
Add fugu 0.9.9e, a graphical client for the Gale secure instant messaging
system. PR: 20542 Submitted by: Peter Haight <peterh@sapros.com>
Diffstat (limited to 'net-im/fugu/Makefile')
-rw-r--r--net-im/fugu/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-im/fugu/Makefile b/net-im/fugu/Makefile
new file mode 100644
index 000000000000..e1d19b2a1555
--- /dev/null
+++ b/net-im/fugu/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: fugu
+# Date created: 11 August 2000
+# Whom: Peter Haight <peterh@sapros.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fugu
+PORTVERSION= 0.9.9e
+CATEGORIES= net python
+MASTER_SITES= http://fugu.gale.org/dist/
+
+MAINTAINER= peterh@sapros.com
+
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python
+RUN_DEPENDS+= ${LOCALBASE}/lib/python1.5/site-packages/Pmw:${PORTSDIR}/x11-toolkits/pmw
+
+PYTHON_VERSION= python1.5
+PYTHON_NO_DEPENDS= yes
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" INSTALL=""
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+.include <bsd.port.mk>