aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/gaim/Makefile
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>1999-04-19 08:15:51 +0800
committermharo <mharo@FreeBSD.org>1999-04-19 08:15:51 +0800
commit52d0493d1b596665be7250d11974740fed7c0afc (patch)
tree778b043432de4e02dc0e4cecdc9394e9a5ba743b /net-im/gaim/Makefile
parente071bbad38b7b299a87aeba11e7d0c4810687796 (diff)
downloadfreebsd-ports-gnome-52d0493d1b596665be7250d11974740fed7c0afc.tar.gz
freebsd-ports-gnome-52d0493d1b596665be7250d11974740fed7c0afc.tar.zst
freebsd-ports-gnome-52d0493d1b596665be7250d11974740fed7c0afc.zip
the GTK+ AOL Instant Messenger
PR: 10976 Submitted by: Jim Mock jim@corp.au.triax.com
Diffstat (limited to 'net-im/gaim/Makefile')
-rw-r--r--net-im/gaim/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-im/gaim/Makefile b/net-im/gaim/Makefile
new file mode 100644
index 000000000000..adbcbd2473b5
--- /dev/null
+++ b/net-im/gaim/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gaim
+# Version required: 0.1
+# Date created: 26 Mar 1999
+# Whom: Jim Mock <jim@phrantic.phear.net>
+#
+# $Id$
+#
+
+DISTNAME= gaim-19990311
+PKGNAME= gaim-0.1
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.marko.net/pub/gaim/ \
+ ftp://ftp.netmug.org/pub/FreeBSD/distfiles/
+
+MAINTAINER= jim@phrantic.phear.net
+
+LIB_DEPENDS= gtk12.1:${PORTSDIR}/x11-toolkits/gtk12
+
+ALL_TARGET= gaim
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk12-config"
+
+post-patch:
+ ${CP} ${FILESDIR}/logo.xpm ${WRKSRC}/pixmaps
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gaim ${PREFIX}/bin
+ @ ${MKDIR} ${PREFIX}/share/gaim/pixmaps && chmod a+rx ${PREFIX}/share/gaim/pixmaps
+ @ ${ECHO} "===> Installing pixmaps"
+ ${INSTALL_DATA} ${WRKSRC}/pixmaps/*.xpm ${PREFIX}/share/gaim/pixmaps
+
+.include <bsd.port.mk>