aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/gaim/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-06-03 01:52:38 +0800
committermarcus <marcus@FreeBSD.org>2004-06-03 01:52:38 +0800
commitc822e65d9c95b2185b983d7e3caa5e16dcc1f4b5 (patch)
tree2c4ed483c344d7cf74c715facc7fdb1a120f3a63 /net-im/gaim/Makefile
parent0b9a517c1cedb714cf8efe9dd58ae54ff5607b98 (diff)
downloadfreebsd-ports-gnome-c822e65d9c95b2185b983d7e3caa5e16dcc1f4b5.tar.gz
freebsd-ports-gnome-c822e65d9c95b2185b983d7e3caa5e16dcc1f4b5.tar.zst
freebsd-ports-gnome-c822e65d9c95b2185b983d7e3caa5e16dcc1f4b5.zip
Add optional SILC (Secure Internet Live Conference) support to Gaim.
PR: 67483 Submitted by: Evgueni V. Gavrilov <aquatique-ports@rambler.ru>
Diffstat (limited to 'net-im/gaim/Makefile')
-rw-r--r--net-im/gaim/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/net-im/gaim/Makefile b/net-im/gaim/Makefile
index 446eb5af5830..9baad7faba59 100644
--- a/net-im/gaim/Makefile
+++ b/net-im/gaim/Makefile
@@ -44,6 +44,14 @@ LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --disable-gnutls
.endif
+.if defined(WITH_SILC)
+LIB_DEPENDS+= silcclient-1.0.3:${PORTSDIR}/devel/silc-toolkit
+CONFIGURE_ARGS+= --with-silc-includes=${LOCALBASE}/include/silc
+PLIST_SUB+= SILC=""
+.else
+PLIST_SUB+= SILC="@comment "
+.endif
+
.if !defined(WITHOUT_NSS)
LIB_DEPENDS+= nss3:${PORTSDIR}/security/nss
CONFIGURE_ARGS+= --with-nspr-includes=${LOCALBASE}/include/nspr \
@@ -93,6 +101,7 @@ CONFIGURE_ARGS+= --disable-audio
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "Gaim has the following tunable option(s):"
+ @${ECHO_MSG} " WITH_SILC Build with Secure Internet Live Conferencing (SILC)"
@${ECHO_MSG} " WITHOUT_GTKSPELL Turns off spell checking"
@${ECHO_MSG} " WITHOUT_AUDIO Disable audio support"
@${ECHO_MSG} " WITH_GNUTLS Enable GNUTLS encryption support"
@@ -109,6 +118,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|-lpthreads|${PTHREAD_LIBS:S/"//g}|g' \
-e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g' \
+ -e 's|-lsilc -lsilcclient ${PTHREAD_LIBS} -ldl|-lsilc -lsilcclient ${PTHREAD_LIBS} -liconv|' \
-e 's|TCL_VERSION found but 8.3 required|TCL_VERSION found but ${_TCL_VER} required|g' \
-e 's|TCL_MINOR_VERSION" -ne 3|TCL_MINOR_VERSION" -ne ${_TCL_VER:E}|' \
${WRKSRC}/configure