aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/gicq/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-07-08 03:59:26 +0800
committersteve <steve@FreeBSD.org>2000-07-08 03:59:26 +0800
commit7879264d29ab2a706345ab21de9f9cd3139efc7a (patch)
tree0fb8a7b052271f54c6bdf617de3027472d998225 /net-im/gicq/Makefile
parentc691dd330a3da8e70bfc74508b9fb3b585604a4d (diff)
downloadfreebsd-ports-gnome-7879264d29ab2a706345ab21de9f9cd3139efc7a.tar.gz
freebsd-ports-gnome-7879264d29ab2a706345ab21de9f9cd3139efc7a.tar.zst
freebsd-ports-gnome-7879264d29ab2a706345ab21de9f9cd3139efc7a.zip
- Use GTK_CONFIG/GLIB_CONFIG instead of hardcoded gtk12-config/glib12-config
- Support CC/CFLAGS/PREIFX/LOCALBASE/X11BASE/MAKE/etc. properly PR: 19623 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'net-im/gicq/Makefile')
-rw-r--r--net-im/gicq/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/net-im/gicq/Makefile b/net-im/gicq/Makefile
index 5e1ee2216e59..e51496425fda 100644
--- a/net-im/gicq/Makefile
+++ b/net-im/gicq/Makefile
@@ -17,12 +17,14 @@ MAINTAINER= flathill@FreeBSD.org
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
icq.0:${PORTSDIR}/net/libicq
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-gnome --disable-nls
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"