aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/icmpchat/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-07-05 00:19:56 +0800
committerdanfe <danfe@FreeBSD.org>2007-07-05 00:19:56 +0800
commit07ca5a09cdf87c946cfbacb4e02b72be5a9a2402 (patch)
tree63cb2a84f4eacfad8b0ee935ef161356ede2bf56 /net-im/icmpchat/Makefile
parent317f61df3200d4981ffe01ec9682dac55f99a826 (diff)
downloadfreebsd-ports-gnome-07ca5a09cdf87c946cfbacb4e02b72be5a9a2402.tar.gz
freebsd-ports-gnome-07ca5a09cdf87c946cfbacb4e02b72be5a9a2402.tar.zst
freebsd-ports-gnome-07ca5a09cdf87c946cfbacb4e02b72be5a9a2402.zip
- Fix the build with GCC 4.2 [1]
- Kill EOF whitespace in pkg-descr - Utilize PORTDOCS macro in pkg-plist - Miscellaneous cleanups Reported by: pointyhat (logs) [1]
Diffstat (limited to 'net-im/icmpchat/Makefile')
-rw-r--r--net-im/icmpchat/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/net-im/icmpchat/Makefile b/net-im/icmpchat/Makefile
index 4ba770d27e6c..d21df3d4ee3b 100644
--- a/net-im/icmpchat/Makefile
+++ b/net-im/icmpchat/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: icmpchat
+# New ports collection makefile for: ICMP-Chat
# Date created: 8 October 2002
-# Whom: mwest@uct.ac.za
+# Whom: Matthew West <mwest@uct.ac.za>
#
# $FreeBSD$
#
@@ -12,17 +12,15 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= icmpchat
MAINTAINER= ports@FreeBSD.org
-COMMENT= Simple console-based chat that uses the ICMP protocol
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
+COMMENT= Simple console-based chat that uses ICMP protocol
pre-patch:
@${REINPLACE_CMD} -e 's|-O2 -Wall -pedantic|${CFLAGS}|;\
s|= gcc|?= gcc|;s|default|all|' ${WRKSRC}/Makefile
+# Fix for GCC 4.2
+ @${REINPLACE_CMD} -e \
+ 's|((uint8_t \*) data) +=|data += sizeof(uint8_t *) *|' \
+ ${WRKSRC}/sha256.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/icmpchat ${PREFIX}/bin
@@ -35,4 +33,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Todo ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>