aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/jabber-pyicq
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2008-01-15 21:11:29 +0800
committergarga <garga@FreeBSD.org>2008-01-15 21:11:29 +0800
commitd54f99c01d2524c5d4c4e07dbd9049b68a44ec30 (patch)
tree18eb5eec84079d1f5615a47962822e33d1b3c927 /net-im/jabber-pyicq
parentee7e0311041485e6a2ee0a9a6638834ae59bb2d2 (diff)
downloadfreebsd-ports-gnome-d54f99c01d2524c5d4c4e07dbd9049b68a44ec30.tar.gz
freebsd-ports-gnome-d54f99c01d2524c5d4c4e07dbd9049b68a44ec30.tar.zst
freebsd-ports-gnome-d54f99c01d2524c5d4c4e07dbd9049b68a44ec30.zip
- Fix UTF8 decoding errors [1]
- Fix startup script rcorder conflict with jabberd [2] - Bump PORTREVISION PR: ports/119619 [1] Submitted by: peter.schuller@infidyne.com [1] Guido Falsi <mad@madpilot.net. [2]
Diffstat (limited to 'net-im/jabber-pyicq')
-rw-r--r--net-im/jabber-pyicq/Makefile1
-rw-r--r--net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in1
-rw-r--r--net-im/jabber-pyicq/files/patch-src_legacy_icqt.py12
3 files changed, 13 insertions, 1 deletions
diff --git a/net-im/jabber-pyicq/Makefile b/net-im/jabber-pyicq/Makefile
index 3cf5838ee092..3e5b346186b3 100644
--- a/net-im/jabber-pyicq/Makefile
+++ b/net-im/jabber-pyicq/Makefile
@@ -6,6 +6,7 @@
PORTNAME= pyicq
PORTVERSION= 0.8a
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://www.blathersource.org/download.php/pyicq-t/
PKGNAMEPREFIX= jabber-
diff --git a/net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in b/net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in
index d2da9865b6c6..d5f9e0eb96e4 100644
--- a/net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in
+++ b/net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in
@@ -4,7 +4,6 @@
#
# PROVIDE: jabber_pyicq
# REQUIRE: DAEMON %%JABBER_REQUIRE%%
-# BEFORE: LOGIN
# KEYWORD: shutdown
#
# Define these jabber_pyicq_* variables in one of these files:
diff --git a/net-im/jabber-pyicq/files/patch-src_legacy_icqt.py b/net-im/jabber-pyicq/files/patch-src_legacy_icqt.py
new file mode 100644
index 000000000000..b16bf791a92d
--- /dev/null
+++ b/net-im/jabber-pyicq/files/patch-src_legacy_icqt.py
@@ -0,0 +1,12 @@
+--- src/legacy/icqt.py.orig 2008-01-09 04:58:42.000000000 +0100
++++ src/legacy/icqt.py 2008-01-13 08:06:51.411126927 +0100
+@@ -327,7 +327,8 @@
+ status = msg[0] + ": " + status
+
+ status = status.decode(charset, 'replace')
+- LogEvent(INFO, self.session.jabberID, "Away (%s, %s) message %s" % (charset, msg[0], status))
++ utfmsg = unicode(msg[0], errors='replace')
++ LogEvent(INFO, self.session.jabberID, "Away (%s, %s) message %s" % (charset, utfmsg[0], status))
+
+ if status == "Away" or status=="I am currently away from the computer." or status=="I am away from my computer right now.":
+ status = ""