aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/libjingle/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2008-09-07 11:05:20 +0800
committerlioux <lioux@FreeBSD.org>2008-09-07 11:05:20 +0800
commitc04aea7bdff0c481dc4dbb5dec5f0c0d2377ea21 (patch)
tree7ff3656375cfc2a219ef1d324cdc830aa7f6bc45 /net-im/libjingle/Makefile
parent62d861a7c4b2421deceddafb15576e4f9a665fe9 (diff)
downloadfreebsd-ports-gnome-c04aea7bdff0c481dc4dbb5dec5f0c0d2377ea21.tar.gz
freebsd-ports-gnome-c04aea7bdff0c481dc4dbb5dec5f0c0d2377ea21.tar.zst
freebsd-ports-gnome-c04aea7bdff0c481dc4dbb5dec5f0c0d2377ea21.zip
o Update to 0.4.0
o Fix BROKEN
Diffstat (limited to 'net-im/libjingle/Makefile')
-rw-r--r--net-im/libjingle/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/net-im/libjingle/Makefile b/net-im/libjingle/Makefile
index fa08796a2151..ecd92633eaad 100644
--- a/net-im/libjingle/Makefile
+++ b/net-im/libjingle/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libjingle
-PORTVERSION= 0.3.0
-PORTREVISION= 9
+PORTVERSION= 0.4.0
CATEGORIES= net-im
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,10 +14,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= lioux@FreeBSD.org
COMMENT= Google Talk's implementation of Jingle and Jingle-Audio
-BROKEN= does not compile with new speex
-DEPRECATED= Has been broken for more than 6 months
-EXPIRATION_DATE=2008-09-19
-
BUILD_DEPENDS= \
pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= \
@@ -27,13 +22,16 @@ LIB_DEPENDS= \
ortp.5:${PORTSDIR}/net/ortp \
expat.6:${PORTSDIR}/textproc/expat2
+CONFLICTS= krb4-[0-9]* krb5-[0-9]* heimdal-[0-9]* srp-[0-9]* \
+ clusterit-[0-9]* pcp-[0-9]* synce-librapi2-[0-9]*
+
USE_GNOME= glib20
USE_OPENSSL= yes
USE_AUTOTOOLS= libtool:15
USE_DOS2UNIX= README
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= \
+CONFIGURE_ARGS= \
--with-ilbc=${LOCALBASE} \
--with-speex=${LOCALBASE}
CONFIGURE_ENV= \
@@ -61,6 +59,8 @@ PORTDOCS= \
.endif
PLIST_FILES+= \
+ bin/login \
+ bin/pcp \
bin/relayserver \
bin/stunserver \
@@ -77,9 +77,7 @@ post-configure:
${CONFIGURE_WRKSRC}/config.h
# configure does not handle OSS support
# force oss
-# force ssl
.for feature in \
- FEATURE_ENABLE_SSL \
HAVE_SYS_SOUNDCARD_H
@${ECHO_CMD} \
'#define ${feature} 1' >> \