aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/licq-console/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-10-13 20:33:21 +0800
committerdinoex <dinoex@FreeBSD.org>2004-10-13 20:33:21 +0800
commit2f16aaf9a33ac77f40a25ede1a689c1e4d6df605 (patch)
tree05615558a9fcc48ad779aed5b0bb656d87917423 /net-im/licq-console/Makefile
parente99a173a56378726c05a3de1360bd5e3e5e0b5a1 (diff)
downloadfreebsd-ports-gnome-2f16aaf9a33ac77f40a25ede1a689c1e4d6df605.tar.gz
freebsd-ports-gnome-2f16aaf9a33ac77f40a25ede1a689c1e4d6df605.tar.zst
freebsd-ports-gnome-2f16aaf9a33ac77f40a25ede1a689c1e4d6df605.zip
- Fix gcc regression in STABLE
Diffstat (limited to 'net-im/licq-console/Makefile')
-rw-r--r--net-im/licq-console/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/net-im/licq-console/Makefile b/net-im/licq-console/Makefile
index cba731a9a398..26571163efd0 100644
--- a/net-im/licq-console/Makefile
+++ b/net-im/licq-console/Makefile
@@ -14,10 +14,19 @@ LIB_DEPENDS= cdk.4:${PORTSDIR}/devel/cdk
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Ncurses-based console plugin for Licq
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
LIBS="${PTHREAD_LIBS}"
LICQ_PORT?= net/licq
+CPPFLAGS+= ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.3
+.endif
+
.include "${PORTSDIR}/${LICQ_PORT}/Makefile.inc"
.include <bsd.port.post.mk>