aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/licq/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-01-31 12:48:15 +0800
committerdinoex <dinoex@FreeBSD.org>2003-01-31 12:48:15 +0800
commit852d99d2b61643e95eb64c84e111b2a5ba4bc87d (patch)
tree4b85ed037cde137d512ddc27c1f3a3944bff9c11 /net-im/licq/Makefile
parentb10e4b5ed4cf520970abc71c2d41f527a06003ac (diff)
downloadfreebsd-ports-gnome-852d99d2b61643e95eb64c84e111b2a5ba4bc87d.tar.gz
freebsd-ports-gnome-852d99d2b61643e95eb64c84e111b2a5ba4bc87d.tar.zst
freebsd-ports-gnome-852d99d2b61643e95eb64c84e111b2a5ba4bc87d.zip
- allows licq used as master-port. e.G. for socks.
- remove WITH_DANTE - fix SOCKS support to work with net/socks5-port. PR: 47636 Submitted by: lofi@lofi.dyndns.org
Diffstat (limited to 'net-im/licq/Makefile')
-rw-r--r--net-im/licq/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index 40963be65477..90485a9a74ac 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -15,26 +15,21 @@ PKGNAMESUFFIX= -socks
MAINTAINER= dinoex@FreeBSD.org
.if defined(WITH_SOCKS)
-.if defined(WITH_DANTE)
-LIB_DEPENDS= socks.1:${PORTSDIR}/net/dante
-.else
BUILD_DEPENDS= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
.endif
-.endif
USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
+INCDIR?= ${.CURDIR}
# workaround for installed autoconf/automake
CONFIGURE_ARGS+=--program-transform-name=s,y,y,
.if defined(WITH_SOCKS)
CONFIGURE_ARGS+=--enable-socks5
-.if defined(WITH_DANTE)
CONFIGURE_ARGS+=--with-socks5-inc=${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
.endif
-.endif
pre-configure:
@${MV} ${WRKSRC}/src/licq.conf.h ${WRKSRC}/src/licq.conf.h.sed
@@ -45,5 +40,5 @@ post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/Makefile.inc"
+.include "${INCDIR}/Makefile.inc"
.include <bsd.port.post.mk>