aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/mastodon
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2017-07-31 23:19:10 +0800
committerjrm <jrm@FreeBSD.org>2017-07-31 23:19:10 +0800
commite3e75df992146cc0d596515c536b83cac047bdac (patch)
treef4453c336ab0c2bb9037af895bb55170e4461a78 /net-im/mastodon
parentd4abd5f45fb4022ff81eec5a5668fee38c023df8 (diff)
downloadfreebsd-ports-gnome-e3e75df992146cc0d596515c536b83cac047bdac.tar.gz
freebsd-ports-gnome-e3e75df992146cc0d596515c536b83cac047bdac.tar.zst
freebsd-ports-gnome-e3e75df992146cc0d596515c536b83cac047bdac.zip
net-im/mastodon: Update to 1.5.0r3
Upstream changes: https://github.com/tootsuite/mastodon/releases/tag/v1.5.0rc3 Port changes: - remove dependency on www/npm
Diffstat (limited to 'net-im/mastodon')
-rw-r--r--net-im/mastodon/Makefile5
-rw-r--r--net-im/mastodon/distinfo6
-rw-r--r--net-im/mastodon/files/nginx-include.conf.in11
-rw-r--r--net-im/mastodon/files/patch-package.json15
-rw-r--r--net-im/mastodon/pkg-plist2
5 files changed, 28 insertions, 11 deletions
diff --git a/net-im/mastodon/Makefile b/net-im/mastodon/Makefile
index 75233abb42f0..800526550303 100644
--- a/net-im/mastodon/Makefile
+++ b/net-im/mastodon/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mastodon
DISTVERSIONPREFIX= v
-DISTVERSION= 1.5.0rc2
+DISTVERSION= 1.5.0rc3
CATEGORIES= net-im www
MAINTAINER= jrm@FreeBSD.org
@@ -13,8 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libidn2.so:dns/libidn2
RUN_DEPENDS= ffmpeg>0:multimedia/ffmpeg \
- libpqtypes>1.5.0:databases/libpqtypes \
- npm>=0:www/npm
+ libpqtypes>1.5.0:databases/libpqtypes
# Dependencies below match Gemfile layout
RUN_DEPENDS+= rubygem-pkg-config>=1.2.0:devel/rubygem-pkg-config
diff --git a/net-im/mastodon/distinfo b/net-im/mastodon/distinfo
index 385b2e904203..ec932aa774c0 100644
--- a/net-im/mastodon/distinfo
+++ b/net-im/mastodon/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501262123
-SHA256 (tootsuite-mastodon-v1.5.0rc2_GH0.tar.gz) = 6801d4f05a6e3de40b1f3bd7daa30d3165d09e256f94f2fbdca74a63cce985f7
-SIZE (tootsuite-mastodon-v1.5.0rc2_GH0.tar.gz) = 9986310
+TIMESTAMP = 1501512775
+SHA256 (tootsuite-mastodon-v1.5.0rc3_GH0.tar.gz) = 5c3f026e39af7c7cedd778c0c2f784acb9640e81879845050b3e79759ca923c3
+SIZE (tootsuite-mastodon-v1.5.0rc3_GH0.tar.gz) = 9987884
diff --git a/net-im/mastodon/files/nginx-include.conf.in b/net-im/mastodon/files/nginx-include.conf.in
index f6a212f87c9f..29d71f964cce 100644
--- a/net-im/mastodon/files/nginx-include.conf.in
+++ b/net-im/mastodon/files/nginx-include.conf.in
@@ -37,15 +37,16 @@ server {
try_files $uri @proxy;
}
- location ~ ^/(packs|system/media_attachments/files|system/accounts/avatars) {
+ location /sw.js {
+ add_header Cache-Control no-cache;
+ add_header Pragma "no-cache";
+ }
+
+ location ~ ^/(emoji|packs|system/accounts/avatars|system/media_attachments/files) {
add_header Cache-Control "public, max-age=31536000, immutable";
try_files $uri @proxy;
}
- location /sw.js {
- add_header Cache-Control no-cache;
- }
-
location @proxy {
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
diff --git a/net-im/mastodon/files/patch-package.json b/net-im/mastodon/files/patch-package.json
new file mode 100644
index 000000000000..229b5435f758
--- /dev/null
+++ b/net-im/mastodon/files/patch-package.json
@@ -0,0 +1,15 @@
+--- package.json.orig 2017-07-31 15:09:11 UTC
++++ package.json
+@@ -7,10 +7,9 @@
+ "build:production": "cross-env RAILS_ENV=production ./bin/webpack",
+ "manage:translations": "node ./config/webpack/translationRunner.js",
+ "start": "node ./streaming/index.js",
+- "test": "npm run test:lint && npm run test:mocha",
++ "test": "yarn run test:lint && yarn run test:mocha",
+ "test:lint": "eslint -c .eslintrc.yml --ext=js app/javascript/ config/webpack/ spec/javascript/ streaming/",
+- "test:mocha": "cross-env NODE_ENV=test mocha --require ./spec/javascript/setup.js --compilers js:babel-register ./spec/javascript/components/**/*.test.js",
+- "postinstall": "npm rebuild node-sass"
++ "test:mocha": "cross-env NODE_ENV=test mocha --require ./spec/javascript/setup.js --compilers js:babel-register ./spec/javascript/components/**/*.test.js"
+ },
+ "repository": {
+ "type": "git",
diff --git a/net-im/mastodon/pkg-plist b/net-im/mastodon/pkg-plist
index c6da84200cd0..397685690eac 100644
--- a/net-im/mastodon/pkg-plist
+++ b/net-im/mastodon/pkg-plist
@@ -499,6 +499,7 @@
%%WWWDIR%%/app/javascript/mastodon/features/compose/containers/upload_progress_container.js
%%WWWDIR%%/app/javascript/mastodon/features/compose/containers/warning_container.js
%%WWWDIR%%/app/javascript/mastodon/features/compose/index.js
+%%WWWDIR%%/app/javascript/mastodon/features/compose/util/counter.js
%%WWWDIR%%/app/javascript/mastodon/features/favourited_statuses/index.js
%%WWWDIR%%/app/javascript/mastodon/features/favourites/index.js
%%WWWDIR%%/app/javascript/mastodon/features/follow_requests/components/account_authorize.js
@@ -5397,6 +5398,7 @@
%%WWWDIR%%/spec/support/examples/lib/settings/settings_extended.rb
%%WWWDIR%%/spec/support/examples/models/concerns/account_avatar.rb
%%WWWDIR%%/spec/support/matchers/model/model_have_error_on_field.rb
+%%WWWDIR%%/spec/validators/status_length_validator_spec.rb
%%WWWDIR%%/spec/views/about/_contact.html.haml_spec.rb
%%WWWDIR%%/spec/views/about/show.html.haml_spec.rb
%%WWWDIR%%/spec/views/stream_entries/show.html.haml_spec.rb