aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/mastodon
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2017-09-16 20:01:42 +0800
committerjrm <jrm@FreeBSD.org>2017-09-16 20:01:42 +0800
commit332ccbad2f531e53c696b8250475bc6b035c7ca6 (patch)
tree7aada91966996faf0b1023343c149e073bb87c5f /net-im/mastodon
parent9cb9872decac749ac339fb674a3bf8c004db9e0d (diff)
downloadfreebsd-ports-gnome-332ccbad2f531e53c696b8250475bc6b035c7ca6.tar.gz
freebsd-ports-gnome-332ccbad2f531e53c696b8250475bc6b035c7ca6.tar.zst
freebsd-ports-gnome-332ccbad2f531e53c696b8250475bc6b035c7ca6.zip
net-im/mastodon: Fix issue running database migration script
Reported by: Marcin Cieslak <saper@saper.info>
Diffstat (limited to 'net-im/mastodon')
-rw-r--r--net-im/mastodon/Makefile9
-rw-r--r--net-im/mastodon/pkg-plist9
2 files changed, 13 insertions, 5 deletions
diff --git a/net-im/mastodon/Makefile b/net-im/mastodon/Makefile
index ebb441027ba2..c33e7905587a 100644
--- a/net-im/mastodon/Makefile
+++ b/net-im/mastodon/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mastodon
DISTVERSIONPREFIX= v
DISTVERSION= 1.6.0
+PORTREVISION= 1
CATEGORIES= net-im www
MAINTAINER= jrm@FreeBSD.org
@@ -140,13 +141,11 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/nginx-include.conf \
${STAGEDIR}${WWWDIR}/nginx-include.conf.sample
${INSTALL_DATA} ${WRKSRC}/.env.production.sample ${WRKSRC}/app.json \
- ${WRKSRC}/config.ru ${WRKSRC}/Gemfile \
- ${WRKSRC}/LICENSE ${WRKSRC}/package.json \
- ${WRKSRC}/Rakefile \
+ ${WRKSRC}/config.ru ${WRKSRC}/Gemfile ${WRKSRC}/LICENSE \
+ ${WRKSRC}/package.json ${WRKSRC}/Rakefile \
${STAGEDIR}${WWWDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} \
- "app config db lib log node_modules public spec \
- streaming vendor" \
+ "app bin config db lib log node_modules public spec streaming vendor" \
${STAGEDIR}${WWWDIR})
.include <bsd.port.pre.mk>
diff --git a/net-im/mastodon/pkg-plist b/net-im/mastodon/pkg-plist
index 2fefde1cf5f8..60cc4c4be1d8 100644
--- a/net-im/mastodon/pkg-plist
+++ b/net-im/mastodon/pkg-plist
@@ -139,6 +139,7 @@
@dir %%WWWDIR%%/app/workers/admin
@dir %%WWWDIR%%/app/workers/pubsubhubbub
@dir %%WWWDIR%%/app/workers/scheduler
+@dir %%WWWDIR%%/bin
@dir %%WWWDIR%%/config
@dir %%WWWDIR%%/config/environments
@dir %%WWWDIR%%/config/initializers
@@ -3250,6 +3251,14 @@
%%WWWDIR%%/app/workers/unfavourite_worker.rb
%%WWWDIR%%/app/workers/unmerge_worker.rb
%%WWWDIR%%/app/workers/web_push_notification_worker.rb
+%%WWWDIR%%/bin/bundle
+%%WWWDIR%%/bin/rails
+%%WWWDIR%%/bin/rake
+%%WWWDIR%%/bin/rspec
+%%WWWDIR%%/bin/setup
+%%WWWDIR%%/bin/update
+%%WWWDIR%%/bin/webpack
+%%WWWDIR%%/bin/webpack-dev-server
%%WWWDIR%%/config.ru
%%WWWDIR%%/config/application.rb
%%WWWDIR%%/config/boot.rb