aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/mcabber
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-09-03 15:07:24 +0800
committersat <sat@FreeBSD.org>2007-09-03 15:07:24 +0800
commitdb457b4c09f710d7250702c15b70735337fb2900 (patch)
tree3d521d0b4bc4f308c34d669d14ba296e49a68250 /net-im/mcabber
parentb46206554e3ca122bde0650b835c8a1459193c27 (diff)
downloadfreebsd-ports-gnome-db457b4c09f710d7250702c15b70735337fb2900.tar.gz
freebsd-ports-gnome-db457b4c09f710d7250702c15b70735337fb2900.tar.zst
freebsd-ports-gnome-db457b4c09f710d7250702c15b70735337fb2900.zip
- Optionify gpgme and aspell
Submitted by: Herbert J. Skuhra <h.skuhra@gmail.com>
Diffstat (limited to 'net-im/mcabber')
-rw-r--r--net-im/mcabber/Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/net-im/mcabber/Makefile b/net-im/mcabber/Makefile
index c19ef23c084f..48c034ee80f3 100644
--- a/net-im/mcabber/Makefile
+++ b/net-im/mcabber/Makefile
@@ -13,12 +13,9 @@ MASTER_SITES= http://www.lilotux.net/~mikael/mcabber/files/ CENKES
MAINTAINER= infofarmer@FreeBSD.org
COMMENT= Small Jabber console client
-LIB_DEPENDS= gpgme.17:${PORTSDIR}/security/gpgme \
- aspell.16:${PORTSDIR}/textproc/aspell
-
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-ssl --enable-aspell=yes
+CONFIGURE_ARGS= --with-ssl
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_OPENSSL= yes
USE_ICONV= yes
@@ -30,6 +27,9 @@ LDFLAGS= -L${LOCALBASE}/lib
MAN1= mcabber.1
+OPTIONS= GPGME "Use security/gpgme for PGP support" off \
+ ASPELL "Use textproc/aspell for spell checking" off
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 503000
@@ -40,6 +40,20 @@ BROKEN= Unicoded ncurses require 5.3
LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
.endif
+.if defined(WITH_GPGME)
+LIB_DEPENDS+= gpgme.17:${PORTSDIR}/security/gpgme
+CONFIGURE_ARGS+=--enable-gpgme
+.else
+CONFIGURE_ARGS+=--disable-gpgme
+.endif
+
+.if defined(WITH_ASPELL)
+LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
+CONFIGURE_ARGS+=--enable-aspell
+.else
+CONFIGURE_ARGS+=--disable-aspell
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|$$"$${datadir}"|"$${datadir}"|;s|-O2||'\
${WRKSRC}/configure ${WRKSRC}/*/configure