aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/mercury/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2007-01-06 07:26:46 +0800
committerthierry <thierry@FreeBSD.org>2007-01-06 07:26:46 +0800
commit8d4668cab43f5ef68f2a12c94c666eda2744c6d5 (patch)
tree7f8cf354c575b9536c02aa9816201c8119afa87d /net-im/mercury/Makefile
parent85281696aeb070b6a6f809da921bb5846515043c (diff)
downloadfreebsd-ports-gnome-8d4668cab43f5ef68f2a12c94c666eda2744c6d5.tar.gz
freebsd-ports-gnome-8d4668cab43f5ef68f2a12c94c666eda2744c6d5.tar.zst
freebsd-ports-gnome-8d4668cab43f5ef68f2a12c94c666eda2744c6d5.zip
- Upgrade to 1.9 RC1;
- Install a tray icon (from x11-toolkits/jdic).
Diffstat (limited to 'net-im/mercury/Makefile')
-rw-r--r--net-im/mercury/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/net-im/mercury/Makefile b/net-im/mercury/Makefile
index 06409aa5ad28..a33b37aebce9 100644
--- a/net-im/mercury/Makefile
+++ b/net-im/mercury/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= mercury
-DISTVERSION= 1.9B10
+DISTVERSION= 1.9RC1
PORTEPOCH= 6
CATEGORIES= net-im java
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://dknapp.ca/mirror/mercury/beta/ \
http://download.mercury.to/
MASTER_SITE_SUBDIR= thierry/${PORTNAME}
@@ -37,8 +37,10 @@ LINSTDIR?= share/Mercury
INSTDIR= ${PREFIX}/${LINSTDIR}
PLIST_SUB= INSTDIR=${LINSTDIR}
SUB_DIRS= lib resources
-DIR2PRUNE= resources/AppData/Games \
+DIR2PRUNE= resources/AppData/Backgrounds \
+ resources/AppData/Games \
resources/AppData/Plugins
+BADOSLIBS= linuxtray.jar wintray.jar
.if defined(WITH_VIDEO) # Experimental
VIDJAR= VidConf-libs.jar
@@ -49,6 +51,10 @@ PLIST_SUB+= VID="" VIDJAR="${VIDJAR}"
PLIST_SUB+= VID="@comment " VIDJAR=""
.endif
+.if !defined(WITHOUT_TRAY)
+LIB_DEPENDS+= tray.0:${PORTSDIR}/x11-toolkits/jdic
+.endif
+
do-install:
${MKDIR} ${INSTDIR}
${INSTALL_SCRIPT} ${WRKDIR}/${SUB_FILES} ${INSTDIR}
@@ -60,6 +66,7 @@ do-install:
.for ed in ${DIR2PRUNE}
${TOUCH} ${INSTDIR}/${ed}/.keep_me
.endfor
+ ${RM} ${BADOSLIBS:S|^|${INSTDIR}/lib/|}
.if defined(WITH_VIDEO)
${INSTALL_DATA} ${_DISTDIR}/${VIDJAR} ${INSTDIR}/lib
.endif