aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/mercury/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2007-02-14 06:59:42 +0800
committerthierry <thierry@FreeBSD.org>2007-02-14 06:59:42 +0800
commit050b39fbbe76b040692948557ff478ac59aca9a2 (patch)
treef625fc41b490a18b9b857fe1c4b48dfa786a3afb /net-im/mercury/Makefile
parent6e3ef7a734be032276a49b7e915766188bb669cc (diff)
downloadfreebsd-ports-gnome-050b39fbbe76b040692948557ff478ac59aca9a2.tar.gz
freebsd-ports-gnome-050b39fbbe76b040692948557ff478ac59aca9a2.tar.zst
freebsd-ports-gnome-050b39fbbe76b040692948557ff478ac59aca9a2.zip
Add a desktop entry.
Suggested by: Tjong-A-Hung <G.V.Tjong-A-Hung (at) student.TUDelft.NL>
Diffstat (limited to 'net-im/mercury/Makefile')
-rw-r--r--net-im/mercury/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/net-im/mercury/Makefile b/net-im/mercury/Makefile
index 15f9ea97199d..3c9db51b6247 100644
--- a/net-im/mercury/Makefile
+++ b/net-im/mercury/Makefile
@@ -41,6 +41,10 @@ DIR2PRUNE= resources/AppData/Backgrounds \
resources/AppData/Games \
resources/AppData/Plugins
+DESKTOP_ENTRIES="Mercury Messenger" "${COMMENT}" \
+ "${INSTDIR}/resources/online.png" \
+ "${SUB_FILES}" "" true
+
.if defined(WITH_VIDEO) # Experimental
VIDJAR= VidConf-libs.jar
EXTRACT_ONLY+= ${DISTNAME}${EXTRACT_SUFX}
@@ -60,6 +64,11 @@ WITHOUT_TRAY= yes
LIB_DEPENDS+= tray.0:${PORTSDIR}/x11-toolkits/jdic
.endif
+post-extract:
+ ${MKDIR} ${WRKDIR}/icons
+ cd ${WRKDIR}/icons && \
+ ${EXTRACT_CMD} ${WRKDIR}/resources/AppData/StatusIcons/MMercury.zip
+
do-install:
${MKDIR} ${INSTDIR}
${INSTALL_SCRIPT} ${WRKDIR}/${SUB_FILES} ${INSTDIR}
@@ -68,6 +77,7 @@ do-install:
cd ${WRKDIR} && ${FIND} ${sd} -type d -exec ${MKDIR} ${INSTDIR}/{} \;
cd ${WRKDIR} && ${FIND} ${sd} -type f -exec ${INSTALL_DATA} {} ${INSTDIR}/{} \;
.endfor
+ ${INSTALL_DATA} ${WRKDIR}/icons/online.png ${INSTDIR}/resources
.for ed in ${DIR2PRUNE}
${TOUCH} ${INSTDIR}/${ed}/.keep_me
.endfor