aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/mikutter
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2014-12-23 22:34:59 +0800
committertota <tota@FreeBSD.org>2014-12-23 22:34:59 +0800
commitdb388b4e0490f5d49a0e30411d83b8cce8fe6caf (patch)
treefaeee83aa5c288be6e5b3c4ca8b4eda409e7af0e /net-im/mikutter
parentee0bdd5d62701b940126cee3dca307b1807a8d09 (diff)
downloadfreebsd-ports-gnome-db388b4e0490f5d49a0e30411d83b8cce8fe6caf.tar.gz
freebsd-ports-gnome-db388b4e0490f5d49a0e30411d83b8cce8fe6caf.tar.zst
freebsd-ports-gnome-db388b4e0490f5d49a0e30411d83b8cce8fe6caf.zip
- Restrict Ruby version to 2.0.0 or later
- Remove dependency on devel/ruby-bsearch
Diffstat (limited to 'net-im/mikutter')
-rw-r--r--net-im/mikutter/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-im/mikutter/Makefile b/net-im/mikutter/Makefile
index b1a8b918625c..e2dd28fed427 100644
--- a/net-im/mikutter/Makefile
+++ b/net-im/mikutter/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mikutter
PORTVERSION= 3.1.0
+PORTREVISION= 1
CATEGORIES= net-im ruby
MASTER_SITES= http://mikutter.hachune.net/bin/ \
LOCAL
@@ -22,7 +23,6 @@ RUN_DEPENDS= rubygem-gtk2>=2.2.0:${PORTSDIR}/x11-toolkits/rubygem-gtk2 \
rubygem-json_pure>=1.8.1:${PORTSDIR}/devel/rubygem-json_pure \
rubygem-memoize>=1.3.1:${PORTSDIR}/devel/rubygem-memoize \
rubygem-oauth>=0.4.7:${PORTSDIR}/net/rubygem-oauth \
- ${RUBY_PKGNAMEPREFIX}bsearch>=1.5:${PORTSDIR}/devel/ruby-bsearch \
rubygem-typed-array>=0.1.2:${PORTSDIR}/devel/rubygem-typed-array \
rubygem-delayer>=0.0.2:${PORTSDIR}/devel/rubygem-delayer \
rubygem-gettext>=2.3.1:${PORTSDIR}/devel/rubygem-gettext \
@@ -33,6 +33,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_RUBY= yes
NO_BUILD= yes
+RUBY_REQUIRE= Ruby >= 200
RUBY_SHEBANG_FILES= mikutter.rb \
core/miku/miku.rb \
core/lib/piapro.rb \
@@ -50,6 +51,12 @@ NOTIFY_DESC= notify-send support
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+.include <bsd.port.pre.mk>
+
+.if !defined(RUBY_PROVIDED)
+IGNORE= requires Ruby 2.0.0 or later
+.endif
+
HTTPCLIENT_RUN_DEPENDS= rubygem-httpclient>=0:${PORTSDIR}/www/rubygem-httpclient
NOTIFY_RUN_DEPENDS= notify-send:${PORTSDIR}/devel/libnotify
@@ -72,4 +79,4 @@ x-generate-plist: stage
${FIND} ${STAGEDIR}${RUBY_SITELIBDIR}/mikutter -type f | ${SORT} | ${SED} -e 's,${STAGEDIR}${RUBY_SITELIBDIR},%%RUBY_SITELIBDIR%%,' >> pkg-plist.new
${ECHO} share/applications/mikutter.desktop >> pkg-plist.new
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>