aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/p5-Net-OSCAR
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-10-12 19:27:31 +0800
committermat <mat@FreeBSD.org>2004-10-12 19:27:31 +0800
commit5e3454aff8cf3a7e44ba562748954f16f46c3a39 (patch)
treeb69cdfc26d7a5a4b91b4bb0006dc8d63b14f565d /net-im/p5-Net-OSCAR
parent141aa0e7e55d0d0d32a260ba3187c7d004ad0f24 (diff)
downloadfreebsd-ports-gnome-5e3454aff8cf3a7e44ba562748954f16f46c3a39.tar.gz
freebsd-ports-gnome-5e3454aff8cf3a7e44ba562748954f16f46c3a39.tar.zst
freebsd-ports-gnome-5e3454aff8cf3a7e44ba562748954f16f46c3a39.zip
Add p5-Net-OSCAR 1.907, perl extension for the AOL Instant Messenger
OSCAR protocol. PR: ports/72103 Submitted by: Kelly Cochran <kcochran@trolans.net>
Diffstat (limited to 'net-im/p5-Net-OSCAR')
-rw-r--r--net-im/p5-Net-OSCAR/Makefile45
-rw-r--r--net-im/p5-Net-OSCAR/distinfo2
-rw-r--r--net-im/p5-Net-OSCAR/pkg-descr3
-rw-r--r--net-im/p5-Net-OSCAR/pkg-plist21
4 files changed, 71 insertions, 0 deletions
diff --git a/net-im/p5-Net-OSCAR/Makefile b/net-im/p5-Net-OSCAR/Makefile
new file mode 100644
index 000000000000..c80270e0b420
--- /dev/null
+++ b/net-im/p5-Net-OSCAR/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: p5-Net-OSCAR
+# Date created: 26 Sep 2004
+# Whom: Kelly Cochran <kcochran@trolans.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-OSCAR
+PORTVERSION= 1.907
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kcochran@trolans.net
+COMMENT= Perl extension for the AOL Instant Messenger OSCAR protocol
+
+PERL_MODBUILD= yes
+
+MAN3= Net::OSCAR.3 \
+ Net::OSCAR::Buddylist.3 \
+ Net::OSCAR::Callbacks.3 \
+ Net::OSCAR::Common.3 \
+ Net::OSCAR::Connection.3 \
+ Net::OSCAR::Connection::Chat.3 \
+ Net::OSCAR::Constants.3 \
+ Net::OSCAR::Screenname.3 \
+ Net::OSCAR::TLV.3 \
+ Net::OSCAR::Utility.3 \
+ Net::OSCAR::XML.3 \
+ Net::OSCAR::_BLInternal.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.if ${PERL_LEVEL} < 500601
+IGNORE= Requires perl 5.6.1+, install lang/perl5.8 and try again
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/p5-Net-OSCAR/distinfo b/net-im/p5-Net-OSCAR/distinfo
new file mode 100644
index 000000000000..690ec866f522
--- /dev/null
+++ b/net-im/p5-Net-OSCAR/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-OSCAR-1.907.tar.gz) = 361ca945dcdba75385868528ab6811bc
+SIZE (Net-OSCAR-1.907.tar.gz) = 104083
diff --git a/net-im/p5-Net-OSCAR/pkg-descr b/net-im/p5-Net-OSCAR/pkg-descr
new file mode 100644
index 000000000000..3740b741df7e
--- /dev/null
+++ b/net-im/p5-Net-OSCAR/pkg-descr
@@ -0,0 +1,3 @@
+This module implements an OO interface to the AIM OSCAR protocol.
+
+WWW: http://search.cpan.org/dist/Net-OSCAR/
diff --git a/net-im/p5-Net-OSCAR/pkg-plist b/net-im/p5-Net-OSCAR/pkg-plist
new file mode 100644
index 000000000000..b2fc025b73a9
--- /dev/null
+++ b/net-im/p5-Net-OSCAR/pkg-plist
@@ -0,0 +1,21 @@
+%%SITE_PERL%%/Net/OSCAR.pm
+%%SITE_PERL%%/Net/OSCAR/Buddylist.pm
+%%SITE_PERL%%/Net/OSCAR/Callbacks.pm
+%%SITE_PERL%%/Net/OSCAR/Common.pm
+%%SITE_PERL%%/Net/OSCAR/Connection.pm
+%%SITE_PERL%%/Net/OSCAR/Connection/Chat.pm
+%%SITE_PERL%%/Net/OSCAR/Constants.pm
+%%SITE_PERL%%/Net/OSCAR/Proxy.pm
+%%SITE_PERL%%/Net/OSCAR/Screenname.pm
+%%SITE_PERL%%/Net/OSCAR/TLV.pm
+%%SITE_PERL%%/Net/OSCAR/Utility.pm
+%%SITE_PERL%%/Net/OSCAR/XML.pm
+%%SITE_PERL%%/Net/OSCAR/XML/Protocol.dtd
+%%SITE_PERL%%/Net/OSCAR/XML/Protocol.parsed-xml
+%%SITE_PERL%%/Net/OSCAR/XML/Protocol.xml
+%%SITE_PERL%%/Net/OSCAR/XML/Template.pm
+%%SITE_PERL%%/Net/OSCAR/_BLInternal.pm
+@dirrm %%SITE_PERL%%/Net/OSCAR/XML
+@dirrm %%SITE_PERL%%/Net/OSCAR/Connection
+@dirrm %%SITE_PERL%%/Net/OSCAR
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true