aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/pidgin-facebookchat
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2008-07-27 10:51:08 +0800
committerahze <ahze@FreeBSD.org>2008-07-27 10:51:08 +0800
commit79c86882edca7030dc2cc37f043ab7022bb6a711 (patch)
treec263c85541c3d1c07fa5177a2b7b0327b62cff42 /net-im/pidgin-facebookchat
parent78c87b6e9fc32362f1996fa7e892025b8e797e14 (diff)
downloadfreebsd-ports-gnome-79c86882edca7030dc2cc37f043ab7022bb6a711.tar.gz
freebsd-ports-gnome-79c86882edca7030dc2cc37f043ab7022bb6a711.tar.zst
freebsd-ports-gnome-79c86882edca7030dc2cc37f043ab7022bb6a711.zip
This is a Facebook chat plugin for Pidgin and libpurple messengers.
It connects to the new Facebook Chat IM service without the need for an API key. Currently the plugin can: Log into the Facebook servers. Grab the buddy list. Send/receive messages. Add/remove friends. Rreceive notifications. Search for Facebook friends. Set your Facebook status. WWW: http://code.google.com/p/pidgin-facebookchat/ PR: ports/125997 Submitted by: ports at c0decafe.net <ports at c0decafe.net>
Diffstat (limited to 'net-im/pidgin-facebookchat')
-rw-r--r--net-im/pidgin-facebookchat/Makefile40
-rw-r--r--net-im/pidgin-facebookchat/distinfo3
-rw-r--r--net-im/pidgin-facebookchat/pkg-descr13
-rw-r--r--net-im/pidgin-facebookchat/pkg-plist5
4 files changed, 61 insertions, 0 deletions
diff --git a/net-im/pidgin-facebookchat/Makefile b/net-im/pidgin-facebookchat/Makefile
new file mode 100644
index 000000000000..b56abcb72655
--- /dev/null
+++ b/net-im/pidgin-facebookchat/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: pidgin-facebookchat
+# Date created: 2008-07-27
+# Whom: ports@c0decafe.net <ports@c0decafe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pidgin-facebookchat
+PORTVERSION= 1.30
+CATEGORIES= net-im
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= ${PROJECTHOST}-source-${PORTVERSION}
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Facebook Chat for Pidgin
+
+BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+
+PROJECTHOST= ${PORTNAME}
+WRKSRC= ${WRKDIR}
+USE_BZIP2= yes
+
+PIXMAPS_DIR= ${PREFIX}/share/pixmaps/pidgin/protocols
+
+do-patch:
+ ${REINPLACE_CMD} "s#i686-pc-freebsd6.0-gcc#${CC}#" ${WRKSRC}/Makefile
+
+do-build:
+ ${MAKE} -C ${WRKSRC} libfacebookbsd60.so
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/purple-2/ \
+ ${PIXMAPS_DIR}/16 ${PIXMAPS_DIR}/22 ${PIXMAPS_DIR}/48
+ ${INSTALL_DATA} ${WRKSRC}/libfacebook.so ${PREFIX}/lib/purple-2/
+ ${INSTALL_DATA} ${WRKSRC}/facebook16.png ${PIXMAPS_DIR}/16/facebook.png
+ ${INSTALL_DATA} ${WRKSRC}/facebook22.png ${PIXMAPS_DIR}/22/facebook.png
+ ${INSTALL_DATA} ${WRKSRC}/facebook48.png ${PIXMAPS_DIR}/48/facebook.png
+
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-facebookchat/distinfo b/net-im/pidgin-facebookchat/distinfo
new file mode 100644
index 000000000000..d77c145b4b68
--- /dev/null
+++ b/net-im/pidgin-facebookchat/distinfo
@@ -0,0 +1,3 @@
+MD5 (pidgin-facebookchat-source-1.30.tar.bz2) = 30e0bb74df881924d64a48c81a67f4a5
+SHA256 (pidgin-facebookchat-source-1.30.tar.bz2) = 7499bcb798de654da69e66e221f1a6f4fffbb5ca5c36e757299166b18137c074
+SIZE (pidgin-facebookchat-source-1.30.tar.bz2) = 32682
diff --git a/net-im/pidgin-facebookchat/pkg-descr b/net-im/pidgin-facebookchat/pkg-descr
new file mode 100644
index 000000000000..7a7cfa3669f9
--- /dev/null
+++ b/net-im/pidgin-facebookchat/pkg-descr
@@ -0,0 +1,13 @@
+This is a Facebook chat plugin for Pidgin and libpurple messengers.
+It connects to the new Facebook Chat IM service without the need for an API key.
+
+Currently the plugin can:
+Log into the Facebook servers.
+Grab the buddy list.
+Send/receive messages.
+Add/remove friends.
+Rreceive notifications.
+Search for Facebook friends.
+Set your Facebook status.
+
+WWW: http://code.google.com/p/pidgin-facebookchat/
diff --git a/net-im/pidgin-facebookchat/pkg-plist b/net-im/pidgin-facebookchat/pkg-plist
new file mode 100644
index 000000000000..50e3fdd9458c
--- /dev/null
+++ b/net-im/pidgin-facebookchat/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+lib/purple-2/libfacebook.so
+share/pixmaps/pidgin/protocols/16/facebook.png
+share/pixmaps/pidgin/protocols/22/facebook.png
+share/pixmaps/pidgin/protocols/48/facebook.png