aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/pidgin-guifications/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-08-20 12:48:36 +0800
committermarcus <marcus@FreeBSD.org>2004-08-20 12:48:36 +0800
commit254ec982e030beccc58d5353f882085fd6779b46 (patch)
treed85d9c71af23a6b8de9e4c819364793828b629b3 /net-im/pidgin-guifications/Makefile
parent413697ec48e2f1cd0f6690e5c16dd0ad38cc73c9 (diff)
downloadfreebsd-ports-gnome-254ec982e030beccc58d5353f882085fd6779b46.tar.gz
freebsd-ports-gnome-254ec982e030beccc58d5353f882085fd6779b46.tar.zst
freebsd-ports-gnome-254ec982e030beccc58d5353f882085fd6779b46.zip
Update to 2.0.
PR: 70651 Submitted by: maintainer
Diffstat (limited to 'net-im/pidgin-guifications/Makefile')
-rw-r--r--net-im/pidgin-guifications/Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/net-im/pidgin-guifications/Makefile b/net-im/pidgin-guifications/Makefile
index c2c167ddf6c9..14dbf35e1774 100644
--- a/net-im/pidgin-guifications/Makefile
+++ b/net-im/pidgin-guifications/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= guifications
-PORTVERSION= 1.10
-PORTREVISION= 1
+PORTVERSION= 2.0
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,5 +22,21 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gtk20
USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE}
+CONFIGURE_ENV+="CPPFLAGS=-I${LOCALBASE}/include" "LIBS=-L${LOCALBASE}/lib"
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-extract:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
+ -e 's#\([@(]\)GAIM_LIBDIR\([@)]\)#\1libdir\2#' \
+ -e 's#\([@(]\)GAIM_DATADIR\([@)]\)#\1datadir\2#'
.include <bsd.port.mk>