aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/py-jabber/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-01-13 17:21:34 +0800
committerijliao <ijliao@FreeBSD.org>2002-01-13 17:21:34 +0800
commit0936a32d4c2fe08f8ac54d4cc11ea4dbeac4c9a5 (patch)
tree1abf92430c437cfcde239d3e03f3957855894fe9 /net-im/py-jabber/Makefile
parentfcdcb4e928608a8cfd6301d8d556c42a30467dba (diff)
downloadfreebsd-ports-gnome-0936a32d4c2fe08f8ac54d4cc11ea4dbeac4c9a5.tar.gz
freebsd-ports-gnome-0936a32d4c2fe08f8ac54d4cc11ea4dbeac4c9a5.tar.zst
freebsd-ports-gnome-0936a32d4c2fe08f8ac54d4cc11ea4dbeac4c9a5.zip
add py-jabber 0.2
A Python Jabber library
Diffstat (limited to 'net-im/py-jabber/Makefile')
-rw-r--r--net-im/py-jabber/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-im/py-jabber/Makefile b/net-im/py-jabber/Makefile
new file mode 100644
index 000000000000..bc7452a0fffd
--- /dev/null
+++ b/net-im/py-jabber/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: py-jabber
+# Date created: Jan 13, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= jabber
+PORTVERSION= 0.2
+CATEGORIES= net python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= jabberpy
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= jabber.py-${PORTVERSION}-1
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyexpat.so:${PORTSDIR}/textproc/py-expat
+
+USE_PYTHON= yes
+
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build
+
+do-install:
+ @${SETUP_CMD} install
+
+.include <bsd.port.mk>