aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/tapioca-qt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-05-28 06:12:09 +0800
committermiwi <miwi@FreeBSD.org>2008-05-28 06:12:09 +0800
commitc486a60f04933c8227640b8faca0f931afbe32ef (patch)
tree827b6cdb889eaa1ccc00ca4598ae40dee1a42a50 /net-im/tapioca-qt
parent888eabb1977d6504355090d942963975c8d755ed (diff)
downloadfreebsd-ports-gnome-c486a60f04933c8227640b8faca0f931afbe32ef.tar.gz
freebsd-ports-gnome-c486a60f04933c8227640b8faca0f931afbe32ef.tar.zst
freebsd-ports-gnome-c486a60f04933c8227640b8faca0f931afbe32ef.zip
- Add common code to support for cmake based ports.
- Update devel/cmake to 2.6.0 (also fix ports/123092) - Use the new CMAKE build framework in all ports using cmake Approved by: portmgr (pav)
Diffstat (limited to 'net-im/tapioca-qt')
-rw-r--r--net-im/tapioca-qt/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/net-im/tapioca-qt/Makefile b/net-im/tapioca-qt/Makefile
index 3d2cd4723e0e..0501a8bc4079 100644
--- a/net-im/tapioca-qt/Makefile
+++ b/net-im/tapioca-qt/Makefile
@@ -6,6 +6,7 @@
PORTNAME= tapioca-qt
PORTVERSION= 0.14.1
+PORTREVISION=
CATEGORIES= net-im
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tapioca-voip
@@ -13,17 +14,12 @@ MASTER_SITE_SUBDIR= tapioca-voip
MAINTAINER= arved@FreeBSD.org
COMMENT= Framework for VoIP and IP applications
-BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
LIB_DEPENDS= QtTelepathyCore.0:${PORTSDIR}/net-im/telepathy-qt
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/build
-CMAKE?= ${LOCALBASE}/bin/cmake
-CMAKE_ARGS= -DCMAKE_BUILD_TYPE=DEBUG \
- -DCMAKE_INSTALL_PREFIX=${PREFIX} \
- -DCMAKE_C_COMPILER:STRING='${CC}' \
- -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
- -DCMAKE_CXX_COMPILER:STRING=${CXX} \
- -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}"
+
+USE_CMAKE= yes
+CMAKE_SOURCE_PATH= ..
USE_QT_VER= 4
QT_COMPONENTS= corelib qmake uic moc rcc
USE_LDCONFIG= yes
@@ -36,7 +32,4 @@ post-patch:
"s,$${LIB_INSTALL_DIR}/pkgconfig,data/pkgconfig,g"\
${WRKSRC}/../CMakeLists.txt
-do-configure:
- cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${CMAKE} ${CMAKE_ARGS} ..
-
.include <bsd.port.mk>